13 Replies Latest reply: Jul 6, 2012 2:25 PM by markk001walker
MistahTuck Level 1 Level 1



I upgraded to OS X 10.7 and am loving everything about it except for the ability to use Logic Pro 9 (9.0.0).



You can't use this version of the application Logic Pro 9 with this version of Mac OS X

You have Logic Pro 9 9.0.0.


I have been told that I can use the Logic Pro 9.1.4 Update (.dmg) which you can download from Apple Logic Support, although when I try to upgrade my I get this message:


An eligible Logic Pro version was not found in the Applications folder. This update requires Logic Pro version 9.0 or higher.


Wow, this is getting frustrating


PS - For anyone using a Apogee Duet like me, Apogee says on their website that the drivers should be available in August 2011.

Logic Pro, Mac OS X (10.7), Lion OS X
Solved by Blueberry on Jul 24, 2011 5:30 PM Solved

Search the forum! You either renamed or moved the Logic Pro application. Make sure it is named "Logic Pro" and located inside the Applications folder and the updater will detect it.

  • Blueberry Level 4 Level 4

    Search the forum! You either renamed or moved the Logic Pro application. Make sure it is named "Logic Pro" and located inside the Applications folder and the updater will detect it.

  • MistahTuck Level 1 Level 1

    Thanks very much! you were right. I must have renamed something before I tried to upgrade Logic.



  • marcoguitargeek Level 1 Level 1

    What if the Logic Pro app isnt located in your app folder?

  • Starzy1994 Level 1 Level 1

    Hi, I just upgraded to Lion and I can't use Logic at all. I tried looking for a software update for it but nothing came up. Any clues what I can do to make it work?

  • Blueberry Level 4 Level 4

    Look 3 posts up!


    Search the forum! You either renamed or moved the Logic Pro application. Make sure it is named "Logic Pro" and located inside the Applications folder and the updater will detect it.

  • bardange Level 1 Level 1

    Got the same problem. Upgraded to Lion. Logic (9.1.0) did not start. Downloaded the 9.1.5 update. Tried to install it: "an eligible Logic Pro version was not found..". Copied my Logic Studio to Applications/Logic Pro, however, still got the same message.

  • bardange Level 1 Level 1

    Thx, but i had already read the folder location and name trick: did not work.


    Got it fixed now by reinstalling Logic Studio 9 from DVD.

    That indeed creates the Logic Pro folder in Applications - something I had tried earlier by simply moving my existing Logic folder. This means the Logic 9.1.5 update does not simply check a folder name: there must be another entry/registry entry it checks. Reinstalling Logic Studio from scratch solved it for me.


    After reinstalling though Lion forgot my Focusrite Saffire 40, so no DAW. Solved that by reading a forum entry on beta drivers.


    So I am happy, music creation wise.


    Left for me is to solve the X Mail application saying it does not run under Lion!


    Model Name:          Mac mini

      Model Identifier:          Macmini3,1

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2.26 GHz

      Number of Processors:          1

      Total Number of Cores:          2

      L2 Cache:          3 MB

      Memory:          2 GB

      Bus Speed:          1.07 GHz

  • bardange Level 1 Level 1

    Mail problem solved.

    Lion has apparantly installed a new Mail app in Applications: I had moved my Snow L Mail to another folder.

    The new Mail starts, imports my messages.

    So happy again, thx everyone for several hints that lead me to a solution.

  • AnaMusic Level 9 Level 9

    OS X works as Expected if Applications remain where Originally Installed...


  • ALAN67920 Level 1 Level 1

    Thanks a lot from France.

  • OPQGIANT97 Level 1 Level 1

    I cant open my logic at all it just bounces onece and says this:

    Process:     Logic Pro [2764]
    Path:        /Users/USER/Desktop/Logic Pro.app/Contents/MacOS/Logic Pro
    Identifier:  com.apple.logic.pro
    Version:     9.1.6 (1700.43)
    Build Info:  Logic-17004300~2
    App Item ID: 459578486

    App External ID: 4083251

    Code Type:   X86 (Native)

    Parent Process:  launchd [159]


    Date/Time:   2012-03-22 17:41:24.882 -0600
    OS Version:  Mac OS X 10.7 (11A390)

    Report Version:  8


    Interval Since Last Report:      21228 sec
    Crashes Since Last Report:       22

    Per-App Interval Since Last Report:  9441 sec

    Per-App Crashes Since Last Report:   20

    Anonymous UUID:                  F616925E-9433-47CD-B669-F8174595D539


    Crashed Thread:  0


    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000


    Application Specific Information:



    Dyld Error Message:

      Library not loaded: /System/Library/PrivateFrameworks/ProKit.framework/Versions/A/ProKit

      Referenced from: /Users/USER/Desktop/Logic Pro.app/Contents/MacOS/Logic Pro

      Reason: image not found


    Binary Images:

    0x1000 -   0xbe3ffb  com.apple.logic.pro (9.1.6 - 1700.43) <24F0EC20-498D-6B24-193D-CAF74AA83457> /Users/USER/Desktop/Logic Pro.app/Contents/MacOS/Logic Pro

      0xe8d000 -   0xec0fe7  com.apple.music.apps.MAAudioUnitSupport (9.1.6 - 232.95) <0096DE94-CBD1-293B-6E75-72C64299119B> /Users/USER/Desktop/Logic Pro.app/Contents/Frameworks/MAAudioUnitSupport.framework/Versions/A/MAAudioUnit Support

      0xed7000 -   0xf08ff3  com.apple.musicaudiodataservices (1.1 - 250.78) <0C7147A5-C89A-8433-DCBD-99F6C2A0C889> /Users/USER/Desktop/Logic Pro.app/Contents/Frameworks/MAAssetSharing.framework/Versions/A/MAAssetSharing

      0xf1e000 -   0xf20fff  com.apple.ExceptionHandling (1.5 - 10) <CBB14B4E-835E-393B-B9B7-80E5A8B557B9> /System/Library/Frameworks/ExceptionHandling.framework/Versions/A/ExceptionHand ling

      0xf26000 -   0xf84ff3  com.apple.music.apps.MALoopManagement (9.1.6 - 218.80) <947687D9-EDE4-38BE-BBB3-F50FEE5E44E0> /Users/USER/Desktop/Logic Pro.app/Contents/Frameworks/MALoopManagement.framework/Versions/A/MALoopManagem ent

    0x8fe00000 - 0x8fe3320b  dyld (195 - ???) <33A6763E-295E-3FE1-9594-81B9E296BACC> /usr/lib/dyld

    0x9006a000 - 0x9006afff  com.apple.audio.units.AudioUnit (1.7 - 1.7) <4DCF450E-9748-3827-BF3C-EFEAF5E542C9> /System/Library/Frameworks/AudioUnit.framework/Versions/A/AudioUnit

    0x93f43000 - 0x93f50fff  libz.1.dylib (1.2.3 - compatibility 1.0.0) <4A5A98C6-C65E-37BD-BC0E-6E5C3BE74C60> /usr/lib/libz.1.dylib

    0x94368000 - 0x945deff7  com.apple.AddressBook.framework (5.1 - 1019) <7A59E861-A4C3-3BFA-8F8A-C054FDCFA3FD> /System/Library/Frameworks/AddressBook.framework/Versions/A/AddressBook

    0x954fc000 - 0x955ddfff  com.apple.DiscRecording (6.0 - 6000.2.11) <63D9A4D0-59F7-3716-8952-DB551677CE05> /System/Library/Frameworks/DiscRecording.framework/Versions/A/DiscRecording

    0x959f9000 - 0x95b4aff3  com.apple.audio.toolbox.AudioToolbox (1.7 - 1.7) <85616AA6-80D3-3ED1-8978-4B5080B8194B> /System/Library/Frameworks/AudioToolbox.framework/Versions/A/AudioToolbox

    0x9670e000 - 0x96716fff  com.apple.DiskArbitration (2.4 - 2.4) <B5535AAA-83EF-3E38-8D6E-EC383AE4926B> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration

    0x968fc000 - 0x9697fff7  com.apple.audio.CoreAudio (4.0.0 - 4.0.0) <4011757D-ED83-3C5B-92EA-F9563861B761> /System/Library/Frameworks/CoreAudio.framework/Versions/A/CoreAudio

    0x96b79000 - 0x96d4afff  com.apple.CoreFoundation (6.7 - 612.3) <D7532126-B03D-3671-8A2F-63EE67DE9832> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    0x97819000 - 0x9787bfff  com.apple.framework.IOKit (2.0 - ???) <27AD0C95-0621-39A8-BC64-5D8ACFDA64DF> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit

    0x98c46000 - 0x98c46fff  com.apple.Carbon (150 - 152) <32170CDA-C57B-32E0-91CF-E5BB31E5EA07> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon

    0x9a547000 - 0x9a7cdfe3  com.apple.QuickTime (7.7.1 - 2199) <61D753A4-D0BA-3BE4-8DD7-D7F886C509D7> /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime


    Model: MacBookPro7,1, BootROM MBP71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.62f6

    Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB

    Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533654465238432D47372020

    Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1067 MHz, 0x80AD, 0x484D54313235533654465238432D47372020

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 )

    Bluetooth: Version 2.5.0b13, 2 service, 12 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Serial ATA Device: Hitachi HTS545025B9SA02, 250.06 GB

    Serial ATA Device: MATSHITADVD-R   UJ-898

    USB Device: Built-in iSight, apple_vendor_id, 0x8507, 0x24600000 / 2

    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0x26100000 / 2

    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06600000 / 4

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8213, 0x06610000 / 7

    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0236, 0x06300000 / 3

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x06500000 / 2

  • groovy57 Level 1 Level 1

    My problem seems to be unsolveable then... instead of just upgrading my OS i have a new Macbook Pro... and logic express 9 won't install... It gets about 3/4 of the way through and just crashes. I have had the disc cleaned, upgraded my software (it didn't work even before i did this) and downloaded the upgrade for logic express 9 which won't install because i haven't installed logic yet. PLEASE HELP

  • markk001walker Level 1 Level 1

    It'a already in my applications foldier. How do I rename it?