Previous 1 2 3 Next 34 Replies Latest reply: Nov 20, 2011 1:54 PM by Laurie Pepper
softwater Level 5 Level 5 (5,370 points)

I posted this in the Safari forum with regards to disabling Resume, but I'm thinking an answer is more likely to be forthcoming here. Apologies for cross posting.

 

As people are discovering, you cant' disable Resume completely by unchecking the option Pref > General > Restore windows when quitting apps.

 

Even with this unchecked, Resume will still re-open any apps that you didn't manually quit before shutdown. In order to stop Lion re-opening all your running apps at Shutdown time, you have to uncheck this box:

 

resume2.png

 

However, you have to remember to do this EVERY time because the default behaviour is to have it checked (even if you unchecked it last time round). What I would like to know is how to change the default behaviour so this box comes up unchecked by default. Presumably there must be something I can do in Terminal that will change this? Anyone know?

 

Thanks in advance.


MacBook Pro 2.53GHz Intel Core 2 Duo, Mac OS X (10.7), 4GB 1067 MHz DDR3
  • EpsilonCygni Level 1 Level 1 (0 points)

    I need this too. App resume is a annoying.

  • R. Yannetta Level 1 Level 1 (0 points)

    If you're listening, Apple, please give us a way to permanently stop app resume globally in the next 10.7 patch.

  • JoeyR Level 6 Level 6 (8,275 points)

    I'll agree.  This needs to be a setting that we can enable or disable permanently.  If I wan't to sleep my system, I'll do that.  Typically when I restart my system for some reason, I want it to start clean.  Having this extra step each time I shutdown/restart, while minor... is annoying.

  • schumacc Level 1 Level 1 (10 points)

    I definitely agree. I came to this thread becuase I was searching on Google for a way to make the box be unchecked by default. Unchecking the system settings preference "Restore windows when quitting apps." should make the box be unchecked by default in my opinion, but whatever, as along as there is a way to change it I don't care how.  Apple, please give me this option. I know many others that want it that way as well but probably woud never post on a forum like this.

  • zander Level 1 Level 1 (0 points)

    Yes apple please help on this issue. I have the same complaints.

  • AnaMusic Level 9 Level 9 (57,060 points)

    Send Your Request to Apple via the Feedback Link:

     

    http://www.apple.com/feedback/

  • softwater Level 5 Level 5 (5,370 points)

    Elsewhere, it is being reported that you can permanently turn off app specific resume's like Safari and Preview with this command in Terminal

     

    defaults write com.apple.Preview ApplePersistenceIgnoreState YES

     

    or

     

    defaults write com.apple.Safari ApplePersistenceIgnoreState YES

     

    Worth doing if you're worried about websites or pdf popping back up unexpectedly when you don't want others to accidentally see what you were working on. If you want to restore it just type the same commands replacing the 'YES' with 'NO'

     

    However, I'm still looking for a terminal command that will turn off that checkbox though...

  • RonL Level 1 Level 1 (45 points)

    Ana... it won't do any good.

     

    Lots of us in the Appleseed program requested it for months and we weren't listened to... as is obvious.

     

    I can't imagine anyone would have a problem with Resume if, as long as we wanted to, we could completely deactivate it so we didn't have to always uncheck that annoying dialog box every time we rebooted or shutdown.

     

    For laptops where you may have to shutdown during a meeting or at an airport I can definitely see the advantage... but if you're working at a fixed site... it can be a real PITA.

  • SteveDSD Level 1 Level 1 (0 points)

    The problem I'm having with auto resume is that my iTunes library is on a NAS server, and every time that Lion does a kernel panic (yeah, it's done it a few times now) and then resumes the NAS mounts take up to a minute to happen and by that time iTunes has already decided to move my library onto the internal hard drive and I have to manually change it back to the NAS drive. 

     

    Very annoying considering I thought "Don't resume apps" would do just that!

  • coocooforcocoapuffs Level 3 Level 3 (845 points)
    The problem I'm having with auto resume is that my iTunes library is on a NAS server, and every time that Lion does a kernel panic (yeah, it's done it a few times now) and then resumes the NAS mounts take up to a minute to happen and by that time iTunes has already decided to move my library onto the internal hard drive and I have to manually change it back to the NAS drive. Very annoying considering I thought "Don't resume apps" would do just that!

    Steve, u might want to start a new thread for that problem. I am no itunes expert, but I do see here on our machines that when iTunes cannot find the current music library, it will issue a warning message, and it will not try to use another library that does exist on a local machine. I am running the lasted tunes in latest lion. cheers

  • K-M Level 1 Level 1 (0 points)

    Hi,

     

    I have the problem with iTunes that this is the only program that is startet every time I restart the Mac. All other programs, when I close them and uncheck the resume button on the shutdown message, do not reopen - only iTunes and I can not find a way to stop it from opening.

     

    Is there any way to find out why iTunes will open on any boot?

     

    Thanks

  • Ian Munday Level 1 Level 1 (15 points)

    You can disable Lion's resume functionality for all applications by going to System Preferences > General and unchecking the Restore windows when quitting and re-opening tabs option.

     

    - Ian

  • R. Yannetta Level 1 Level 1 (0 points)

    Yep, tried that. Unfortunately, Lion's apps dosen't seem to recognize that button exists since Resume is still enabled even when that box is unchecked.

     

    We need a global Resume ON/OFF button.

  • RonL Level 1 Level 1 (45 points)

    Ian,

     

    Not really.

     

    I was one of the people on the Appleseed team and they refused to change the appearance of the Resume dialog box when a person shuts down or reboots. And it is always checked... it is not possible to completely deactivate Resume.

     

    If you don't believe me simply leave some apps running when you shut down or reboot... they'll activate afterwards even if the preference is unchecked in System Preferences > General > "Restore..."

     

    Mail is usually running whenever I shut down or reboot and if I have it hidden or minimized then when I restart it 'slaps me in the face' and I have to dismiss it. Not good.

     

    This Apple knows best (like with the hiding of the Library) is not user friendly.

     

    Love Apple but sometimes they simply won't listen. (e.g. bud-ugly faux leather frame around iCal and Address Book with it two panes instead of the more useful three panes of SL).

Previous 1 2 3 Next