Previous 1 2 Next 20 Replies Latest reply: Jan 20, 2013 1:58 AM by DIESEL-X
DIESEL-X Level 1 (35 points)

Ok, here's the scenario.


The important thing to remember is that all was working well, as happy as 'larry the lamb'. Being that I was running Snow Leopard on my MacBook Pro 8,3 while accessing the internet through my iPhone 4 using it's Personal Hotspot feature (with iOS 4.2.5/4.2.6 running on the iPhone 4). Internet thethering worked beautifully between the MacBook Pro & iPhone4 and all was well. Some time before this I had used the Time Capsule's WiFi for internet access with NO problems (when I had dedicated broadband), but then switched to using mobile tethering (personal hotspot feature).


I then upgraded to OS X Lion 10.7 (11A511) the day it was released and did this over a friends fast internet connection using cable ethernet connection for quicker speed. While I was doing this, I also downloaded the latest iOS update for my iPhone 4 being iOS 4.3.4 (8K2).


Then the problems started.. I have not been able to connect to the iPhone's Personal Hotspot, nor the Time Capsule's WiFi and neither the Airport Express unit  (that plugs straight into the power socket). All three devices say 'connection timeout'. Resetting them either physically (reset button) or through the Airport Utility using an ethernet link (in the case of time capsule and airport express) make no difference.


I wish I never updated the iPhone iOS and previously put of updating it for the previous few updates because the tethering worked so well on it, therefore I would want to downgrade it to iOS 4.2.5/4.2.6 again (need to locate and re-download those two versions and accuire instructions - if anyone could help, would be very appreciated?).


Now this is the strange thing:- Although I cannot connect to the Apple Time Capsule, Apple Airport Express and iPhone Personal Hotspot (getting the 'connection timeout' error all the time), I am however able to connect to a non-Apple device Vodaphone 3G WiFi point. The Vodaphone 3G device is a 3G USB mobile dongle that is plugged into it's own dedicated small WiFi base station.


I am at a loss as to what is going on here?

MacBook Pro 17, Mac OS X (10.7), MacBook Pro 8,3 - Intel Core i7 2.2
  • AMMOCAN Level 1 (140 points)

    Have you tried deleting your network from all devices and then recreating it?

  • DIESEL-X Level 1 (35 points)

    Still problems...


    Did type a much more detailed lengthy reply, but unfortunately I temporarily lost connection (through ethernet cable link as the cable fell out) and surprisingly Safari in Lion completely and entirely navigated away from the 'reply' text box within the discussion thread to a completely new blank grey webpage saying only that there's no network connection. Usually the current webpage would just sit there until the user navigated away, therefore the detailed reply I typed out had completely vanished and was unfortunately presented with having to log back into my account with Apple ID for the forum - most frustrating! But in short, I'm still experiencing connection timeout problems using WiFi.

  • AMMOCAN Level 1 (140 points)

    I can totally understand your frustration and it ***** that you are having to experience it. I do know that for me yesterday the page was down all day. I could connect to any other website, but not the website. However, that doesn't solve your issue.


    I would advise you to break down your issue by each component and then work to solving them one at a time. I would first look into getting your machine connected to the internet first. If you have no way of getting it connected to the internet without using the other devices you mentioned at your home network, then go to a friends or to a place where you can test your machine's ability to stay connected to the internet through a different network. This will allow you to rule out the posibility that the issue is isolated to your machine/OS. If you find yourself still having connectivity issues, then work on solving them before introducing your other devices to the problem.


    Once and if you solve the issue with your machine I would then start looking into your home network and the devices you are using (i.e. Time Capsule, Airport, etc.) and be sure to check to see if you have the latest updates for them:


    For my own network, I use a modem (ARRIS) and router (Linksys E2000) and have had no issues with any of my machines (running Lion) or any of my other devices (i.e. iPhones, iPods, printers, etc.) connecting to my Wi-Fi network. I do however have family and friends that are using the same devices as you, but are not having any issues. However, none of them are using their iPhone's HotSpot and neither myself or anyone else has updated to iOS 4.3.5.


    I truly wish I could be me more of help, but the truth of the matter is when dealing with networks that deal with many different devices there are just so many variables that can be at play in regards to the issue, that you truly just have to take it one step at a time until you isolate the source of the issue at hand.

  • DIESEL-X Level 1 (35 points)

    Thanks for info.


    With reference to the iPhone's personal hotspot problem; the recent iOS v4.3.5 (8L1) update seems to have made the personal hotspot feature functional again from it's mysterious non-functioning behaviour after installing iOS 4.3.4 from before.


    OS X 10.7.1 update may have helped the Wifi conection in general, but I have yet to test the time capsule as I kind'of gave up on it and packed it away. Although the MBP is the new 2011 model, the airport express and time capsule are the old version-1 models (non dual-band) and I'm sorry to say that the time capsule's connection has never been the best for long-term consistency.


    The airport express now works, but can sometimes suddenly loose conection after some days for no reason and can't be seen/listed under the WiFi list when this happens, despite having SSID broadcasted. However in all fairness this may just be down to excessive interference in the area. Maybe at some point I'll invest in a brand new mullti-diversity, Dual-Band, 'N' standard WiFi router!

  • DIESEL-X Level 1 (35 points)

    Regrettably I jumped the gun there...  I'm still getting "A connection timeout occured" when tethering, via trying to connect using the iPhone's personal hotspot WiFi feature. Yet I can connect to the internet via the iPhone's USB-Sync cable no problem whatsoever, but if attempting to use the iPhone's WiFi hotspot then it's a no go.


    It's absolutely important to point out that it had worked flawlessly everytime when the iPhone was running iOS 4.2.5 (or 4.2.6). But the problems regarding the iPhone's personal hotspot only started after updating from iOS 4.2.5 (or 4.2.6). The MacBook Pro model 'MacBookPro8,3 early 2011' is running OS X Lion 10.7.1 and the iPhone is less than a meter away from the MacBook Pro to ensure signal strength and an improved chance over any possible interference. Also the connection timeout problem occured in OS X 10.6.8 as well as Lion 10.7 and 10.7.1


    Hate the thought of having to try and restore iPhone if Apple can't address this. The question arrises, why did the personal hotspot work flawlessly when running iOS 4.2.5 (or 4.2.6) and not after subsequent updates.

  • bmmms Level 1 (0 points)

    Hello. I have exactly the same problem here... is there any work around? The problem is identical connection from a MacBook w/ OS X Lion and from a Sony Vaio w/ Windows 7, IOS is the latest (4.3.5, 8L1).



  • DIESEL-X Level 1 (35 points)

    I can confirm my iPhone now currently shows the same version as yours at 4.3.5 (8L1) and no surprise, the problem still persists.


    I know not of any workaround and have tried everything I can think of, however I don't suspect any immediate solution due to the problem being mentioned frequently on the net. As stated, all was perfect in iOS version 4.2.5 (or 4.2.6) I never, not once experienced a single timeout problem when using the Personal hotspot feature on that iOS version.


    Amazingly Apple have allowed this problem to run-on for months now, approximately 5 months according to the first post date for the following thread created on the MacRumours site:-



    Probably one of the most frustrating problems, as I found the Personal WiFi Hotspot to be a valuable feature.


    Note: Initially I made the jump from the happy and working iOS 4.2.5 (or 4.2.6) to the troublesome iOS 4.3.4 (and then 4.3.5) at the exact same time I upgraded to Mac OS X 10.7 Lion; therefore initial impressions appeared to be that Lion was the cause of the timeout problems... hence this post being initially started in the Lion forum. However I later booted from an external OS X 10.6.8 Snow Leopard drive to test the personal WiFi hotspot feature (with iPhone iOS 4.3.5) and the problem still persited immediatelly implying to me that it was related to any iOS superseeding 4.2.5 (or 4.2.6), because iOS 4.2.5 (or 4.2.6) did not have this timeout problem when I was on OS X 10.6.8 and using personal WiFi hotspot from iPhone.


    On the other hand; the intermittent problem with occassional unreliable and non-consitent nature of WiFi connection being experienced with both my Time Capsule and Airport Express does appear to have happened since OS 10.7 and therefore is related to Lion.

  • bmmms Level 1 (0 points)

    Thanks for the information. I confirm that the problem seems to be related to IOS, as I have exactly the same problem connecting from a Mac OS X Lion as from a Windows 7... Isn't there a way to report this problem to Apple?

  • DIESEL-X Level 1 (35 points)

    I envisage Apple are fully aware of this and can't imagine that they are not in light of this problem being mentioned and reported in many places elswhere on the internet.


    Why they allow this problem to continue seems to defy believe and is beyond me. Although Apple have their ways and for the 'bigger picture' understandably usually keep us in the dark with regards to many issues, however in this case I believe nothing can justify why they should put us through so much pain regarding this issue. The 'personal hotspot' feature/setting is there to use - it previously did work absolutely flawelessly through WiFi (cable free with iPhone in Pocket - beautifull..!) - it still works if using the iPhone's USB Sync cable (while balancing the iPhone somewhere nearby while MacBook Pro is on your lap with cable connected)... however the WiFi connection type side of it is an absolute bag of hurt and there's really no need for it to still be not working months down the line. This problem gives a headache and I feel like I'm having my teeth pulled out.


    I've even upgraded properly to the developer's iOS 5 beta 6 in a vain attempt to see if the 'connection timeout' problem has been addressed and erradicated, but unfortunately I have to report that the problem is still there and even worse so as the MacBook Pro doesn't always see the iPhone 4 straight away over WiFi in order to attempt to connect to it. When it does see it in order to attempt connection, regrettably its still the same old 'connection timeout'. Therefore all I can say is that I truly whish I didn't update the iOS on my iPhone 4 because the personal WiFi hotspot feature is a feature I use the most and all those affected are truly suffering now.

  • malawton Level 1 (0 points)

    Its now Nov 10 is this problem still not fixed as I am having exactly same problem....hotspot connection to iphone 4 from MBP worked beautifully, have now installed Lion and iOS 5 and nothing happening - it wont find my iphone anymore unless i use the please as the previous poster said that this is a really good way of connecting out to the internet but its now turning me off apple products to be honest....arrgghhh

  • Hank in Boston Level 1 (0 points)

    Just found this fix - worked for me.  good luck. Note that the buttons on the screen are not actually green and red....


    go into Network > Advanced in System Preferences and set up a new account complete with password etc. To do this highlight your network name and hit the little button, reboot and then hit the little button and proceed to set up with WPA2 Personal. Also make sure only the first box beneath account is selected, 'Remember Networks etc' and others left unchecked.

  • wojuman Level 1 (0 points)

    I am reporting same problem. Macbook Pro Lion. iPhone 4 iOS 5. Tethering works on cable only. Wifi doesn't connect and Bluetooth hotspot connects but signals 'Connection Timout' and no traffic goes through. Previously it worked (before iPhone update). Cable connection for personal hotspot connects me to web and works flawlessly

  • Marcus Foth Level 1 (50 points)



    iPhone 4 with iOS 5.0.1, trying to use the Personal Hotspot feature and the wifi network it generates shows up in the list but selecting it always results in a "Connection timeout" error. I changed the password, removed the keychain items, removed and re-added the wifi entry in the Network pane in system preferences. I can connect just fine via USB and Bluetooth, it's just the wifi that's not letting me connect. Both MacBook Air and iPad can't connect.



  • Marcus Foth Level 1 (50 points)

    This issue is also being discussed in another discussion threat here:



    That suggestion worked for me:


    Settings>General>Reset>Reset Network Settings

Previous 1 2 Next