Previous 1 28 29 30 31 32 Next 667 Replies Latest reply: Aug 22, 2014 2:25 PM by MlchaelLAX Go to original post
  • ZX48 Level 1 (0 points)

    dimoe wrote:



    it would be great to have an installer package, even if everything works fine for three month now


    Except deep hibernation:

    The Mini goes to sleep, it turns off

    when I restart the Mini, it loads the SleepImage but this never ends (or get a kernel panic)

    I have to reboot hardly

    Hi Dimoe,


    See my reply Jaystrom above: What happens if you check the box in system preferences to ask for a password upon waking from sleep?


    I find it takes 5-10 seconds for the password insertion box to appear, with the colours wrong the first time, but not the second.

  • dimoe Level 1 (0 points)

    Hi ZX48,

    I used "DeepSleep" for two years now: great widget!


    The Mini always ask for a password after sleep or 5 minutes screensaver.

    With colours I have no problems,

    I always see the grey screen with the runing Clock (running at the beginning), then it freezes

    or I get a kernel panic

  • ZX48 Level 1 (0 points)

    Hi Dimoe. I note that you are running the i7 dual 2.7 with AMD graphics. I have the server with HD3000 so this may be the difference.


    Does normal sleep work OK for you?


    Normal sleep definitely was failing for me every second sleep. I've not tested Deepsleep modes for long enough to tell, but it seems to have changed the behaviour slightly.


    Note that I do not see the grey screen you mentioned. But then I have an SSD so perhaps the image loads in very quickly? I'll play around tomorrow and see what happens.


    My previous workaround was to just leave the mini on all the time (it is a "server" after all) and just set the display to sleep.

  • dimoe Level 1 (0 points)

    at the moment, I only turn  off the Mini or turn off the display


    but sometimes it's smart to save open windows/programms and work on later

  • newfoundglory Level 1 (0 points)

    I'm wondering, for images which arent cloned/restored from something like a 2011 MBP, if we're still missing certain system files and kexts. It was discovered that the Intel HD3000 kexts were not the correct versions, but I didnt check any of the others - so completely possible there are other kexts which need replacing/updating too.  The thing is, the version of 10.6.8 i'm running works fine; so kinda hard to check and test.


    I'll have to see if I can create a broken image at the weekend and compare all the kernel extension versions to a known working 10.6.8, and then create a pkg from that which can just be installed.

  • Bollogg Level 1 (10 points)



    I´ve installed SL 10.6.8 Server onto my Macmini 5.2. I made a installation with my MBA 2010 onto an external USB HDD, upgraded to 10.6.8 and cloned this 10.6.8 SLS system onto the Macmini HDD. Made the "LION kext" patch as instructed in this thread and reinstalled the 10.6.8 combo update. The Macmini runs satisfying besides one problem:


    DVD/CD sharing enabled on a MP 2008 with 10.6.8 client does not work on the Macmini 5.2 running 10.6.8 server (aswell tested with a 10.6.8 client install on the Macmini). DVD/CD sharing works fine on the MBA 2010 with 10.7.3.


    No firewall enabled on the Macmini and network shares are working without any issues.


    Any hints where to look for to fix DVD/CD sharing on the Macmini?

  • ZX48 Level 1 (0 points)

    I'm not sure what is going on here, but since doing two things: reinstalling the 4GB Apple RAM and installing DeepSleep my computer now behaves much better (i7 server)


    FYI, I first tried the DeepSleep options of: Regualr sleep (Deep), Widget sleep (quick), at which point I had the strange colours upon waking the display. This was also an intermittent sympton I'd seen over the past few weeks (so can't be directly related to the DepSleep widget itself). Now I have reverted back to the widget defaults: Regular sleep (Quick), Widget Sleep (Deep).


    If I use Option+Command+Eject (or the menu option), the system now sleeps absolutely fine. I have slept and woken it a doen tiems in a row with no problem (I have a password to be requested opon waking, and it takes 2-5 seconds or so for the password box to appear).


    BUT: The system does not sleep on its own! I have set it to sleep after 2 minutes. The display goes off at 1 minute, but after 3-4 minutes, the mini light is still fully lit, and pressing the keyboard wakes the display and gives me the password box. At least I can now force sleep when necessary.


    Any ideas?

  • Aescleal Level 1 (0 points)

    Any chance you are sharing internet?  That stops sleep, dead in it's tracks.  Found that out the hard way.


    Just something to look for.

  • ZX48 Level 1 (0 points)

    OK. I think sleep now works fine for me, but it was nothing to do with the DeepSleep widget. I restared with a different 10.6.8 installation and that now also behaves fine, so I think the issue was just the 8GB HyperX RAM (1866Mhz). I was having intermittent kernel panics anyway, so perhaps waking form sleep was a good trigger. I am now running with the original 4GB RAM and sleep behaves fine. The only thing of slight interest is that it takes my machine 4-5 minutes to go to sleep on its own even if I have 1 minute set under system prefs.


    Of course it coudl also be a 8GB issue.


    Regarding DeepSleep. This works but upon waking the pasword login screen is extremeley dark/black. It is barely visible at all. Solved by hitting Return three times (it then goes back into normal sleep) then I wake it up and the login/screen colours are normal. In neither situation do I see this grey screen with clock that you mention Dimoe.


    Dimoe, does your machine crash before or after the password screen?

  • ZX48 Level 1 (0 points)

    Aescleal wrote:


    Any chance you are sharing internet?  That stops sleep, dead in it's tracks.  Found that out the hard way.


    Just something to look for.

    Actually I am (to a firewire cable that is plugged in), but nothing is currently connected.


    This makes sense! The other 10.6.8 sleeps fine (well after an extra minute or two) but in fact this installation (my main one with the internet sharing on) still doesn't sleep on its own (but it will if I force it to sleep).


    Thanks for indicating the solution, Aescleal!

  • Aescleal Level 1 (0 points)

    My pleasure.  I ran into a sleep issue 2 months ago on a new 2011 Mini, and tried everything imaginable before learning it was just my own sharing settings that was causing the problem.  Just sharing the good news!



  • newfoundglory Level 1 (0 points)

    Well, as promised here it is...


    NOTE: Can ONLY be installed on 10.6.8 - also requires testing (from people on here) to verify that it works.


    What does the package do?

    1.  It runs launchctl to unload kextd

    2.  It deletes most of the kernel extensions from /System/Library/Extensions

    3.  It installs kexts into /System/Library/Extensions

    4.  It deletes the contents of /System/Library/Caches

    5.  It then requires a reboot (will be slow the first time after installing)


    Comes with no guarantee - please BACKUP before testing, and at worst expect to have to reinstall Mac OS X.


    Tested on a mac mini 2011 quad core server only.


    Please report back on how it goes for you.

  • dimoe Level 1 (0 points)

    Thank you!


    I tried it on my MacMini i7 2,7GHz with AMD-Graphic:

    I got some popups :BJUSBLoad.kext, and .kext of hp and lexmark are not loaded,

    So I took them out of Systems-Lib-Extensions


    It has much better speed of the internal disk: AJA-System Test now:100-110 - before 50-60 !


    but the geekbench (32bit) is worse: now 6600 - before 7000 !

    First Start: 6200, then I repaired disk permissions and cleaned caches, restarted and used geekbench again (two times)

  • dimoe Level 1 (0 points)

    I compared the new extensions with my old ones in my TimeMachine and marked newer and missing (red lines).

    Then I copied the newer back (as root user), repaired disk permissions and now I have

    a geekbench of 6950

    and AJA Test of 88 (first ifs fast, then it slows down)


    If someone knows wich kexts are needed, here they are

  • ZX48 Level 1 (0 points)

    Dimoe: How did you end up with kexts that are newer than the ones NFG has? i.e. in particular the ones dated 4th Feb 2012 and 26th Jan 2012?


    I thought the newest kexts would have dated (at the latest) to the release of the last SL Macs. Which would have been when the 10.6.8 combo was released mid 2011. What am I not understanding?

Previous 1 28 29 30 31 32 Next