Previous 1 2 Next 25 Replies Latest reply: Jan 22, 2013 11:57 AM by donfromchalampe
BallisticJack Level 1 (0 points)

I decided to go with a fresh install of Lion at the weekend on my iMac and Mac Mini and came across a strange bug...

Basically, when changing sharing settings it seems to 'corrupt' a user's preferences. This 'corruption' is evidenced by not persisting (after a reboot) say the removal of a dock item or changing what the sidebar displays in Finder. If I make a change like this (or a series of changes) and restart my machine the change(s) made since last restart are reverted.

I came across this issue when undertaking the following:


  • On iMac: Shared out an attached hard drive that I use for Time Machine (so I could use the same drive for Time Machine on my Mac Mini)
  • On iMac: Changed the permissions on the 'user' folder so that Mac Mini could see it.
  • On Mac Mini: Changed the permissions on the 'user' folder so that iMac could see it.
  • On Mac Mini: Enabled screen sharing.

The above actions resulted on the 'corruption' of the user preference file(s) on both the iMac and Mac Mini.


I found nothing on Google and as I couldn't sort I re-installed Lion and performed the following actions:


  • On Mac Mini - Changed the permissions on the 'user' folder so that iMac could see it.
  • On Mac Mini - Enabled screen sharing.


Again, the above actions resulted on the 'corruption' of the user preference file(s) on the Mac Mini.

I then tried creating a new user account and making the desired permission/screen sharing changes. More specifcally, I did the following on a clean Lion install:


  1. On Mac Mini: Set Up a NEW Administrator Account.
  2. On Mac Mini: Reboot.
  3. On Mac Mini: Log In with NEW Administrator Account.
  4. On Mac Mini: Changed the permissions on both 'user' folders (DEFAULT & NEW Administrator) so that iMac could see it.
  5. On Mac Mini: Removed 4 unwanted icons from the dock.
  6. On Mac Mini: Reboot
  7. On Mac Mini: Log In with NEW Administrator Account to find that previoulsy deleted icons had reappeared.
  8. On Mac Mini: Reboot
  9. On Mac Mini: Log In with DEFAULT Administrator Account.
  10. On Mac Mini: Removed 4 unwanted icons from the dock.
  11. On Mac Mini: Reboot
  12. On Mac Mini: Log In with DEFAULT Administrator Account to find that previously deleted icons had reappeared.

Sorry for the long post but the devil is in the detail. If anyone has any ideas as to how to solve or is able to replicate the problem I'd been keen to know.

iMac, Mac OS X (10.7)
  • WillytheKidd Level 1 (25 points)

    I have the exact same problem.  None of the preferences save.  If I click the box in the general tab to turn off restore windows, and close preferences re open preferences the box is checked again.  If I set a wall paper restart the machine, the wall  paper reverts to the default wall paper.  Anything removed from the dock re appears when machine is restarted. 


    If there is a fix I would really be happy to know.

  • johncocci Level 1 (0 points)

    Having gthe same issue as well after a fresh install of Lion. Was having some major MobileME sync issues as well, but I just disabled that for now seeing that its all going to change once ICloud comes out. The issue is only happening with one of the user accoutns though. My user account is just fines, MobileME syncs just fine and all preferences wsave and what not, but my wife's user account does not. I deleted everything in her preferences folder and that seemed to work for a bit, but eventually it stopped working again.I guess we have found a bug in the new version.

  • rhysj Level 1 (0 points)

    Am having the same problems, all starting from when I tried to set up file sharing between two machines on the network at home (latest gen MacBook Air and latest gen MacBook Pro). I tried everything I could manually to get it to work and thought I'd caused the problems, so I was about to do a clean install of Lion or Snow Leopard on both to fix the permissions until I found this post.


    Here are most of the things I've experienced so far:










    I'm now thinking it will be easier to just wait for an update to Lion, and in the meantime just keep everything running and transfer data the old fashioned physical way. Device backups will just have to wait...

  • BallisticJack Level 1 (0 points)

    Any news yet on a potential fix for this issue? Has anyone managed to work around the problem?

  • smokesausage Level 1 (0 points)

    I'm having the same problem. Lion won't save my preferences. Id could save them a couple of days ago, but today when i wanted to change some settings it stopped saving them.


    - Reboot, no fix

    - Repair disc permissions, no fix

    - Create second useraccount, same problem


    what to do, i'd love a fix

  • kwik.3.mart Level 1 (0 points)

    Hey guys,


    I tried something and it did work for a while, but then went back to normal. See if you have any luck with it, and let us know if it worked.


    1) Inserted Mac OS Installation CD

    2) Booted up with disk (Hold C Key at startup)

    3) Chose language at startup screen

    4) Went to menu and under Utilities clicked on Reset Password (Utility)

    5) Went to the bottom of the Reset Password Utility and clicked Reset Home Directory Permissions

    6) Restarted


    See if it works guys, and get back to us on your success/failure!



    "If you have modified the contents of the folder /Library/Receipts, the Repair Permissions feature won't work as expected. Repairing permissions requires receipts for Apple-installed software. Additionally, the utilities only repair Apple-installed software and folders (which does not include users' home folders).

    Note: In Mac OS X 10.5 and later, while started up ("booted") from the Mac OS X 10.5 installation disc, a user's home directory permissions can be reset using the Reset Password utility."

  • Joe Fitzgerald Level 1 (5 points)

    Is there a picture of OS X Lion on Fail Blog yet? There needs to be.

  • Joe Fitzgerald Level 1 (5 points)

    I may have found a solution to your problem. It's similar to what was happening to my machine. You can view it here:

  • Toby Fulton Level 1 (15 points)

    I was having the same problems.  As discussed in the link provided above I the used the BatChmod program to reset the permissions on my Home folder (and all enclosed folders) and seems to have fixed the issue.  System prefs now saving and MobileMe now working again.


    I used BatChmod to select my Home folder and then set Owner: as my username with RWX, Group: as 'staff' with RWX and Everyone: with no access.  Tick the 'Change ownership and privileges', Clear ACLs and 'Unlock' options.  Also tick the 'Apply to enclosed folders and files' option.  It was super fast so it didnt' think it was doing anything - but after I rebooted everything was working fine!!

  • smokesausage Level 1 (0 points)

    Not working for me. I changed settings as explained, it did nothing for me.

  • kwik.3.mart Level 1 (0 points)

    Hi everyone, I have found a solution. This worked for me:


    1) Create a new user account. Make sure it has a desireable name, otherwise you're going to want to change it later, and that will cause permission issues. (check if preferences are saving in this temporary new account, if not, I can't help you.)

    2) Transfer all the files you want to keep by putting them in the SHARED folder.

    3) Change permissions to the folders and files in your shared folder by right clicking and clicking on GET INFO. Then go to the very bottom of the popup menu and unlock the picture of the lock. Next change permissions so that your new account will have permission to view the files. You might have to add your new account to the list by pressing the plus button, or simply allow staff the read and right, or just let everyone read and right. Next click on the gear menu (the one with the little gear on it.) and click on APPLY TO ENCLOSED ITEMS.

    4) Go to your new user account and take the things in the shared folder and put them where you had them in your older account.


    Now you have a new user with the files you want, the permissions right, and preferences will save!

    I really really really hope this works for you. I know how extremely frustrating it was. It worked for me, and I am so relieved now.

  • lotusone Level 1 (0 points)

    This was driving me *crazy*. Then I found this (


         In Terminal, try removing ACLs from your home folder:

              sudo chmod -RN ~


    It worked for me.



  • hornet330 Level 1 (0 points)

    Holly ****!!! Thank you so much lotusone!! This issue was driving me crazy too...In four years using hackintosh with Tiger, Leopard and SL I had never experienced a Failure that Big like this with my Mac Mini (mid 2011). Was totally freaking out!. I used this commands in terminal (within SO, i havent used any kind of DVD or restore partition).


    sudo chmod -RN ~




    sudo chown -R `id -un` ~


    Watch the blanks! I really hope this works for all of you.

  • BallisticJack Level 1 (0 points)

    For those of you interested...10.7.1 didn't fix my issue. Now trying Joe Fitzgeral's suggested solution.

Previous 1 2 Next