13 Replies Latest reply: Dec 23, 2012 6:36 AM by gusgrave
gusgrave Level 1 (25 points)

Hello again fellow Mac users!


Last time I posted regarding this subject I was "fairly" new to the Mac system, now I have more time behind the keyboard and have, in general, come to accept Mac as far superior to PC.


Though I still have one nagging pain that I cannot understand or solve. I have EXTREME problems with my home network and connectivity with my router. Every time I think I have found a working solution the problem re-emerges and I cannot solve it permanently. What I am curious to find out is if there is anyone that have figured out what the actual problem is, why so many are experiencing this problem?


I have been sweeping the net for any and every solution and I have found tons of them, though no solution is permanent and no solution is universal. No solution I have found has solved the problem for everyone.


At home I have a D-Link DIR-655 router and for some reason I am experiencing connection problems with my MBP.


If I manage to connect, saving the network with password, it will connect, reconnect, wake from sleep and connect, come home from work and connect..... In other words, work perfectly. But this is always only temporary, ranging from a day up to two weeks. Then one day, the connection will timeout and then I cannot connect. Using the same method, it will find the network and timeout, then I have to restart AirPort in order for the network to show up in the list again. If I try to reconnect AirPort will prompt me for my password even though it is already stored on my MBP. If it continues to show up in the list it still wont connect automatically even though it is the highest priority network in my wireless list, as if it is a new network which is not recognized. THough I have not reset, turned of or changed any settings on the router.


If I use the Network preferences window to try to connect when this problem occurs I still have to fill out my password, the colored ball shows up for a few seconds and then a new pop-up prompting me for the password again. It does not matter how many times I try, I never get through.


As I mentioned, I have found several solutions, none of which is permanent. Everything from restarting to actually changing the wifi card and moving cables around in the antenna... They span from 2007 to present day over different OS X versions and AirPort versions.


I do not believe that this problem is hardware related because this would mean a ton of malfunctioning macs and/or routers. It also seems unlikely since the router is working flawlessly with a PS3, with an iPhone, with a Nokia phone, with a Sony VAIO PC, with a WD MyBookWorld NAS, with an old PC running both Windows XP and Ubuntu, as well as any and every other WiFi enabled product that has ever entered our apartment.


On the other side of the coin, the Mac always connects to any new wireless network I have encountered (except my own). I used to have a connection problem but this was caused by a lingering IP filter from a idiotic PeerGuardian install and was solved by a complete format and re-install. I travel a lot with work and have not encountered any connection problems at any hotel on any continent. I also connect perfectly at work, at my mothers, my brothers and my fathers, all running different routers and different ISP:s.


Since it works flawlessly when I actually get it connected at home, I cannot understand why (as I have seen suggested) D-Link and Mac would be incompatible? Since nothing is changed at home, with the router or the environment, I do not understand why it would work perfectly one day and not at all another day if this was compatibility related, then it should be related to settings or environment, or not work at all right?


The problem is that the behavior is completely erratic. Deleting all network related information works sometimes but not all the time, manually connecting to the router instead of using DHCP works sometimes but not all of the time, verifying disk permissions and repairing airport related problems worked one or twice when problems where found but not every time and does not solve the problem permanently, safe reboots, clearing PRAM and so fort works sometimes but not always, switching channels work sometimes but not always, rebooting the router while hardwired to the mac (ethernet) works sometimes but not always, switching channels works sometimes, sometimes it just starts working without me doing anything and works for a couple of days just to break again. Switching IPv6 configuration to Off works sometimes and then stops working again. Changing settings works sometimes just to fail later...


It seems that switching router to another brand (NetGear or Apples AirPort seems to be the favorites) solves the problem, but when my current setup is working it is working flawlessly so I refuse to believe that this is a problem that should not be solvable.


I'm getting tired of finding a working solution just to be dumbstruck when it breaks again after a few days so I thought I'd give this one last try before finally give up and change to another router.


Is there anyone that has the same setup as I have at home that have experienced problems similar to mine and actually managed to find a working solution that solves this problem permanently? In that case, how on earth did you solve the problem?


Best regards


MacBook Pro, Mac OS X (10.6.3), 2.53 GHz Intel Core 2 Duo, 4 GB 1067 Mhz DDR3
  • gusgrave Level 1 (25 points)

    Not a solution, but I still would like to highlight how extreemely strange I find this behaviour!


    I am getting more and more convinced that, at lest some of, the issues are software related. Eventhough the network is on top of my list of prefered networks, OS X does not recognize it and does not connect to it! Even though it is present in the airport pulldown menue with full strength it does not even try to connect, it only promts the "None of your prefered networks..." bla bla bla. If I choose to connect manually, my password is already there, if the connect fails and I turn airport off and on again, it no longer finds my password, although it is already stored in KeyChain, twise (System and login).


    If I delete every trace of my network from my computer, restart and then try 3 or 4 times, I can usually get my computer to connect to the WiFi, what I have done now is install Caffeine and just manually dim the display. Because as long as I do not shut my computer of/let it go to sleep or manually disconnect, my WiFi is stable and everlasting. It hasn't lost connection or failed in 48 hours. Though I know that once I bring the computer to work next time, the process will have to start over...


    I really believe that the issues are somehow software related

  • PaddlinLou Level 1 (0 points)

    I'm having the same problems and it just started a few days ago. Prior to that I've had no problems.  Sometimes if I restart my MAC I can connect again without a problem... very frustrating.

  • gusgrave Level 1 (25 points)

    This morning, no WiFi again. I deleted everything, reset PRAM, restarted and still 'Connection Timeot'.


    Though once I got to the office, my co-worker (running 10.5.X) on his MBP had problems accessing Spotify and e-mail accounts. Everything was moving extremely slow, so we checked his network settings and found that for some reason his WiFi had priority over his Ethernet and because of this was running over a poor AirPort WiFi conection onstead of through the 100/100 Mbits ethernet. I checked my own network settings and found that my order had been magically altered as well, so I put the AirPort on top of the preffered order of connections and when I got back home this evening, I got connected to my WiFi on the first try!


    I know this is not a permanent fix since I've done this countless times before, but I still get extatic when it actually works as intended. So if you haven't already, see if the connection method order has changed for you as well since the last update, try putting AirPort on top of the list, apply and start airport.


    I'm just curious to see of this will be a temporary fix for you as well? Then I atleast have something to go on, because right now I'm just stabbing at anything that works since the problems are so inconsistent!


    Best regards

  • gusgrave Level 1 (25 points)

    As expected, I close the lid on the MBP and opened it again once the sleep mode had been activated, and voila, no WiFi connection again.

  • gusgrave Level 1 (25 points)

    I'm still baffled and still no closer to figuring this out, though I finnaly found something that might be an issue and this would seem logical.


    I checked the Console Messages after the last fail to connect and this is what I found:


    8/1/11 23:25:03           Apple80211Agent[3125]          Error joining network: Connection timeout (-3905 timeout connecting)


    Which lead me to this forum thread where someone observed issues with connectivity and this process: http://forums.macrumors.com/showthread.php?t=1064753


    So the Apple80211Agent is the 802.11 wireless network agent and this is supposed to be the process fetching the network password from the KeyChain. If this process is associated with the connection issue some things would appear atleast slightly logical.


    Although I'm at a point where I no longer think this issue can be solved, this would explain a few things. For starters, this would explain why removing every trace of the network and re-applying some change would allow WiFi connection after reboot, this could also explain why AirPort/Network Utillity does not seem to remember the password for the WLAN eventhough it still is being stored in keychain and also why trying to connect from the network utility results in repeating prompts for password. There might be a conflict/issue with the pasword storage and supply function between the router and MBP, this would also explain why resetting the router with new network name and password temporarily fixes the problem.


    I do not know for certen that this is related to the issue, though I remember these errors occurring earlier, if I run a Verify Disk Permissions after a failed WiFi connection I get multiple issues with:


    Permissions differ on "System/Library/CoreServices/RemoteManagement/ARDAgent.app/*

    Permissions differ on "System/Library/CoreServices/RemoteManagement/AppleVNCServer.bundle/*

    Permissions differ on "System/Library/CoreServices/Menu Extras/RemoteDesktop.menu/*


    All of the above seem to be related to language setting (Italian.lproj, French.lproj), and I do not know why this should effect/be a result of failing WiFi connections?


    Permissions differ on "System/Library/Java/JavaVirtualMachines/1.6.0.jdk/*

    Permissions differ on "System/Library/Java/Support/Deploy.bundle/*

    Permissions differ on "System/Library/Frameworks/JavaVM.framework/Versions/*


    As I wrote, I have no idea if these issues are related, though I know I've repaired these issues multiple times before.



    My guess is that there is some communication problem between the router and the MBP during connection regarding the password information, this could also explain the multiple threads I've found where people report that changing the encryption from WPA2 to WPA/WEP temporarily solved the issues. The question is, how can this be resolved?


    Any ideas frome someone who knows more about network solutions than me?


    Best regards

  • gusgrave Level 1 (25 points)

    Well, I do not expect this to be an permanent fix, though my WiFi has been up without disruption and reconected without problems for 5 days straight, after reboots and sleep-mode.


    I went bananas and examined the console messages in detail, and it seems to me that there are actually multiple problems with the airport connection. But lets focus on what worked first, then what didn't work. After a lot of Googeling and trials I erased all my network settings and passwords regarding my home network from the "Automatic" location in network settings and keychain. After this I created a new location, removed every connection alternative but AirPort and turned airport on. I got connected on the first try and have not had any problems since then. Though I still remain sceptical and I'm still waiting for it to break again.


    So, here are some problems emerging from the console messages:


         kernel            en1:802.11d country code set to 'X3'

         kernel            en1:Supported channels 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100104 108      112 116 120 124 128 132 136 140


    My guess, searching for a real country code since X3 does not translate into a country.


         kernel            00000000  00000020  NVEthernet::setLinkStatus - not Active


    Don't know why there would be any problem with the Ethernet, except for it not being used?


         configd[14]            networkconfiguration changed.


    This message keeps shoing up in the log in connection with failed attempts to connect and is giving me a real headache, I have not changed any network configurations and I cannot see why this would be triggered?


         kernel            en1:802.11d country code set to 'US'.

         kernel            en1:Supported channels 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64 100 104 108112 116      120 124 128 132 136 140 149 153 157 161 165


    This is obviously a problem, since I'm living in Sweden and not the US of A. The country code I would expect is SE. This also explains the signal "drop" in a matter of speaking, when the network is up and running, my router is broadcasting on channel 13, a channel not present in the US settings. Hence, changing channels on the router to 11 would probably work. From what I have found online, this is an issue related to someone in the proximity running a wrongly configured router, or an imported router. This is all fine and I can accept these points, though I do not understand why this issue would be resolved by simply creating a new location? Wouldn't airport still pick up on the US configured router?


         eapolclient[3198]            en1STOP

         kernel            directedSSID scan fail


    I do not really understand exactly what these errors refer to, though I understand that it is related to authenticating networks and scanning for broadcasted SSID:s. So obviously this would affect my ability to get connected.


         Apple80211Associate() failed -3905 (Timeout)

         Apple80211Associate() failed 6 (Device notconfigured)

         SystemUIServer[122]            Errorjoining virus_net: Connection timeout (-3905 timeout connecting)

         Apple80211 framework[122]            airportdMIG failed (Associate Event) = -3905 (Timeout)  (port = 24855)

         /System/Library/CoreServices/Apple80211Agent.app/Contents/MacOS/Apple80211Agent [5479]                 MDSError: unable to create user DBs in/var/folders/2t/2tzJPYIkGoCjGmSBp54ZrE+++TI/-Caches-//mds

         Apple80211 framework[5442]            ACInterfaceGetPowercalled with NULL interface

         SCHelper[5448]            nocommand

    Even more errors/problems. Do not know exactly what these are or how hey are related to the failing connection, though my guess is that this does not have any possitive effects on my airport connection.


         Apple80211 framework[5479]            SecKeychainSearchCopyNext()returned error: -25300

         Apple80211 framework[5479]            _ACNetworkCopyKeychainItem()expected password for "XXXXX" not      found: -25300 (The specifieditem could not be found in the keychain.)


    This does on the other hand seem self explaining. Eventhough I have both the network and the password stored/saved, AirPort is unsuccessful in retrieving the network password from the keychain, and this would relate to my previous ideas of some large problem with the password handeling and presentation.


         Apple80211 framework[122]            Scan()error 16 (Resource busy)

         Apple80211 framework[122]            __performScan()EBUSY, sleep 1 sec, try again


    Again, a problem showing up from time to time in the log, obviously related to some issue finding the network?



    Obviously there seems to be more than one issue with the airport connection stemming from different causes, surprisingly they were all resolved by creating a new location with only AirPort as an option for connecting. Eventhough this might not be a lasting fix, it is surprising to me that this would resolve these numerous problems.


    What I also find interresting is that when searching for these many problems found in the log, almost all of the returend results are from users with AirPort connection problems who own a macbook or a macbook pro. It also seems that in the most cases, the response from apple is that there is a hardware problem. Though I find this less likely since my WiFi is now running with good speed without any connection problems. I don't think a new location would solve a hardware issue, it feels more like a software based issue?


    Any comments/feedback on this is more than welcome!


    Best regards

  • elata Level 1 (0 points)


    I have been experiencing the same problems- the intermittent service with the DIR 655. It was working pretty good until I did a firmware upgrade on the dir 655  a couple months as recommended by DLink as I was having trouble with the router logging in and out and affecting all computers in my home. I called DLINK directly and they ran me through a firmware upgrade for the DIR 655 in August, 2011.

    All my computers, PC, blackberries, etc. connect fine now, but now my IMac does not connect properly. Cannot depend on it to load internet pages quickly, Skype works intermittently and bottom line it is very aggravating. An IT person told me the firmware upgrade was causing the problem and the MAC didnt like the changes...I have been scouring the internet for a solution or perhaps some help from DLINK but I have found nothing. I am going to write DLINK and see if there is something they can help mw with as this is so annoying, you can't believe it.

    Anyway, I share your pain and if I find something out, i will let you know.

  • gusgrave Level 1 (25 points)

    I just updated the other forum where I was complaining about connectivity issues:




    Its been several weeks now, and I have still not experienced a single connection issue. So this is not a fix to the problem, more of an inconvenient solution. But still, I have WiFi, and thats is good enough for me, at least for now!


    Best regards

  • duker61 Level 1 (0 points)



    I've been seeing similar unable to connect issues. I have a DIR-655 Rev A at 1.35NA. I've enabled WEP for my primary network. Given the huge number of portable devices me and my friends have I decided it would be best to enable the guest network rather than give out the password.


    I'm thinking my problems all started after enabling the guest network.


    I'm seeing on random intervals the wireless network will no long allow devices to connect. Once that happens, it's a matter of time before connected wireless devices are disconnected.


    A switch reboot restores everything for a period of time. 1 to 6 or 7 days before we start all over again.


    Wired devices are never affected.


    I'm posting here because it almost always seems to starte with my son's MBP and iPhone devices. It "spreads" to the rest of the wireless devices.


    Once the switch stops no wireless devices can connect.


    I noticed in the router logs that the wireless devices seem to get stuck in a loop where the log repeatedly records an IP address assigned but a connection is never made.


    Here is a log clip:


    WARN]Tue Sep 11 11:13:49 2012A network computer (iPhone) was assigned the IP address of
    [WARN]Tue Sep 11 11:10:42 2012Above message repeated 11 times
    [WARN]Tue Sep 11 11:10:32 2012A network computer (1093E95D286A) was assigned the IP address of
    [WARN]Tue Sep 11 11:10:29 2012Above message repeated 2 times
    [WARN]Tue Sep 11 11:09:45 2012A network computer (iPhone) was assigned the IP address of
    [WARN]Tue Sep 11 11:05:01 2012Above message repeated 15 times
    [WARN]Tue Sep 11 11:02:59 2012A network computer (1093E95D286A) was assigned the IP address of
    [WARN]Tue Sep 11 11:02:58 2012Above message repeated 1 times
    [WARN]Tue Sep 11 11:02:28 2012A network computer (iPhone) was assigned the IP address of
    [WARN]Tue Sep 11 10:43:00 2012Above message repeated 9 times
    [WARN]Tue Sep 11 10:39:53 2012A network computer (4860BC74EF1E) was assigned the IP address of
    [WARN]Tue Sep 11 10:39:50 2012A network computer (iPhone) was assigned the IP address of
    [WARN]Tue Sep 11 09:42:04 2012Above message repeated 21 times
    [WARN]Tue Sep 11 09:41:47 2012A network computer (1093E95D286A) was assigned the IP address of


    Today the wireless failed again. The MBP and iPhones started with not being able to connect. The wireless PCs followed. I was going to reboot the switch but instead disabled the guest network and saved the router settings.  This restored the wireless connections for everything.


    Is your guest network enabled?

  • duker61 Level 1 (0 points)

    Just for fun, I've created a GuestZone schedule in the router configuration where I disable the guest zone for 2 minutes a day. I'm thinking the disable/enable cycle might be enough to keep things moving.

  • gusgrave Level 1 (25 points)

    I left this thread unfinished. I solved my own problem.




    I keept the work going in another thread. I changed my language setting to use "." instead of "," as a decimal sign. This changed my "region" from the correct country to "custom" region. Apparently, the "custom" region excludes some specific signs from being displayed correctly. Changing the language settings back to my country solved my connetivity issues. I've been solid for several months now!


    // Gus

  • Benissar Level 1 (0 points)

    Hi Gustaf,


    I have used my Dir-655 in 3-4years with my macbook pro and air and it worked without any problem, then 3 weeks ago I moved to another apartment in Stockholm and now I got this annoying error, I cannot find the network after the computer been sleeping, in about 70% of the cases...  I tried your fix with changing the language settings from "," to "." but this does not work for me... do I need to restart, and reset everything after this change? (and same time, I want to use "," not "." in excel etc.)


    Interesting to see is that the error occur when I am using my router in a new area/sorrunding. I will continue try out different channels.


    Do you know if 10.8 upgrade helps? I am using 10.7

  • gusgrave Level 1 (25 points)

    Well, your not supposed to just change the comma/point.


    I don't remember the swedish menue entries but go to the following:


    System Preferences -> Language & Text -> Formats


    and change the drop-down menue "Region" from "Custom"/"English" or whatever it might be to "Swedish" and do not fiddle with any of the ettings.


    Give this a try, if this doesn't help, the easiest way is to reset router and the network settings. Then, since you moved, try to change the channel on you router. But try this first and well se what happens.


    // Gus