Previous 1 2 Next 20 Replies Latest reply: Aug 13, 2013 12:16 AM by n_v14404
rbrome Level 1 (0 points)

Since upgrading to Lion, my mouse cursor has been jumping all over the place. At least once every five minutes - if not more - the cursor will just jump to a different part of the screen completely. I'll "lose" it, and have to shake the mouse all over for a few seconds to find the new location. It's extremely frustrating.


I have a 27" 2.8 GHz Core i7 iMac and a Bluetooth Magic Mouse. My keyboard is wired USB with numeric pad.


This never happened before Lion.

iMac 27, Mac OS X (10.7)
  • coocooforcocoapuffs Level 3 (845 points)

    try installing MagicPrefs (free) and let us know if that fixes it.

  • Jade Leary Level 3 (665 points)

    Getting erratic behaviour as well. Same iMac (Quad 2009). MagicPrefs doesn't change anything.

  • UmpaEG Level 1 (25 points)

    Hey same here - I thought it was me !!!

  • zeugmatis Level 1 (0 points)

    Same here - bluetooth mouse just "flicks" randomly all over the place. Worked perfectly under Snow Leopard and started doing this immediately after the upgrade, which completed about 20 minutes ago.  Terribly frustrating - to the point the computer isn't even usable anymore.  I have a trackpad, but don't like it and work much faster with a mouse. 


    Seems to be particularly bad if I type for a few minutes and then move the mouse.  This is replicable here - type for a few minutes, move mouse and it wildly flicks clear across the screen...

  • incredimike Level 1 (0 points)

    I did not have a problem with my magic mouse, but when I started using my Logitech MX518 I was experiencing the same "pointer skip" that everyone else has mentioned.


    After some research it seems like the problem is related to mouse acceleration during high CPU usage...


    I found a piece of software that allowed me to turn off mouse pointer acceleration and it seems to have helped stop the pointer from jumping around the screen as much, but the problem isn't completely solved. Obviously turning off isn't a solution, either.


    The software I used to turn off acceleration is USB-Overdrive, but it's shareware.


    I also discovered that you can turn off acceleration from the command line by using the following commands:


    $ curl -O

    $ chmod +x killmouseaccel

    $ ./killmouseaccel mouse


    Source: e/

  • bonnober Level 1 (0 points)

    My 2010 MBP just started doing this. Trackpad, magic mouse, and regular USB mouse suddenly became uncontrollable. My machine's battery is also making a lot of noise and getting very hot. Wonder if the symptoms are realted, though the jumpy cursor occurs now even when machine is cooled off. Apple - you gotta deal with this. Obviously people's problems are not getting solved.

  • sli92 Level 1 (0 points)

    I bought a new iMac 2011 and have the same problem. There always little cursor jumps. It drives me crazy.

  • jerbarb Level 1 (0 points)

    Same problem with the cursor.  Called Apple Care service and they tried to blame it on the mouse batteries.  Same batteries I used with Leopard with no problem...???!!!

  • timothyta2 Level 1 (0 points)

    Anyone else having this problem with iTunes open? If I close iTunes my cursor stops "jumping" and as soon as I open it again the cursor starts jumping all over the screen. It doesn't matter if it's in the foreground, background, or hidden. I'm not sure if it started with the Lion update or the iTunes 10.4 update as I hadn't used it in a while.

  • bonnober Level 1 (0 points)

    Mine does it with or without ITunes open. 10.6.8. Extremely maddening!

  • siduffy Level 1 (0 points)

    Same here, itunes doesn't make a difference, the mouse feels like the mouse in windows 3.1 did, laggy as ****, and jumping skitishly from one place to the next. It feels like it's having a hard time keeping up...I have an 8 core 2008 MP so 8 xeons shouldn't be having trouble tracking my hand but that's what it feels like


    It only started today and I've had Lion for a couple of weeks now, haven't changed anything on my system etc etc


    Very odd bug, needs squashing ASAP, work is very very frustrating ATM

  • marthafromcocoa beach Level 1 (0 points)

    Mky mac book is doing the same but it has nothing to do with the mouse, it's the track pad that is the   problem

  • jamesfromoregon house Level 1 (0 points)

    Hi, Martha. Would you elaborate?


    I have an early 2008 MBP, bt trackpad, bt mouse (logitech), and bt keyboard. I write code in both Lion and Snow Leiopard (external drive) and I get the cursor randomly changing positions in both environaments.


    At first I thought it might be the complex formatting of Xcode-- maybe I just didn't understand it properly-- but the problem appears in other applications as well. It's not happening here, nor can I remember it happening when I'm typing into a text fireld on a website.


    So, Martha, my dear, my suspicion is that your hypothesis bears further testing. If the problem originates with the trackpad, that would explain its appearing in both Lion and Snow Leopard, and would preclude its being a bug in either (unless its common to both, which seems doubtful).


    I've wondered if it might be symptom of a low battery in the trackpad. Or could I be inadvertently and unconciously bumping the trackpad while working? I'll have to observe this more closely.


    If I am able to pinpoint the source of this phenomena, which ranks right up their with Clippy the Paperclip for irritation, I'll post an addendum here.


    If anyone else solves this, please also do post your findings. It would improve my working hours!





  • marthafromcocoa beach Level 1 (0 points)



    My Mac Book is only 6 months old.  I haven't upgraded, downloaded or otherwise altered the original package. 


    I unplugged my wireless mouse but the cursor jumped anyway.


    I tested hardware, shut down, restarted and  tried anything I saw in the support responses.  No help.


    If I keep my hand lightly on the track pad it calms it enough that I can click on something.  If not, the track pad doesn't work properly and trying to click on an item or X is like trying to swat a fly with a 2 x 4.

Previous 1 2 Next