Previous 1 2 3 Next 36 Replies Latest reply: Apr 1, 2013 4:52 PM by manzana grande
Chris-UK Level 1 (0 points)



Since upgrading to Lion my Macbook Pro 13 is getting very hot and constantly indexing with 4 x mdworker and 1 x mdworker 32


They are taking loads of CPU, causing a lot of heat and taking the battery that was steadily at 6-7 hours pre Lion down to 2 hours


I have seen lots of old threads on mdworker problems in Leopard and previous releses, but I have not had this problem until upgrading to Lion


Is there something different Lion is doing and any way to switch it off or is it a problem?


I went into System Preferences -> Spotlight and excluded my entire hard drive but it still keeps kicking in randomly a while after use. When rebooted it stays OK for a while then starts to go crazy as I use more apps.


There was only one incompatible app when I upgraded (McAfee Security) which I dont know if relevant.


My system.log seems to indicate there is some issue with McAfee even though not running - but could be a red herring and totally inrelated:


Menulet[16385]: Menulet : Caught an Exception while Registering with FMP

Menulet[16385]: Failed to register with FMP[339] (com.mcafee.menulet): Throttling respawn: Will start in 10 seconds

com.mcafee.reporter[16386]: objc[16386]: Object 0x41b630 of class __NSCFString autoreleased with no pool in place - just leaking - break on objc_autoreleaseNoPool() to debug

McAfee Reporter[16386]: Reporter : FMP exception in ReporterRegisterWithFMP: msg :: connect call failed

McAfee Reporter[16386]: Failed to register with FMP[339] (com.mcafee.reporter): Throttling respawn: Will start in 10 seconds[10]: Can't open CFBundle for /usr/local/McAfee/AntiMalware/Extensions/Virex.kext.

--- last message repeated 1 time ---[10]: Error: Kext /usr/local/McAfee/AntiMalware/Extensions/Virex.kext - not found/unable to create.

com.mcafee.virusscan.ssm.ScanManager[16387]: /usr/local/McAfee/AntiMalware/Extensions/Virex.kext failed to load - (libkern/kext) not found; check the system/kernel logs for errors or try kextutil(8).[1] (com.mcafee.virusscan.ssm.ScanManager): Throttling respawn: Will start in 10 seconds


Anybody else getting this mdworker/mdworker32 going a little crazy now they are on Lion?


Thanks, Chris

MacBook Pro, Mac OS X (10.7)
  • Level 1 (30 points)

    New MacBook Air mid-2011 with 4GB RAM/128SSD, migrated from Snow Leopard  on a MacBook Pro


    I am getting the same problem with multiple instances of mdworker and mdworker32 running, with one usually pegged at 80+% CPU usage.  Only reason I even checked Activity Monitor was because I heard the fan come on.  I figured Flash was running somewhere :-D


    I have 7 accounts on my Air, and I have seen mdworker processes running on all of them, although none except my main account is actually logged in.


    I see that even a user called _spotlight has multiple mdworker processes running. Never seen that.  Is this a new user paradigm? I've certainly seen root running before

  • ealtson Level 1 (0 points)

    I too have similar issues. I have determined that it does NOT have to do with FileVault, as the same problems occur with or without encryption. The multiple instance is mdworker (all running at 40-50% of CPU) are what is causing the majority of the heat issues, and seem almost random in nature. The system will run fine for a while, then start crunching away for no apparent reason. I suspect that it is related to multiple users (and possibly having more than one user running at a time) but can not confirm this yet. This is a major bug in Spotlight, and since it's something that is built into the deep OS, Apple really needs to take this seriously. Right now, I could NOT recommend the Lion update to anyone.

  • ealtson Level 1 (0 points)

    AH! Okay, I have discovered a possible solution!


    It seems that TimeMachine is now indexing the backup drive (maybe it did it before, but I never noticed). My current setup has my TimeMachine drive as a mounted network volume, so I do not know if this will apply to anyone using a locally connected drive. I saw that when I manually ran a TimeMachine backup, the backup drive mounted (as usual), but did NOT unmount as it used to do when finished with a backup. Almost at once (right after the backup) mdworker processes spawned for each of my users plus one for _spotlight and started sucking up my CPU. I tried to exclude the backup drive from indexing, but was not allowed to, HOWEVER, I could manually EJECT the mounted backup drive. Instantly the mdworker processes vanished and all was well.


    I'm not sure what Apple was thinking here, or if indexing the backup drive is somehow necessary in Lion, but the process by which they are doing so is definitely messed up. Having my cpu run at 90°C for hours is NOT okay.


    On a side note, I also noticed that the indexing of the backup drive does NOT show up in the Spotlight icon and happens completely in the background. I'm guessing that the more users you have on your machine, the more mdworker processes would spawn.

  • Simon Brueckner Level 1 (10 points)

    Thank you, that was exactly the case. I unmounted my network drive and voilà, the 4 mdworker suddenly disappeared.

  • Alexander Ostleitner Level 1 (15 points)

    Did the process ever complete? I've been seeing the same problem on a MBP15" mid-2007 running Lion (and ejected the volume after an hour or two each), and now after having a new MBA13" 2011 (migrated from the Time Machine backup) for a week, it's suddenly showing up here too. 


    I'm running a Time Capsule 2nd generation, firmware 7.5.2, and each computer has its own sparsebundle backup file on the Time Capsule.


    By the way: I doubt the number of processes is related to the number of users as I have 4 mdworker instances but only one user - and in case the theory is correct that Lion is indexing the backup: why did it start right now and not a week ago on my new MBA?


    It feels like something is corrupting the backup over time, which then causes these (endless?) processes.

  • ckingsbu Level 1 (10 points)

    Thanks Ealston, that did it for me. 


    I had 5 or 6 mdworker processes running, keeping my hard-drive churning.  As soon as I hit the eject on the Time Machine Backup, all but one of the mdworker processes died.  The drive didn't actually eject, as eventually a dialog window popped up saying it couldn't eject as process was still using the mount.  But, I can see in activity monitor that the disk I/O is back to normal.   Looks like a bug in Lion that needs to be addressed.



  • Alexander Ostleitner Level 1 (15 points)

    Simon, Chris: I hate being the one breaking the bad news to you, but these processes will return, most likely after one of the next backups. You might have to keep ejecting the volume every hour, until that problem is addressed.

  • Simon Brueckner Level 1 (10 points)

    Alexander: Yes I am aware of that. My guess is as follows: The TM drive indeed needs to be indexed (no bug so far), but it uses too much CPU causing fans to start and slowing down working. I assume it will vanish at some point, when the drive is fully indexed (I see activity on the drive now). By ejecting the drive while working, I can at least shift this task to a time when it does not annoy me - and I can but my Mac in the fridge ;-)

  • Alexander Ostleitner Level 1 (15 points)

    Simon, I'd say there are three bugs:


    1) users who are not familiar with the activity monitor have no way to tell what is causing their batteries to drain and their fans to spin at max for lengthy periods,


    2) the backup volume remains mounted on the desktop, which might be confusing for novice users,


    3) the indexing of the TM backup seems to take ages. I've let the processes run for many, many hours on my MBP, indexing a ~150GB backup file, and I can't tell if it will be done soon, or if the processes restart from scratch each time I eject the drive.

  • ealtson Level 1 (0 points)

    I have opted to do my TimeMachine backups manually until Apple adresses this issue. You can do this by putting the TimeMachine application on the dock, turning it "OFF" in the system preferences, and then right-clicking the dock app and selecting "Back Up Now". Alexander, no, my processes never did complete, but I did not let them run for more than a few hours. That kind of temp on my MBP for long periods is simply not acceptable. You do seem to be correct about the number of processes. I continue to see *at least* four processes when this occurs, and it does look like we have to manually eject each time we backup. Doing backups manually will at least save the trouble of having to go through that every hour.


    I would love to know if the processes do ever actually stop. Perhaps someone with a computer with better cooling could let it run overnight (a Mac Pro maybe?).

  • EvanL Level 1 (0 points)

    Similair problem here on a 2006 Mac Pro.


    My TM backup is on a USB drive attached to an Airport Extreme; eventually all 4 processor cores on the Mac Pro are consumed to varying degrees by mds and mdworker, accompanied by high network traffic (often up to 18 MB/s). Ejecting the TM volume temporarily cures the issue and adding the TM volume to Spotlight's privacy exclusion list did not resolve the problem.


    Anyone else wishing they would've stayed with Snow Leopard for just a little while longer??

  • jollyllama Level 1 (0 points)

    Just started having this problem tonight, about two weeks after upgrading to Lion. I have a HD plugged into a Airport Extreme that I'm using as a TM disk. Tried everything suggested on these threads and nothing has helped.

  • Level 1 (30 points)

    Unfortunately, it's not just a Time Machine issue


    I found this thread due to the same problems, but I'm on a new Air with no Time Machine.


    However, I do note that the problem eventually went away.

  • etresoft Level 7 (27,781 points)
Previous 1 2 3 Next