Previous 1 5 6 7 8 9 Next 134 Replies Latest reply: Jul 19, 2015 4:19 PM by vctrmp Go to original post
  • Pafnutius Level 1 Level 1 (0 points)

    I won't forgive you Apple, sorry Zacross3.

    I really don't understand why I need to dance with this issue firstly with Mac Air secondly with Mac Book Pro Retina.. Every gadget has the same problem which is not being solved for a years as I can see. I have another OS on laptop which is Windows and everything works there. This is the solution of the problem, people! Switch to another OS and forget about this nightmare.

  • rsilvers Level 1 Level 1 (0 points)

    sudo rm -f /var/vm/sleepimage fixed it for me.

  • マイケルサムラー Level 1 Level 1 (0 points)

    rsilvers, could you expand on that a bit? I would love to not send my imac back, but wireless would be nice as well.

  • rsilvers Level 1 Level 1 (0 points)

    Open a terminal window. Type:

     

    sudo rm -f /var/vm/sleepimage

     

    It may ask for the administrator password. Type that in.

     

    Then reboot the machine. I did a hard reboot where I held down the power button until it forced a restart without saving anything.

     

    It started back up, and the wifi hardware was working again.

  • Brmusic1 Level 1 Level 1 (0 points)

    So. Turned off the computer. Closed the laptop and Turned it over on its screen and pressed down on the back panel on all for corners. Fixed the problem. It is a hardware flex cable issue.

  • KhalidEB Level 1 Level 1 (0 points)

    I just had the same problem today. All what I did is turn off my bluetooth, and then restarted my Macbook pro, and it worked for me!

  • Pastrybandit Level 1 Level 1 (0 points)

    I have tried all of the solutions listed previously and none of them are working for my 2012 MacBook Air.

  • saintmonkey Level 1 Level 1 (0 points)

    Well !!!!


    I thought my issue was related to the 10.8.5 update,

     

    My machine since the update started saying no wifi hardware etc and also freezing .

     

    Ive just spent 4 hrs doing a time machine back to pre 10.8.5

     

    all was well, but it went to sleep and for the 1st time ever wouldnt wake up ... hard reset and yes you guessed it no hardware error !!!, several resarts later and its back on ...

     

    Ive got to say this is the last apple anything I buy ...

     

    Bought an iphone 5 last week ... battery lasts 1 day with everything turned off if im lucky ...

  • saintmonkey Level 1 Level 1 (0 points)

    Update ...I finally sorted my problem out, I removed the wireless card unhooking all the associated cables, guides on youtube, put it all back after cleaning connections with alcahol ... its been over a week now with no issues ... not one

  • Sean_Zor Level 1 Level 1 (0 points)

    From what I can tell this is a software problem. If it were a hardware problem the wireless wouldn't work no matter what you boot with.

     

    When I boot it up in anything except my normal OS, which is mavericks right now, like windows 7, I can connect just fine. The same thing happens if I were to connect when it gives me the option to choose my boot path, I can connect.

     

    I have tried pretty close to all of the "solutions" I can find and some of them sometimes let me use wifi for maybe 10 min. Deleting the sleep image works the most for me but so does restating my PRAM and restarting my SMC. But like I said only sometimes works.

     

    Apple needs to not only admit there is a problem but also do something about it.

     

    Also if anybody knows another way that could potentially fix this problem if it were a software problem then post something, that would be wondrous.

  • Yosuke Hasumi Level 1 Level 1 (0 points)

    Mines working now and I thought I'd put my 2 cents in.

     

    I have a Mid-2010 macbook pro. Came with snow leopard installed on it. I had this "No wifi installed" issue for quite some time and I WAS running mountain lion. Things that I've tried:

     

    • Reset PRAM
    • Reset SMC
    • Removed all configuration files/settings for keychain
    • Removed all configuration files/settings for wifi
    • Various terminal stuff to try and clear out and reset the issue
    • Clean install of mountain lion
    • Changed the network card
    • Changed the netword card cable
    • Downgraded my KEXT to snowleopard

    Nothing worked for me. I resorted to using a USB network adapter and thought that it was just a case of me using my computer everyday for 6-8 hours a day for 3 years. Things get old and circuits get fried... even apple can't stop that. I'm not even going to try and understand the world of modern day computing and the fact that these computers are so far advanced than what I ever thought imaginable, therefore I'm not going to criticize the programmers at apple or ANYWHERE else for that matter. The only thing I could say is that someone should from apple should be around to stop this panic and do some PR work to do damage control.

     

    Anyway because of another issue I ended up reinstalling my osx. this time with snowleopard using the OSX that was designed for my computer - Snow Leopard. Althought it's a step backward things in terms of my OS my WIFI has come back! stoked about that.

     

    Some of the apps I need required I have Lion installed so I carbon copy cloned my hard drive (just in case) and I upgraded to Lion (not Mountain Lion) and my WIFI seems to still be working perfectly, no complaints (I'll keep my fingers crossed).

     

    My issue (on my computer anyway, I know it's gonna be different for everyone) was that Mountain Lion doesn't play nice with my WIFI card. I'll stick with Lion for now and probably forever on this machine.

     

    Good luck everyone.

  • brendanuk Level 1 Level 1 (0 points)

    Brmusic1 wrote:

     

    So. Turned off the computer. Closed the laptop and Turned it over on its screen and pressed down on the back panel on all for corners. Fixed the problem. It is a hardware flex cable issue.

     

    Tried everything and still same wifi: no hardware installed error, so thought why not. switched off, closed lid, pressed all four corners, open lid, powered on. WIFI is back. Must be hardware issue

  • L111 Level 1 Level 1 (0 points)

    Hi Folk

     

    I joined this forum specifically to say that switching off, closing the lid and pressing all four corners worked for me.

     

    It looks like a hardware/build quality issue.

  • LYK Level 1 Level 1 (0 points)

    Open a terminal window. Type:

     

    sudo rm -f /var/vm/sleepimage

     

    This solved my problem. I upgraded to 10.9 and start having this issue randomly. ANyway, for the time being it seems to be working.

  • rcovin Level 1 Level 1 (0 points)

    TEMPORARY SOLUTION:

     

    An apple employee gave me this solution, and it is working so far

     

    SMC RESET

     

    Plug in MacBook

    Shutdown

    Hold down control,option,shift, and power buttons for 30 seconds or until computer turns back off

    Turn on

    If wifi is not on go into system preferences>network

    Click the plus sign and add wifi

    Click apply

    If the dot next to wifi is not green, restart

    Hope this helps!

Previous 1 5 6 7 8 9 Next