Previous 1 4 5 6 7 8 9 Next 134 Replies Latest reply: Jul 19, 2015 4:19 PM by vctrmp Go to original post
  • iclausen Level 1 Level 1 (0 points)

    Sadly, from my last note I took the following steps:


    Booted in to Bootcamp Window and the NIC was also not recognized there, which leads me to believe it's a hardware issue.


    I read some more posts and decied to give the box a good shake (yes physically shake the laptop) and reboot. This actually fixed the issue with also leads me to believe it's a hardware issue. As with my MBP 2010 I will likely take this machine to the genius bar to be looked and and she will be on her best behaviour in the store and then act up again when I leave. I wish I didn't have to shake my hardware to get it to work.


    *sigh* Apple really worth it?

  • Alex Bartl Level 1 Level 1 (0 points)

    I had the problem "no hardware installed" as well for quite a while on my MacBookPro, but could never figure out why it sometimes disappeared again and why or when it comes back again. I was just curious about the fact it could have to do with the sleep function. Recently I could not get rid of the problem any more by trying kind of everything mentioned in various threads. However I could fix the problem by removing the sleepimage (sudo rm -f /var/vm/sleepimage), shutting off the machine (hold power button for a couple seconds) and rebooting the MBP. Wifi was back installed and working!


    The error messages about the not found wifi card in system.log disappeared as well.

  • grrbears Level 1 Level 1 (0 points)

    I'm having this problem with my Macbook Pro. WiFi no hardware installed comes and goes. How exactly do I remove the sleepimage?

  • Alex Bartl Level 1 Level 1 (0 points)


    Just open a terminal (applications - utilities - terminal) and type the command above. You can find further details at

  • grrbears Level 1 Level 1 (0 points)

    Nope, didn't work. Thanks, though.


    Brand new MacBook Pro. Recently went in for warranty work: they replaced the inverter and the logic board. When I got it back from the technician this "Wi-Fi: No hardware installed" problem started happening. I called them and they told me it must be a software problem, which is not covered under warranty.


    I have tried every software-related fix I can find online; nothing has helped. The problem always starts when the machine goes to sleep. It lasts a few hours, after which restarting the laptop fixes the problem. It doesn't happen every time it goes to sleep. It's gone for days without the problem, only to have it happen again for no apparent reason.


    Any suggestions?

  • Tony850 Level 1 Level 1 (0 points) -installed-error-in-os-x/


    I found this solution. I am running tests right now and will reply with results.

  • jayesel Level 1 Level 1 (0 points)




    I found this link that helped me fix this problem.  After going to the Genius bar twice and having my System Softeare deprecated to 10.7.3, and after a few hours of searching I foudn this link which helped and FIXED my problem.


    Basically there is a change that needs to be made to IO80211Family.kext file


    The steps are here :




    The instructions will tell you to download the following archived file: edited Atheros kext for Lion*3

    And a utility called:


    Drag the kext file to the app, it makes the edits, reboot and you're all fixed up until Apple gets a patch out.


    Worked for me, and I love Apple and hate going 30 miles to the nearest store 3 times to fix a problem that is easy to fix yourself.

    Apple, please be truthful, and fix this problem. 

  • jayesel Level 1 Level 1 (0 points)

    That will NOT work.  the .kext file needs to be edited.  It's in the software completely.

  • J_Royal Level 1 Level 1 (0 points)

    I've tried numerous different solutions trying to solve the "Wi-Fi: No hardware installed" bug. Resetting the PRAM, updating operating systems, deleting cache etc. The below link explains how to fix for Mac Pro's, MacBook Pro's etc.



    "sigh" switch it off and on again. But it really worked - and saved me the effort (and embarrassment) of taking my mac to the Apple store to have it work there!


    Running Mac Pro 2 x 2.4 Ghz Quad-Core Intel Xeon, 12Gb Ram.

  • ColPanik Level 1 Level 1 (0 points)

    That's a big NOPE.

  • Skerfan Level 1 Level 1 (0 points)

    I've been so frustrated with this.  I've tried every fix.  The Kext fix worked for awhile - then - boom.  Nothing.  I finally purchased a usb wireless, which works great.  Funny thing, though, when I plugged in my usb wireless, the Airport one started to work again.  Maybe it's jealous. 

  • ColPanik Level 1 Level 1 (0 points)

    My solution was hardware, but it wasn't easy. I have AppleCare, and had the logic board, Airport Card and RAM replaced. I am enjoying a much more productive life now. To read about the process I endured, here are my blog posts:

  • Jeff Guinn Level 1 Level 1 (0 points)

    Thanks for all your advice on this -- I have been able to dodge the problem for the last year because the iMac was close enough to an ethernet port.


    Not any more.  In order to use the thing I need to have WiFi.


    I have reset the NVRAM, SMC, and booted both with, and without, the bluetooth keyboards off. 


    The result is always the same:  the BT icon in the menu bar says "No Hardware Installed".  However, the system profiler shows a WiFi card installed, and the Network Preferences panel provides the option to turn WiFi on (although it doesn't pay any attention).  Also, the Sharing Preferences panel provides the option of sharing Internet via WiFi -- but throw up a warning that WiFi needs turning on, which the computer won't do.  I never get a progress bar when it is booting.


    WiFi worked perfectly until I upgraded to 10.7.  On restart following the upgrade is when the problems started. 

  • Jeff Guinn Level 1 Level 1 (0 points)

    I put up with this for a year, because the iMac was in a location with easy ethernet access.  Unfortunately, I had to move it to a place not so blessed.


    I took it to an Apple store, where the genius bar ran a harware test, which said the WiFi card was bad, and wanted $103 to replace it.  So I bought and installed a replacement myself ($43).  Still had a "No Hardware Installed" message.


    Then the light bulb went on -- I bought a Netgear wireless range extender ($60), which is connected to the iMac via the ethernet port, rendering the WiFi issue moot.  You will need another computer with WiFi to set the thing up, but it only takes about two minutes.


    And I didn't have to pay Apple to fix the problem Apple created.

  • Zacross3 Level 1 Level 1 (0 points)

    As a lifelong supporter of Apple (as I type this on my third iPhone over the many years), I must say I've never been more disappointed in a company than I am right now with Apple over this issue. My MacBook Pro has been unable to connect to the Internet since August 2012. I've tried every so called "solution" that I've found browsing the Internet (via iPhone, of course) but it's been to no avail (not from a lack of diversity of home grown solutions; google "MacBook pro no wifi hardware" and you get over 8 million hits). I've also sent my computer off to the Apple store where they just replaced my airport card, which worked fine for a week but then the same issue rose again.

    I am just confused how such a blatant error on Apple's part is not being met with public outrage and also how Apple has not made an effort to fix this mistake. Where is the update that solves this issue? I am dependent on the Internet for my business and my thumbs are getting tired from typing all of these emails from my phone. Please Apple, solve this problem and stop blaming your consumers and supporters for your mistake.

    We will forgive you, just fix it.

Previous 1 4 5 6 7 8 9 Next