Previous 1 2 Next 23 Replies Latest reply: Jan 26, 2015 1:19 PM by Duncan C
kra_ste Level 1 Level 1 (15 points)



since I upgraded Lion I got tons of these messages in my logs:


Jul 25 21:11:58 neptun sandboxd[5347] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.XTJXHr4

Jul 25 21:12:29 neptun sandboxd[5348] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.86EVSpI

Jul 25 21:12:59 neptun sandboxd[5349] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.CJaoJoj

Jul 25 21:13:30 neptun sandboxd[5350] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.ZGxllUy

Jul 25 21:14:00 neptun sandboxd[5351] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.NApWQdS

Jul 25 21:14:31 neptun sandboxd[5352] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.w1isGGi

Jul 25 21:15:02 neptun sandboxd[5361] ([4420]): Preview(4420) deny file-write-create /Users/user/Library/Preferences/ByHost/.GlobalPreferences.146446A7-88D0-5241-85 F7-F6FDD0201B5F.plist.TC4h3SQ


So this is just Preview adding this every 30 seconds to the logs. Similar errors occur, for example, when Spotlight indexes movies.


Does anyone have an idea what is causing this and how to fix it?




MBP Late 2008, Mac OS X (10.6.2)
  • MC1220 Level 1 Level 1 (0 points)

    I am having the same issue.  Does anyone know what it means?  Thanks!

  • Barney-15E Level 8 Level 8 (43,130 points)

    Looks to be a permission problem.

    Type this in Terminal and report what it says for the first line (it will end with a single . ) and also for the ByHost folder.


    ls -ale Library/Preferences


    Also check to see if either the first line or the ByHost line has a line immediately following it with a 0:

  • MC1220 Level 1 Level 1 (0 points)

    The first line is: drwx------+ 335 Michelle  staff    11390 Jul 27 09:05 .


    The Byhost line is: drwx------   90 Michelle  staff     3060 Jul 27 09:03 ByHost


    Thanks so much!

  • kra_ste Level 1 Level 1 (15 points)

    Mine looks like this:


    drwx------  251 stefan  staff     8534 27 Jul 15:29 ByHost


    And the first few lines look like this:


    drwx------+ 763 stefan  staff    25942 27 Jul 15:41 .

    0: group:everyone deny delete

    drwx------@  60 stefan  staff     2040 25 Jul 09:27 ..

    0: group:everyone deny delete


    But as I said in my initial post, such errors do not only appear for the ByHost folder. It happens for various preferences, for example, when Spotlight indexes a M4V movie and tries to create/access a codec property file. Or here are some other examples when Safari is running:


    sandboxd[4159] ([4152]): Safari Webpage P(4152) deny file-read-data /Users/stefan/Library/Preferences/

    Jul 27 12:41:16 neptun sandboxd[4183] ([4182]): Safari Webpage P(4182) deny file-read-data /Applications/

    Jul 27 12:41:16 neptun sandboxd[4183] ([4182]): Safari Webpage P(4182) deny file-read-data /Applications/



  • kra_ste Level 1 Level 1 (15 points)

    Here's one more:


    sandboxd[5432] ([5427]): mdworker(5427) deny file-write-create /Users/stefan/Library/Preferences/com.cod3r.a52codec.plist.imarlP7 (Importing type '' using 'file://localhost/System/Library/Spotlight/CoreMedia.mdimporter/' - diagnostic:0 - find suspect file using: sudo mdutil -t ...)

  • Barney-15E Level 8 Level 8 (43,130 points)

    I'm out of ideas. I don't know how the sandbox works, or why it is jumping all over everything trying to write files.

  • kkathman Level 1 Level 1 (0 points)

    For what it's worth, I'm getting those errors too.  Mine are sandboxd based and hit through either Safari trying to write to /private/vars/folders/zz


    I am also getting a lot of reports of buffer allocation zero.


    Here's the detail from the sandboxd out:


    mds(68) deny file-write-create /private/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T



    Process:         mds [68]

    Path:            /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadat a.framework/Versions/A/Support/mds

    Load Address:    0x106592000

    Identifier:      mds

    Version:         ??? (???)

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [1]



    Date/Time:       2011-08-16 22:45:26.988 -0500

    OS Version:      Mac OS X 10.7 (11A511)

    Report Version:  7

  • maxcasal Level 1 Level 1 (35 points)

    Are you using a username originally created in Tiger and migrated through different versions of OS X?

  • DaddieMac Level 1 Level 1 (35 points)

    Are you using a username originally created in Tiger and migrated through different versions of OS X?

    Yes I am, and I am having these issues alot.


    My username was actually created in 10.0.


    I migrated through many 10.x's.


    When I came to Lion, when I first updated, my user account was not there at all. So I had to add it manually by creating a new user and pointing it at the old user directory. What would that have done?


    Oh yeah. I also changed my user's UID in Directory Utility so it would match the one on my laptop and I could access files between the machines without permissions issues. Was that bad to do?

  • Loren Ryter Level 2 Level 2 (495 points)

    having this kind of logging too while re-indexing boot volume with spotlight (ie, mdworker).


    yes, this system has been upgraded through panther probably. what's the issue and the fix?

  • Leopoldnak Level 1 Level 1 (0 points)

    same issue here - especially with iPhoto, also upgraded account from 10.1 to 10.8 - any fix?

  • ossapha Level 1 Level 1 (0 points)

    Getting the following errors in console log after I upgraded to 10.8 on a client machine


    error message code


    sandboxd[6634]: ([6449]) Mail(6449) deny file-write-create /path


    I have creted a symbolic link to the location of the mail folders off to another hard drive. Worked fine in 10.7, looks like this is no longer supported.


    Mail can't seem to create new folders, or if they are already there the IMAP folders convert to Read-Only

  • baltwo Level 9 Level 9 (62,195 points)

    Known bug, but they've not yet fixed it. File a bug report with Apple. The more users who report it, the higher on the priority list it moves.

  • asux Level 1 Level 1 (0 points)

    Thanks for the hint: I upgraded to Mountain Lion (10.8.2) today ... since then I had two new "features" (among different others!):

    - aborted every now and then

    - Mails from an Exchange server were "read only" (no remove/no move possible)


    Just found this discussion here by googling for "sandboxd ...: Mail(...) deny file-write-unlink .../Posteingang.mbox/".


    The directories were actually a symlink from ~/Library/Mail/V2 to a second hard disc since I wanted my external emails on some other disk which worked perfectly well under 10.7 (Lion). However, moving back the folder to the "right" place solved the two issues (at least until now).




Previous 1 2 Next