Previous 1 2 3 4 5 Next 61 Replies Latest reply: Mar 1, 2012 8:08 AM by fabiolr Go to original post
  • François J. Perreault Level 2 Level 2

    tried it (while skipping the optional undo steps) and number 7 failed for me.

    but for a moment you'd given me hope. 

  • Warwick Teale Level 3 Level 3

    HI Boaz sadly your suggetion of resetting the SMB sharing under ROOT does not work for me. Thanks for the tip it was certainly worth trying!

     

    I have two ADMIN users on this machine mac pro that was migrated form SNOW LEOPARD to LION 10.7.1 and one user works (setting the SMB) and the other does not (incorrect password).

     

    Its very strange.

     

    any further clues by anyone?

     

    w

    HONG KONG

  • Caraline Level 1 Level 1

    I am wondering if there has been any update on this issue?  I too can not un-click my account in the sharing window.  It does accept my password, but just puts the tick back in the box immediately.  For this reason I have to keep turning SMB on and off if anybody needs access to some files as I am not happy having my admin account enabled.

     

    Caraline

    Australia

  • Cj Shumate Level 1 Level 1

    I did a clean install of Lion and am having problems with SMB. I can view the shared folders from a Windows 7 machine, but every time I try to edit a file, I get a read-only error.

  • paolo dagani Level 1 Level 1

    same problem........

  • mibrodt Level 1 Level 1

    Correct me if I am wrong here, but if you don't have SMB Sharing turned on in the first place, then whether or not our user account is selected doesn't really matter, does it? In my mind, this is a bug, no doubt, but if you are not actually ever sharing anything via SMB, then just uncheck the sharing box. Whether or not your user account is selected shouldn't matter any more than having a user listed under the Remote login section, when SSH is turned off.

     

    Just to qualify this, if SMB sharing is disabled as a whole, can anyone still connect to their home folder over SMB?

  • fakpuppet Level 1 Level 1

    Try the following:

     

    1. Create a Sharing Only account through "Users & Groups", assign a password to the account. Suppose we you create an account named "mike".

     

    2. In Network select your interface, go to Advanced and then WINS. Under Workgroup set the default WORKGROUP and under NetBIOS Name set whatever suits you (let's assume you put "imac").

     

    3. Now go to Sharing select a folder to share and add the "mike" user account you just created for sharing-only purpose, go to Options tick the checkbox for SMB and then for the "mike" account and enter its password when asked for it.

     

    4. When accessing the shares from Windows box enter username in format "imac\mike" and the password for the account.

     

    This should set you up for accessing your Mac shares from your Windows machine.

  • jamiem1987 Level 1 Level 1

    Got exactly the same problem as everyone else in this forum, if i disable and re enable file sharing it works ok until the next restart. This is a clean install of lion i've had running since september using smb with no issues every day until today?! Seems a strange one, desperate for a solution

  • SanderFromH Level 1 Level 1

    First time poster here, but long time mac user. But I foud the solution to this problem and recon this maybe the solution for more people.Not Native English so if something is not clear please ask and I will elaborate.

     

    This is (very) technical solution, be careful with it, as itcan truly mess up your account.
    It includes editing the file that stores your account info/password/etc.
    The file is a plist file so some converting needs to be done.
    Also all editing is done with vi and I used sudo to acces the file.

     

    1. Locate the file /var/db/dslocal/nodes/Default/users/<user>.plist
    2. MAKE A BACKUP of the file
    3. MAKE A BACKUP of the file
    4. Copy the file to a location to edit it
    5. Convert the file with ‘plutil’ so it becomereadable
    6. Open the file and find the entry at ‘authentication_authority’
    7. In my file I found 2 lines in the entry

               <key>authentication_authority</key>

               <array>

                            <string>;Kerberosv5;;<ACCOUNTNAME>@<lotsof extra info……..></string>

                            <string>;ShadowHash;HASHLIST:&lt;SALTED-SHA512,SMB-NT&gt;</string>

               </array>

    1. THE FIX is to SWTICH these 2 lines around, so the line with ‘SMB-NT’ is the first line

    My entry after the switch looked like

               <key>authentication_authority</key>

               <array>

    <string>;ShadowHash;HASHLIST:&lt;SALTED-SHA512,SMB-NT&gt;</string>

                           <string>;Kerberosv5;;<ACCOUNTNAME>@<lots of extra info……..></string>

               </array>

     

    1. Save the file and convert it back with ‘plutil’
    2. Copythe file ‘over’ the old file in /var/db/dslocal/nodes/Default/users/
    3. Trydisabling and re enabling the setting now in system preference.

     

    For those curious on how I found:

    Created a new account where I was able tochange the setting (like people already figured out).
    Now using the find command I located all files changed in the last 5 minutes.
    Found the files in /var/db/dslocal/nodes/Default/users/ Looked around on the webon what information is stored in there. Came to the conclusion that this mustbe the file holding the info.
    Started comparing the files of the 2 users (1 where it was working and 1 whereit was not) and noticed the difference in the ordering of the lines.
    Changed the lines around and this did it. …… wooohooooo

  • tommi0 Level 1 Level 1
    expertise.ipad
    iPad

    This is the solution! Thanks SanderFromH!

     

    I had the same problem that I always got "incorrect password" when trying to enable smb for my account on my MBA. I could create new accounts, where it worked, but never for my account that existed before I upgraded to Lion.

     

    This post solved my problem by switiching the 2 lines around in my plist file. Interesting...

  • jmcgeejr Level 1 Level 1

    I am very glad to see that this helps the users with the incorrect password.  However, it still doesnt help the users who upgraded from SL to Lion who have the inablity to disable SMB.

  • Gagnar Level 1 Level 1

    Perhaps those users should try to change the string from

     

    ;ShadowHash;HASHLIST:<SALTED-SHA512,SMB-NT>

     

    to

     

    ;ShadowHash;HASHLIST:<SALTED-SHA512>

     

    beause that's what the string looks like with SMB disabled.

  • Edumara Level 1 Level 1

    Wonderful discovery. Thanks!

  • svkrzn Level 1 Level 1
    expertise.iphone
    iPhone

    I get Access Denied when trying to open Default folder. And i'm logged as admin.

     

    By the way, is this the only 'fix' that works so far? Does apple know about that bug? And is that a bug?

    SanderFromH wrote:

     

    First time poster here, but long time mac user. But I foud the solution to this problem and recon this maybe the solution for more people.Not Native English so if something is not clear please ask and I will elaborate.

     

    This is (very) technical solution, be careful with it, as itcan truly mess up your account.
    It includes editing the file that stores your account info/password/etc.
    The file is a plist file so some converting needs to be done.
    Also all editing is done with vi and I used sudo to acces the file.

     

    1. Locate the file /var/db/dslocal/nodes/Default/users/<user>.plist
    2. MAKE A BACKUP of the file
    3. MAKE A BACKUP of the file
    4. Copy the file to a location to edit it
    5. Convert the file with ‘plutil’ so it becomereadable
    6. Open the file and find the entry at ‘authentication_authority’
    7. In my file I found 2 lines in the entry

               <key>authentication_authority</key>

               <array>

                            <string>;Kerberosv5;;<ACCOUNTNAME>@<lotsof extra info……..></string>

                            <string>;ShadowHash;HASHLIST:&lt;SALTED-SHA512,SMB-NT&gt;</string>

               </array>

    1. THE FIX is to SWTICH these 2 lines around, so the line with ‘SMB-NT’ is the first line

    My entry after the switch looked like

               <key>authentication_authority</key>

               <array>

    <string>;ShadowHash;HASHLIST:&lt;SALTED-SHA512,SMB-NT&gt;</string>

                           <string>;Kerberosv5;;<ACCOUNTNAME>@<lots of extra info……..></string>

               </array>

     

    1. Save the file and convert it back with ‘plutil’
    2. Copythe file ‘over’ the old file in /var/db/dslocal/nodes/Default/users/
    3. Trydisabling and re enabling the setting now in system preference.

     

    For those curious on how I found:

    Created a new account where I was able tochange the setting (like people already figured out).
    Now using the find command I located all files changed in the last 5 minutes.
    Found the files in /var/db/dslocal/nodes/Default/users/ Looked around on the webon what information is stored in there. Came to the conclusion that this mustbe the file holding the info.
    Started comparing the files of the 2 users (1 where it was working and 1 whereit was not) and noticed the difference in the ordering of the lines.
    Changed the lines around and this did it. …… wooohooooo

  • SanderFromH Level 1 Level 1

    Some more info

     

    - I encountered this problem when I myself upgraded from SL to Lion

     

    - As Gagnar already noticed, removing the SMB-NT willdisable SMB filesharing for that user. I however do not recommend doing it thatway.
    Just switch the 2 lines around, once you have done that all the SystemPreferences option regarding the SMB file sharing will work as normal again.
    The less you mess around in the plist file directly the safer you are. As faras I can see now this file stores your (hashed) password information etc. So ifthis files becomes corrupted/messed up the system will no longer be able toverify your password and you can no longer log in etc.

     

    - Only root is able to access this file and for goodreasons. I myself did all the access and editing trough the terminal/commandline. I have no idea how safe it is to do these changes trough the ‘normal’finder view.

     

    - As far as I can see now:
    Between SL en Lion apple decided to switch the 2 lines around in the plistfile. When you do a clean install or add new users once Lion is installed thisis no problem as the entry in the file is done correctly.
    But it seems that apple forgot to add a check in the upgrade to change the 2lines around in all the accounts that existed on the machine.

    One thing they can do now I bring out a patch that fixesthis by checking all accounts and switching the 2 lines if they are the wrongway aroud.

    A second possibility (and Imy opinion the best) is that the code that reads/changes the information in theplist is patched so that it is able to read/write the lines no matter in whatorder they appear.