12 Replies Latest reply: Sep 7, 2011 6:26 AM by Trent Curtis
Trent Curtis Level 1 Level 1 (15 points)

After installing the latest batch of updates, my sudoku widget doesn't work anymore. Anyone else having a problem like this, or know how to fix it?

 

I noticed on the website which created it that others are also having this problem in the last few days:

 

http://briandeboer.com/posts/sudoku-20-approaching-beta-status/

 

Thanks!


iMac, Mac OS X (10.6.6)
  • Trent Curtis Level 1 Level 1 (15 points)

    I hadn't updated my profile when I posted this originally, which is why it says I'm using 10.6.6, instead of 10.6.8. I updated my profile, but it still says I'm using 10.6.6, but I'm not.

  • laplanj Level 1 Level 1 (0 points)

    Mine does not work either.  Any help would be greatly appreciated

  • rickmanw Level 1 Level 1 (0 points)

      For me DVD Releases and Tivo NowPlaying have stopped being able to connect to its website or my Tivo respectively after I updated to 10.6.8. I tried deleting the com.apple.dashboard.client.plist and com.apple.dashboard.plist from the (Home)/Library/Preferences folder, but all that ended up doing was making me restore all of my widgets. Those 2 still don't work.

      The supplemental update yesterday didn't change anything.

  • Trent Curtis Level 1 Level 1 (15 points)

    I use this widget BY FAR more than any other. That it is now the only one which now doesn't work is awful.

     

    I'm getting ready to offer a reward to anyone who can figure out how to fix this. If I knew a reasonable way to offer such a thing, which would guarantee a legitimate response, I would.

  • portraitpainter Level 1 Level 1 (5 points)

    I'm having the same problem. I noticed the last bunch of updates said they were preparing things for making things compatible with Lion, assuming you will upgrade to that. I can only assume that that version of Sudoku, also my favorite, does not work at this time with Lion. I installed these updates with Software Update on my iMac, but didn't get around to doing that on my new MacBook Pro. The Sudoku widget still works fine with 10.6.8 on the MacBook Pro. So it isn't 10.6.8, its the latest bunch of updates and I think the Lion thing. Hopefully the writers of that widget will update it.

  • Trent Curtis Level 1 Level 1 (15 points)

    Thanks for the clarification, portraitpainter. Very much appreciated.

     

    Don't hold your breath, though, about it being updated. The website it comes from hasn't been updated in literally 5 years (July, 2006):

     

    http://www.briandeboer.com/

     

    So, it doesn't look like he will be updating it anytime soon. I've tried other Sudoku widgets, but none of them are as good as this one. Unfortunately, however, all of them still work. Figures, right?

     

    Thanks again for your help.

  • cpp173 Level 1 Level 1 (0 points)

    I had the same problem after the latest software update. My Environment Canada weather widget and my Egg Timer widget no longer work after the install.  I removed them from Dashboard and re-installed to no avail. I'll be super annoyed if this is permanent, I use both of those widgets frequently.

  • Trent Curtis Level 1 Level 1 (15 points)

    If you, or anyone else, figures out how to resolve these problems, PLEASE let us know.

     

    Or is this something which only Apple can resolve?

  • ABergeson Level 1 Level 1 (0 points)

    I'm running 10.5.8 on a MacBook Pro and my Sudoku Widget is doing the same thing.  Also, I cannot connect to the briandeboer website. 

  • Trent Curtis Level 1 Level 1 (15 points)

    Someone posted the following on the Sudoku widget website:

     

    "Just wanted to add to my previous post. This widget uses images “.png” files so the font issue has not affected it’s performance. After some digging I found WebKit2 was bundled with the latest Safari update (5.1 and 5.0.6). WebKit2 uses a whole bunch of new APIs rendering some old ones obsolete. My guess is as good as yours, but most likely the SudokuC controller inside the widget is referring to one of those obsolete APIs."

     

     

    Does anyone know what this means, and can explain it to someone, like myself, who is not a programmer?

     

    Also, does it seem like a relevant solution and/or cause of the problem?

     

    Thanks!

  • Erik Bulckens Level 1 Level 1 (45 points)

    Same problem here. I'm on 10.5.8 and yesterday I updated Safari and Java for Mac so I guess it's one of those that causes the Sudoku widget to not function properly anymore. Gonna try to revert to the previous versions using time machine, not sure if this will work.

    If anyone has a solution, it would be more than welcome. The Sudoku widget was great on the train or just when passing some time and it doesn't waste any paper either ;-)

     

    Erik

  • Trent Curtis Level 1 Level 1 (15 points)

    I tried using Time Machine, but couldn't get it to work. If you're successfull, please let us know.

     

    It's a shame this widget doesn't work anymore. It was by far my favorite, and the one I used most often.

     

    If anyone knows how to fix this, please contact me. At this point, I'm willing to pay someone through PayPal if you can get it to work.