12 Replies Latest reply: Apr 3, 2012 2:09 PM by etresoft
Soundhunter Level 1 Level 1 (0 points)

Since installing Lion on my Macbook Pro ftp to and from my RiscPC has stopped working. With the latest version of Cyberduck on the Mac I can see directories on the RPC but I can't write to them. In the other direction I can't get a connection at all. It all worked fine under Snow Leopard so it's the OS that's kyboshed it, not third party applications.

  • DLH2 Level 1 Level 1 (0 points)

    I have the same FTP issue - just got off the phone with Apple and even the rep didn't know what happened until a day later (today).  He told me that Lion no longer supports FTP AT ALL!  Apparently now you have to have an FTP Server or a third party software to handle the FTP.  He could not offer any suggestions on how to help me with this, or find the right software package, or anything.  Pretty lame, very dissappointed.  I use this dozens a time each day for my business (Scan & FTP to a folder on my Mac) and now all business has stopped for a week - back to faxing docs.

  • djdawson Level 2 Level 2 (170 points)

    I haven't yet upgraded to Lion because I'm still checking for compatibility issues, which is how I learned about the FTP server being removed.  Snow Leopard uses the "tnftpd" open source FTP server software, which can be easily installed via MacPorts, and that's what I plan to do after i upgrade.  The only downside is that now there won't be a Sharing preference for managing this server and I'll have to edit config files, but I suspect that's not too big a deal (though there are potential security issues with FTP servers, which I'm guessing is why Apple dropped it).  There are other FTP servers available via MacPorts as well that might be either more secure or easier to set up, such as "pure-ftpd", "vsftpd", and others, so I plan to check those out, too.  My FTP requirements are very simple, so I suspect a minimal config will be enough for me.

  • Soundhunter Level 1 Level 1 (0 points)

    Actually, as I've now found out, what the Apple rep said isn't exactly true. Lion doesn't have an FTP client, as indeed Snow Leopard doesn't so you have to use something like Cyberduck for outgoing ftp. But that's only half the story.

     

    Snow Leopard enabled the FTP server by default but Lion doesn't. What is Apple thinking about?

     

    Anyway I found out via the comp.sys.acorn newsgroups and a blog called LandofDaniel that you can enable the ftp server using the command line interface. Run Terminal and enter the following command:

     

    sudo -s launchctl load -w /System/Library/LaunchDaemons/ftp.plist

     

    To stop the server it's the same command but with 'unload'.

     

    I suspect that Cyberduck needs to be updated to work with Lion.

  • griffdb Level 1 Level 1 (0 points)

    Thank you for the command.  It worked great to turn on and off ftp.

  • etresoft Level 7 Level 7 (27,120 points)

    Apple wants to discourage people from using such an old and insecure protocol.

     

    You can still use FTP from the Finder and from an ftp link in Safari. When it asks you to login, just choose "Guest" for anonymous access. The Finder, as always, only give you read support. If you need to upload, use the command-line ftp client.

     

    Even better, use sftp.

  • griffdb Level 1 Level 1 (0 points)

    Thanks for the pointer.  I was able to use sftp with FileZilla from my PC to my mac successfully.  Firewall was on and sharing was on.  Thanks!

  • boston6006 Level 1 Level 1 (0 points)

    Thank God I found this site and your comments.  I've been tearing my hair out over this problem. The only way around it, is for me to use my Mac Book Pro with Leopard to send out all my video files. Lion is a disaster and Apple Support techs claim to never have heard about this problem.  Some help they are.

  • etresoft Level 7 Level 7 (27,120 points)

    What problem?

  • boston6006 Level 1 Level 1 (0 points)

    When I post video files to my FTP site or to sites like filesanywhere, they reach about 25% to 31% then the upload freezes, then the process times-out and dumps me with an error message. This happens about 80% of the time. By transferring the files from my imac to my Mac Book Pro which has the older Leopard OS I can then post without any problems. So it's fairly obvious. I never had this problem until I upgraded my imac to LION.

  • etresoft Level 7 Level 7 (27,120 points)

    You would have this problem in any operating system when you use incompatible software. Don't use FTP. Don't use third party software that is incompatible. Are you aware you are broadcasting your password in plain text? No reputable service would even offer FTP anymore.

  • boston6006 Level 1 Level 1 (0 points)

    Are you saying that FTP sites like filesanywhere are not reputable?  It's obvious that it's the receiving end that has the problem reading LION generated files.How can you explain why the problem only occurs with LION and not Leopard? This is a language problem.

  • etresoft Level 7 Level 7 (27,120 points)

    boston6006 wrote:

     

    Are you saying that FTP sites like filesanywhere are not reputable? 

     

    I am saying that any FTP sites are absolutely not reputable. Filesanywhere doesn't appear to offer FTP. They offer secure FTP, which is perfectly fine.

     

    It's obvious that it's the receiving end that has the problem reading LION generated files.How can you explain why the problem only occurs with LION and not Leopard? This is a language problem.

     

    No, it is your problem. There is noting about Lion that prevents any type of FTP. If you have installed some third party software that doesn't work with Lion, then don't use that software with Lion. Use something else. It isn't Apple's responsibility to fix bugs in other people's software. There are many of us who have no trouble sending files to any online service.

     

    This thread is almost a year old. I have no idea what your issue is. I suggest updating Cyberduck. If that doesn't work, then start a new thread for your problem.