Skip navigation

Bluetooth Pairing Request

2183 Views 8 Replies Latest reply: Dec 17, 2013 5:28 PM by Argyles RSS
Parrish Jones Level 1 Level 1 (100 points)
Currently Being Moderated
Jul 26, 2011 7:45 AM

Never had this problem until upgrading to Lion. Now I am constatly getting a Pairing Request for a hearing aid streamer that I use to connect to my TV through another Bluetooth Device. The streamer is at least 20 feet away.

 

I checked the advanced settings in Bluetooth Prefs and checked for it to reject incoming audio requests.

 

In older posts I found persons saying to uncheck both the On and Discoverable boxes in the Bluetooth Preferences. I hesitate to do that as I use a Bluetooth Keyboard and track pad. It seems like unchecking those boxes will disable Bluetooth.

MacBook Pro 2.2 Ghz., Mac OS X (10.6.7), iWork 09, ILife 09, other
  • Roycroft Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 22, 2013 5:53 PM (in response to Parrish Jones)

    Sorry to see no responses to your query after all this time. I am having this issue with a bluetooth hearing aid adaptor. I had previously paired it with the computer to listen to music through the aids. But the adaptor is a pretty dumb device and I found that the conflicts between iPhone and laptop were too difficult to manage.

     

    So I removed the hearing aid adaptor from the list on the laptop, unchecked discoverable, checked reject incoming audio requests, all just as you have done, and I too cannot get the pairing requests to go away. I tried identifying .plist and .kext files related to bluetooth, used Text Wrangler to edit out references to the bluetooth adaptor, and still get the annoying Pairing Request spash boxes. Aaaargh!

    MacBook Pro, Mac OS X (10.6.8), 2.66 Ghz Intel Core i7; 4GB RAM
  • xa0s Calculating status...
    Currently Being Moderated
    Jun 4, 2013 6:00 AM (in response to Parrish Jones)

    Well, for what it is worth, I got Snow Leopard and Streamer Pro 1.0. The bluetooth request to pair is driving me crazy and I DONT WANT it to be paired to it. It's ******* me off.

  • AmozMac Calculating status...
    Currently Being Moderated
    Aug 12, 2013 8:56 AM (in response to xa0s)

    i use 10.8.4 i have this problem too.... I DONT WANT it to be paired also!!!!!!!!!!!!!!!

  • itrade Calculating status...
    Currently Being Moderated
    Aug 24, 2013 9:36 AM (in response to Parrish Jones)

    Yup, I'm on 10.8.4.  My son's apple bluetooth keyboard keeps sending pair requests.  I've been all over the net and can't find a solution.  I can't just turn off bluetooth or I lose my Apple mouse.

     

    Common, there has to be an answer to this!

     

    (Excuse any mistakes.  I have to type fast before the pair request comes back and I throw my computer out the window.)

  • Streeja Calculating status...
    Currently Being Moderated
    Sep 29, 2013 1:28 PM (in response to itrade)

    Is this still not resolved?  I am having the same issue with a JBL soundbar.  Pairing request just won't stop and I can not turn off my bluetooth because I have other devices that I need.

  • MPhipp Calculating status...
    Currently Being Moderated
    Dec 17, 2013 12:13 AM (in response to Parrish Jones)

    I am so disappointed that no one has come up with a solution to this issue.  It just started on my iMac and it is driving me crazy!

  • Argyles Calculating status...
    Currently Being Moderated
    Dec 17, 2013 5:28 PM (in response to MPhipp)

    Problem solved, so far.  When I contacted hearing aid company, that sells my streamer, I received a lengthy and credible explanation of why the product is designed to keep asking to pair. From the manufacture's viepoint there is no solution. But when I posted here, a nice person wrote an Applescript that changes Sound preferences. What to do is accept the pairing request from the Streamer. It becomes listed as a source, but the script deselects it, and selects "Internal Microphone" instead. I saved the script as an application and put a copy in the dock, for manual use, and a copy in "Login Items" to run automatically. I created a duplicate script and changed "Input" to "output" and "internal microphone" to "internal speakers." Both are in "Login Items" just to cover all the bases. It's working for me so far. You can find the script and instructions at:  https://discussions.apple.com/thread/5646313

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.