Previous 1 11 12 13 14 15 Next 217 Replies Latest reply: Aug 25, 2013 2:31 PM by judyfromfairmont Go to original post
  • nuno.bett Level 1 Level 1 (0 points)

    Thanx craigfromdenver for the workaround. Worked great for me.

  • harrison95 Level 1 Level 1 (0 points)

    Same issue, with my 2011 iMac. Not happy

  • Mac__Mike Level 1 Level 1 (0 points)

    Experiencing grey background on Lion 10.8.2.  Seems to be related to external monitor.  Have an HDMI converter.  Just started happening this week (1/12/2013).  Did not happen for the previous six months.  I do not believe I upgraded Lion recently, but I do always install the latest updates when they come out.  Killing the Doc process does restore the wallpaper.

  • DJ1234 Level 1 Level 1 (0 points)

    I have this problem too (2011 MBA,OS X 10.8.2), mostly when I close the lid and disconnect my external monitor at the same time. The solution that works for me is connecting my external monitor again (through VGA adapter), close the lid, wait a few seconds for the MBA to react, than opening the lid again --> nice background.

  • Al Guru Level 1 Level 1 (0 points)

    I have the same problem too, after using DV player or similar app that sends the computer into single monitor mode (how nuts but another thread now) in Mac OS 10.8.2 the main screen of a dual 24 inch screen set up attached to a Mac Mini does not refresh the wallpaper / background on quit. it just stays grey. This was never a problem under 10.6.8.

     

    Thank you so much to craigfromdenvor: "Did you try the log in window like I posted right before yours?"

     

    This works a treat and is very quick! But it would be nice for Apple to fix the issue.

     

    AB

  • Astitva Narayan Level 1 Level 1 (0 points)

    I just recently got the solution to this problem!

    The problem is because of full screen iTunes!

    What solves it for me is, just de-full screen iTunes...

    Then you can full screen it again! I don't know why is this happening but this sure seems to solve it for me!

  • dinglebat Level 1 Level 1 (0 points)

    Astitva Narayan wrote:

     

    I just recently got the solution to this problem!

    The problem is because of full screen iTunes!

    What solves it for me is, just de-full screen iTunes...

    Then you can full screen it again! I don't know why is this happening but this sure seems to solve it for me!

     

     

    I somehow doubt you'll find this to be a solution.  You will find that it just hasn't happened again -- yet.  But it will.  Please keep us informed about its long-run success.

  • TheBlackSaint Level 1 Level 1 (0 points)

    I have this happen to me all the time. I have a Retina MacBook Pro 15-inch running 10.8.3 and have two external monitors I plug into every morning. One is a Thunderbolt display and the other is just a 21" Dell montior that I plug into the HDMI port. Most mornings after I plug both in and log into my computer, the Thunderbolt screen (main screen) has a gray background. At first I thought it just lost the link to the wallpaper file but then I figured out it wouldn't let me set another image as the wallpaper period.

     

    I've found a temporary fix and just run the "killall -KILL Dock" from the terminal window and it resets it and goes back to normal. In the mean time, I've made an Automator app that runs that command in the shell and I've put that app icon in my dock so all I have to do is click it to fix the no wallpaper issue.

  • dinglebat Level 1 Level 1 (0 points)

    Well, at the risk of jinxing things, I do believe that 10.8.3 may have fixed the issue for me.  I suddenly realized, after many days of running this new release, that the gray screen hasn't occurred for a long time.

     

    Of course, now that I've written this, it will no doubt occur on my next wake-up.

     

    But, let's hope.

     

    Meanwhile, if anyone continues to have the problem with 10.8.3, let us know.

  • Holdielox Level 1 Level 1 (0 points)

    To fix this problem go to the apple logo at the top left of your screen and go to the log out option at the bottom. Once logged out, log immidiately back in and see if your problem is fixed. This worked for me.

  • dinglebat Level 1 Level 1 (0 points)

    Holdielox wrote:

     

    To fix this problem go to the apple logo at the top left of your screen and go to the log out option at the bottom. Once logged out, log immidiately back in and see if your problem is fixed. This worked for me.

     

     

     

     

     

    Well, that's not a fix for the problem; it's a work-around.  Nor is it the simplest work-around.  It's easier and faster to open the Activity Monitor and kill the dock.

     

    However, there does seem to be a fix for the problem. Upgrade to 10.8.3.  This continues to work well for me.

  • djv1967 Level 1 Level 1 (0 points)

    Permanent Fix

     

    After enabling Automatic Login, I got the grey background. Tried every workaround but no permanent solution, until I did the following:

     

    1. Repair disk permissions in Disk Utility

    2. Create a new test user account

    3. Restart

    4. Test with both users & everything OK

    5. Delete test user account

    6. Reboot

    Fixed!

     

    After many reboots & shutdowns everything back to normal, so far. Even with enabling & disabling Automatic Login. Let's hope it stays that way...

  • dinglebat Level 1 Level 1 (0 points)

    If you're not using 10.8.3, I suspect your problem will return.  Let us know how things are going in a week or two.

  • djv1967 Level 1 Level 1 (0 points)

    2013 rMBP 15" on 10.8.3

     

    Using Macs since 2007, never happened before.

  • Robert Clare1 Level 1 Level 1 (5 points)

    I have never seen this problem until today.  I was showing a Keynote presenation (on a secondary monitor) when I ran out of battery power (a different story).  I closed the laptop and when I went back to my office and plugged it into my thunderbolt display, when it came up it had the dreaded grey backdrop.  I did not reboot or logout, but was stymied until I came across the suggestion to kill the Dock.  Instantaneously (or so it seemed!), my backdrop was back, long before the desktop icons were recreated.  A simple 'force quit' on the Dock from the Activity Monitor, or an even quicker (for me) 'killall Dock' from a terminal window is enough to 'fix' the problem.  I'm on 10.8.3 on an MBAir regardless of what my sig currently says.