Skip navigation

Bluetooth causing System Preferences to hang in Lion?

250 Views 1 Reply Latest reply: Jul 27, 2011 5:21 PM by rocklebee RSS
rocklebee Level 1 Level 1 (10 points)
Currently Being Moderated
Jul 27, 2011 7:28 AM

just put Lion on 2 MacPros at work.  on one of the machines, I'm getting a weird hang when connecting to Bluetooth.  It'll connect (to my trackpad in this case), work for a few minutes and then stop working.  But it also causes System Preferences to hang/crash.  I can open SysPrefs but not click on any module.  Also I get a beach ball in the menu bar for any Apple sys prefs.  First time, i just restarted the comp and when it rebooted i got the "Bluetooth unavailable" icon (greyed out with the wavy line in it).  Then I tried trashing the bluetooth prefs and resetting SMC, which allowed me to connect on reboot, but again it crapped out after a few minutes?

 

Any body else having this issue or had this issue with older OSes?  To be honest I hadn't used Bluetooth very recently under Leopard or Snow Leopard, so i don' t know if the issue existed before the upgrade to Lion.

 

What about tryin gto reseat the Bluetooth antenna

Mac Pro, Mac OS X (10.7), Early 2008 Quad-core

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.