14 Replies Latest reply: Oct 2, 2011 3:48 PM by samantacalabro
tgabrielli Level 1 Level 1 (0 points)

iPhoto 9.5.1 crashes since OS X v10.7 Lion Update... HELP!!!

 

So here's my story...

 

Last week I upgraded from Snow Leopard to Lion, like every MAC enthusiast. After my successful install I check the system for any Software Updates, results iPhoto 9.5.1. I downloaded in installed it. Since then, everytime I try to open iPhoto it crashes. Everything else seems to me working fine.

 

I've tried everything I could think of as well as many of the suggestions found on the Support Fourm. Still to no avail

 

I'm posting this message in hopes that someone has had the same issue and can guide me through how to fix it. I'm technically savvy and hate it when the computer wins!!!

 

Thank you very much in advance.


MacBook Pro, Mac OS X (10.7)
  • Terence Devlin Level 10 Level 10 (134,540 points)
    I've tried everything I could think of as well as many of the suggestions found on the Support Fourm.

     

    Rather than us guess the many things you've tried - wasting your time and ours - do list them for us, so we can get the problem solved faster.

  • tgabrielli Level 1 Level 1 (0 points)

    Long story short... Installed, Reinstalled and Uninstalled iPhoto. Everything from versions 8.0 to 9.5.1.

     

    None work... v8.0+ says need a newer version, v 9.5.1 just crashes at startup.

     

    And obviously all the basics of booting, rebooting and all that good stuff. At the moment, the app is back at its initial state were the problem began 9.5.1.

     

     

    Don't know if this helps, but here is the report that pops up when it crashes:

     

    Problem Details and System Configuration

     

    Process:         iPhoto [2005]

    Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

    Identifier:      com.apple.iPhoto

    Version:         9.1.5 (9.1.5)

    Build Info:      iPhotoProject-6150000~1

    Code Type:       X86 (Native)

    Parent Process:  launchd [129]

     

     

    Date/Time:       2011-07-27 15:35:32.017 -0400

    OS Version:      Mac OS X 10.7 (11A511)

    Report Version:  9

     

     

    Interval Since Last Report:          53113 sec

    Crashes Since Last Report:           36

    Per-App Crashes Since Last Report:   36

    Anonymous UUID:                      214BBFBA-C399-407C-A902-79F2A2A2D0F5

     

     

    Crashed Thread:  0

     

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

     

     

    Application Specific Information:

    dyld: launch, loading dependent libraries

     

     

    Dyld Error Message:

      Library not loaded: /Library/Frameworks/iLifeFaceRecognition.framework/Versions/A/iLifeFaceRecognit ion

      Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto

      Reason: image not found

     

     

    Binary Images:

        0x1000 -   0xeffff7  com.apple.iPhoto (9.1.5 - 9.1.5) <65AA38DF-C3AF-A06F-62AA-254A854FA060> /Applications/iPhoto.app/Contents/MacOS/iPhoto

    0x1056000 -  0x1136fe7  org.python.python (2.6.6 - 2.6.6) <2683D847-5FC7-3F47-816E-D1CB71594F4F> /System/Library/Frameworks/Python.framework/Versions/2.6/Python

    0x1181000 -  0x11aafff  com.apple.iPhoto.Tessera (1.1 - 48.10) <39FACFA3-C1A1-CC57-9874-CF0E2EB0684C> /Applications/iPhoto.app/Contents/Frameworks/Tessera.framework/Versions/A/Tesse ra

    0x11c3000 -  0x11eaff3  com.apple.iPhoto.Tellus (1.3 - 48.10) <BE3ADEF1-C058-3660-60C5-5AC69CD5414D> /Applications/iPhoto.app/Contents/Frameworks/Tellus.framework/Versions/A/Tellus

    0x1209000 -  0x1213ff7  com.apple.iphoto.AccountConfigurationPlugin (1.1 - 1) <44FEAB1C-0E0B-7E80-82A5-5CF6287CF5DF> /Applications/iPhoto.app/Contents/Frameworks/AccountConfigurationPlugin.framewo rk/Versions/A/AccountConfigurationPlugin

    0x8fe3d000 - 0x8fe6f9c7  dyld (195.5 - ???) <134323A7-49DC-3A9D-ACFD-32FAD0FD6BA2> /usr/lib/dyld

     

     

    Model: MacBookPro4,1, BootROM MBP41.00C1.B00, 2 processors, Intel Core 2 Duo, 2.5 GHz, 4 GB, SMC 1.28f3

    Graphics: NVIDIA GeForce 8600M GT, GeForce 8600M GT, PCIe, 512 MB

    Memory Module: BANK 0/DIMM0, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F7F7F8300000000, 0x202020202020202020202020202020202020

    Memory Module: BANK 1/DIMM1, 2 GB, DDR2 SDRAM, 667 MHz, 0x7F7F7F8300000000, 0x202020202020202020202020202020202020

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8C), Broadcom BCM43xx 1.0 (5.10.131.36.11)

    Bluetooth: Version 2.5.0f17, 2 service, 19 devices, 1 incoming serial ports

    Network Service: AirPort, AirPort, en1

    Serial ATA Device: Hitachi HTS542525K9SA00, 250.06 GB

    Parallel ATA Device: MATSHITADVD-R   UJ-875

    USB Device: Built-in iSight, apple_vendor_id, 0x8502, 0xfd400000 / 2

    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x1a100000 / 2

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x820f, 0x1a110000 / 3

    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0230, 0x5d200000 / 3

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x5d100000 / 2

  • Terence Devlin Level 10 Level 10 (134,540 points)

    iPhoto is missing background frameworks that it needs to launch. Did you trash the recipts before your various re-installs?

     

    To re-install iPhoto

     

    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)

     

    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

     

    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type

     

    /var/db/receipts/

     

    2c: on 10.7 they're at

     

    /private/var/db/receipts

     

    A Finder Window will open at that location and you can remove the iPhoto pkg files.

     

    3. Re-install.

     

    If you purchased an iLife Disk, then iPhoto is on it.

     

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

     

    If you purchased it on the App Store you can find it in your Purchases List.

     

     

    If that fails you'll need to reinstall the OS

     

    Regards

     

     

    TD

  • tgabrielli Level 1 Level 1 (0 points)

    Hey TD,

     

    Yes I had read your post in another discussion fourm. I did try it out, option 2c, however with negative results.

     

    I'm sure there is some kind of fix before reinstalling the OS. My main concern is losing my iPhoto Library.

     

    Anyone else have a solution? This is the first time I've had this type of issue with my Mac... Kind of reminds me of running Windows... Wow do I not miss those days!!!

  • Terence Devlin Level 10 Level 10 (134,540 points)

    Well this is what's missing or damaged:

     

    /Library/Frameworks/iLifeFaceRecognition.framework/Versions/A/iLifeFaceRecogniti on

     

    If you have another working Mac perhaps you can copy that over.

     

    Regards

     

     

    TD

  • tgabrielli Level 1 Level 1 (0 points)

    Thanks for the timely reply TD.

     

    Just wondering... I have been backing my system up with Time Machine but have never has to restore anything, Would TM allowme to restore iPhoto even though I have updated my OS?

  • tgabrielli Level 1 Level 1 (0 points)

    SOLUTION FOUND without reinstalling OS!

     

    I used Time Machine (for the first time) to restore iPhoto. It restored iPhoto to its previous version (9.1.1) without effecting any of my libraries. In other words, it worked like a charm!!!

     

    And this is why I love MACs... another simple solution!!!

     

    I'm going to try any re-update iPhoto to version 9.5.1... I'll post an update with the results.

  • Doogie125 Level 1 Level 1 (0 points)

    I copied all of the iLife Frameworks from a working install to /Library/Frameworks.  iPhoto is now working fine.

     

    Thanks for the tip, TD!

  • Renegate3000 Level 1 Level 1 (0 points)

    Did the same thing , copied from another Mac!

  • magnusholm Level 1 Level 1 (0 points)

    Hi, I have exactly the same problem as tgabrielli but unfortunately never installed Time Machine. I have therefore no TM iPhoto library to restore (which I understand is proposed as the correct solution). What I have is a copy of my iPhoto library on a HDD but it covers only 80% of the collection (backed up in April last time, I think). Does anyone have an advice for me? Best regards

  • Doogie125 Level 1 Level 1 (0 points)

    See Terence Devlin's solution above.  It does not use Time Machine, but a working copy from another Mac.

     

    I suspect that if you were using Time Machine to back upyour entire hard drive, that you could also find the iLifeFaceRecognition.framework folder in TM and restore it from there.

     

    Best of luck.

  • magnusholm Level 1 Level 1 (0 points)

    Many thanks for your reply. My wife has an older MB with SnowLeopard and iLife 10. Could I use the iLifeFaceReconition.framework from her iLife 10 folder? Or does it has to be iLifeFaceReconition.framework from iLife 11 (which I only could download to my newer Lion-run MBP)? Many thanks!

  • Doogie125 Level 1 Level 1 (0 points)

    I don't remember if the previous version had face recognition.  I don't think using the old framework, if available, would be any worse than no framework.  I have no way to test it, though, so make sure that you have a good backup.

     

    Speaking of which, I thought you had an old Time Machine backup.  The framework may have been saved there.

  • samantacalabro Level 1 Level 1 (0 points)

    I followed your steps, because I'm having a big issue with my iphoto 9.5.1 version. I posted earlier my problem (https://discussions.apple.com/message/16267189#16267189) and kept doing research about it.

     

    I followed all the steps you mentioned above (unistall, reinstall and now upgrading iphoto, becuase it doesn't let me open it as long as I don't do the upgrade of ilife 11 to a version 9.1).

     

    The thing is, how do I restore all my original photos? Do I go to my time machine and restore my iphoto originals from the pictures folders? I'm really afraid it will crash again! so I cannot upgrade to 9.5.1?

     

     

    Thanks a lot for any hint!