Previous 1 2 3 Next 102 Replies Latest reply: Dec 7, 2014 6:14 AM by NikonMan13
dudyk Level 1 Level 1 (0 points)

Now we have CAPT Printer Driver Ver.3.36 for Mac OS X v10.7

But older driver for lbp2900 no supported with new CAPT, old CAPT no supported with 10.7.

How install LBP 2900 in OS X Lion?


Mac OS X (10.7)
Previous 1 2 3 Next