6 Replies Latest reply: Mar 27, 2012 4:30 AM by samw2
Bernie300374 Level 1 Level 1 (20 points)

I use BusyCal as my main calendar, although on occasions I do use iCal. I have my MobileMe accounts on both of them, but every time I make a change on BusyCal, iCal will automatically open in the background. This has only started to happen since installing Lion, does anyone know how to stop this from happening, other than deleting my account in iCal, which I don't want to do

  • William Quattlebaum Level 1 Level 1 (35 points)

    Bernie - I've just moved from Now Up-to-Date to using BusyCal and have some iCal confusion as well. The problem of both launching went away for me when I was able to tell iCal to no longer ask if it should be the default calendar application.

     

    I don't see this in iCals prefs - it just popped up one time when launching and now that I've told it not to be default and not to ask again things work better. I should add I am now using Lion.

     

    My last problem is that in MobileMe sysn I no longer have a Calendar entry. I can sync Bookmarks, Contacts, Dashboard, etc - but Calendar shows for an instant in the list then vansishes. I'm in the process of searching Communities for info when I found your entry.

  • Roger Wilmut1 Level 9 Level 9 (72,485 points)

    You can set BusyCal as the default calendar program in BusyCal Preferences>Advanced.

     

    The setting in System Preferences>MobileMe>Sync for Calendars is no longer relevant: iCal does not sync using this method any more, but reads the calendars from the MobileMe Server. Please see this troubleshooting page:

     

    http://support.apple.com/kb/TS3397

  • Bernie300374 Level 1 Level 1 (20 points)

    That's how it's set up, BusyCal as the default calendar, but anytime I add/delete an event in BusyCal, iCal automatically opens up, I can't seem to stop this from happening.

     

    William, when I first set up iCal on my Macbook, I had that same prompt and the problem of iCal opening up automatically didn't happen, it was only happening on my iMac. So for trouble shooting, I deleted the account in BusyCal on my MacBook, then added it again, then the Macbooks iCal started to open up automatically as well!! Like you, I've never had the prompt from iCal again asking me about the default calendar...strange???

  • Mark Biech Level 1 Level 1 (5 points)

    I have the same problem ... I tried to check the box that asked about iCal being the default calendar when the error happens ... restarted ... created a new event in BusyCal ... iCal starts up right away ... tried unchecking iCal in Mobile Me Sync which we know isn't something to worry about anymore, but that also didn't work ... so ... I went into iCal preferences and deleted my account .... at first I started to delete my calendars, but the SYNCS ... don't do that ... I just went into prefs and accounts ... took out my account and now I can use BusyCal with no problems ... but .. I can't use iCal ... which is ok with me actually ....

  • paulsalter Level 2 Level 2 (465 points)

    I had this initially when I upgraded to Lion, something seems to have changed with push notifications (or SL didnt have push calendars)

     

    open up iCal, go into preferences and accounts, change your mobile me from push to 5 mins (might work with 1 min, not tested that), this stops it opening when you change anything in BusyCal

  • samw2 Level 1 Level 1 (0 points)

    I had this problem too, BusyCal have it covered:

     

    http://www.busymac.com/faq/index.html#lion-push

     

    In short, change your iCal Account preferences from 'push' to a time interval.