Previous 1 2 3 4 5 6 Next 130 Replies Latest reply: Oct 23, 2015 11:10 PM by Eclectickle Go to original post
  • Buddy99 Level 1 (0 points)

    You have to sleep the computer and after 5 min re open it easy !!!!!!!!!!!!

  • NintendoNaut Level 1 (0 points)

    Kyen99's solution worked for me.  Thanks a lot man!

  • b@lde@gle Level 1 (0 points)

    Hi ****_voyager,


    I downgraded my Parallels to 6 as I found it buggy as **** and there was an issue with full screen mode.  Has this been fixed in the upgrade?



  • Orion7 Level 1 (25 points)

    Thanks very much for the app, kyen99!


    My problem was that once I unplugged a set of exterior speakers, the volume control icon was grayed out and the controls inactive, and I was getting no sound. I tried the Terminal command and kyen's app, and I could see the process happen (the icon changed to indicate no volume, but then returned to the original level), but the icon in the menu bar remained gray and inactive.


    Then I plugged the speakers back in (which made the icon a nice black again, and made the controls operative) and ran the app. This time, when I unplugged the speakers, the volume controls continued to work and I had sound. If the command didn't work for you, you might want to try it again with something plugged into the headphone port.


    Thanks very much to those of you who provided the Terminal script and to kyen for the app.

  • Tracy Rasmussen Level 1 (70 points)

    I have this same problem after unplugging speakers that I have been using for a month with no problem. Now, no internal sound except the chime. I am using Leopard.

    The volume control in the upper toolbar has the ball all the way at the top but it is greyed out and not moveable. Nothing in sound preferences is changeable to help this. When I push the volume control F4 or F5 or mute they all have a circle with a line through it showing that there is no sound. Resetting PRAM didn't help and I went into MIDI utility as someone else suggested and mute was not checked in the boxes there, though next to M the sound is turned all the way down but it is greyed out there too and I can't change it.  I tried the SMS reset too and that did not help either. ???

    And I assume the app will not work with Leopard.

  • kyen99 Level 1 (0 points)

    The app should totally work for Leopard.  There are two ways to test if it will work.  When you have the problem...




    Run Activity Monitor and find the process called "coreaudiod", select it and press Quit Process.




    Run Terminal and do: "sudo killall coreaudiod" (without the quotes)


    Both methods will ask for your admin password.  After running either of these it might take a few seconds for audio to start working.  If either of these temporarily fixes your problem, then the app will probably work for you.  The app just does the exact same thing.  It isn't really lion-specific but I never had this problem on snow leopard or leopard.



  • Scott Spindler Level 1 (10 points)

    Since upgrading to OS X 10.7.2 this issue has gone away for me.

  • Tracy Rasmussen Level 1 (70 points)

    Thanks. I did the Activity Monitor procedure and restarted (and did PRAM reset again just for good measure on restart) and no change. I wonder if I should do it with the external speakers plugged in, as someone mentioned above. I'm not where they are today, though.

  • Tracy Rasmussen Level 1 (70 points)

    I just noticed taht when I go into Audio MIDI Setup, it says under Audio Output, "Output is not supported". No options. What I had been looking at before, where the volume control is greyed out next to "M", is the Audio Input side.

  • Tracy Rasmussen Level 1 (70 points)

    OK, I got back to my office where the speakers are, plugged them in and the sound volume control became black and moveable again. But when I unplugged them it went back to gray. So I plugged them back in and ran the Activity Monitor process as you suggested and it worked. Even when I restart now, it is usable again. If it goes back to gray in the future, I will run the app. THANK YOU kyen99!

  • pyrog Level 1 (0 points)

    Unfortunately, not for me. It's better, but the problem is still there.


    Macbook 13", last 2009

  • TomBille Level 1 (0 points)

    There is another solution to reset the Coreaudio.


    Hold the ALT Key and right lick the Speaker Icon to quickly switch between available audio ouputs. Most of the time switching one or two times between speakers and USB Audio remedies the problem.


    - The problem persists there since Tiger for me

    - e.g. starting Toast reliable kills my Z-10 Logitech Speakers and other USB Audio, since whenever.

    - Killing Coreaudio works also for me.


    I guess it has todo with how certain programs scan the USB Bus.

  • TomBille Level 1 (0 points)

    some more points :


    - as long as the process (e.g. Toast) is scanning for drives or whatever its doing with the USB-Bus the reset doesnot work.

    - sometimes it has to be done 2 or 3 times, either by switching the device or killing the coreaudio driver.

  • 12johan21 Level 1 (0 points)

    This worked to me thanks to Kyen99(THANK YOU!):


    1. Go to Applications > Tools > Terminal    and open it.

    2. Copy and paste this in the Terminal window:

    sudo killall coreaudiod


    3. klick enter and wait for 5 sec +/-

    Then hopefully it'll all be ok and the sound's working as normal.


    If this worked for you then thank Kayen99. He's awesome

  • ClaudiaGB Level 1 (0 points)

    I've just upgraded from a white MacBook to a 13" i7 MacBook Pro that came with OSX Lion. I've had it just over 3 weeks and I've always had this problem. I'm a student so spend most of my day working with headphones, but of an evening when I want to watch films using my internal speakers this happens.  It also happens during the day if I remove and re-plug the headphones more than x times (about 5).  It's really inconvenient having to reboot, and I don't have the problem caused by X11 because I'd never even heard of it before reading this thread.

    Also, my iTunes won't quite unless forcequite, I don't know if this is related?

    Any advice on what I should do as it's inconveniencing my life tremendously.

    For reference, all my hardware is Mac compatible as my headphones are Beats Pros.

    Thank you.

Previous 1 2 3 4 5 6 Next