Previous 1 3 4 5 6 7 Next 130 Replies Latest reply: Oct 23, 2015 11:10 PM by Eclectickle Go to original post
  • marcusfromtuebingen Level 1 Level 1

    Here's another goodie from the Lion audio failfest. I'm streaming my audio from a mid 2010 MacBook Pro (17'') to a Logitech bluetooth adapter my speakers are connected to. With some trickery I got this setup to a point where it chose to work reliably, more or less. Some days ago I used my Samsung bluetooth headphones on said machine, only to see all of my audio deeply frozen - to a point I had to dance the nuke-your-whole-Lion-BT-scheme-and-rebuild-from-scratch-dance. Brilliant. Now all is back to good working order - except the volume control for said Logitech device. Increasing or decreasing volume (method doesn't matter) will invariably kill sound alltogether, which can be brought back instantly by tapping the mute button on the keybord twice. Feels almost kinda … playful. Did I mention that Logitech thingie works like a charm from my original iPad, volume and all?

  • iMichiel Level 1 Level 1

    Hi, Today i reveived my new Mac Mini 2.7 2011 with the 6630m.


    At first i had all the trouble you all had till i found this solution;



    Follow the steps, including the paste in Terminal and you will all be fine !


    Everything works now. Ac3, Dolby Digital, etc. In VLC and Quicktime alike !


    Good luck and anjoy your minis !




  • Perr0 Level 1 Level 1

    This Lion audio problem is driving me nuts. None of the solutions proposed here or in any other thread in this forum has worked for me. What was working until today was running all the automation scripts with Onyx. But today this solution stopped working too (yesterday's update related, maybe).


    Well, what makes me really angry is that I don't see Apple say a word about this. Looks like they're not even looking at it.

  • Perr0 Level 1 Level 1

    kyen99, I have no coreaudiod process running.

    kyen99 wrote:


    The app should totally work for Leopard.  There are two ways to test if it will work.  When you have the problem...




    Run Activity Monitor and find the process called "coreaudiod", select it and press Quit Process.




    Run Terminal and do: "sudo killall coreaudiod" (without the quotes)


    Both methods will ask for your admin password.  After running either of these it might take a few seconds for audio to start working.  If either of these temporarily fixes your problem, then the app will probably work for you.  The app just does the exact same thing.  It isn't really lion-specific but I never had this problem on snow leopard or leopard.



  • Perr0 Level 1 Level 1

    I finally found a definitive solution. At least (and hopefully) until Apple releases its official one:


    Running Windows 7 on bootcamp partition.



    I know, it's sad. But it's true.




    Last time I had a computer with no audio was on 92 or 93. It was a 486 DX2 66. And it was audioless only before I bought a Creative Labs Multimedia Kit. I've had audio ever since. At least until two months ago, when I updated to Lion.


    Thanks Apple for reminding me of this nostalgic time.

  • kyen99 Level 1 Level 1

    Make sure that "All Processes" is selected in Activity Monitor.  I believe the default is "My Processes", which won't show you system daemons.

  • Perr0 Level 1 Level 1

    You were right, selecting "All Processes" showed coreaudiod. But quitting it does not work for me though. Same for sudo killall coreaudiod.

  • kyen99 Level 1 Level 1



    Either your problem is with something besides coreaudiod or it's not restarting itself properly.  Make sure after killing it (either method) that it shows up again (takes about 5sec on mine to restart) and that when it does it has a different PID than it did before you killed it.


    If it doesn't show up again, then you could try restarting by doing: "sudo coreaudiod".  If it is there with the same PID as before, it didn't die.  Try killing it again. 


    If it does come back with a new PID but you still have no audio, then your problem is something completely different.  I don't have any idea what else to try.

  • Perr0 Level 1 Level 1

    kyen99, thanks for your attention. coreaudiod does show up again and it has a new PID. So I suppose my problem is not related to it.


    I've read some posts before in this thread that Parallels 7 seems to affect audio in Lion and I do have it installed. Uninstalling it seems to solve the problem, but I just can't try that now.


    Thanks anyway.

  • HinamoriAmu Level 1 Level 1

    I don't have Lion, (not really sure what I have) but I do have the same problem, like when I unplug my headphones no sounds comes out of the internal speakers and I have to restart my computer

  • wazZzif Level 1 Level 1

    I'm using MBP with OS Lion. The speakers I have are Altec Lansing XT1 (Portable USB-Powered).


    After watching a movie last night I just closed the lid without unplugging the speakers. Next day I unplug the speakers and turn MBP on. I could hear the volume adjustment sound but no matter what I played (youtube for instance), there was no sound. So I plugged in the speakers again, went to 'System Preferences > Sound > Output' and chose 'Internal Speakers' which did the job.


    Reason I knew the workaround already was because everytime I need to use these speakers, I have to manually select it in 'System Preferences > Sound > Output' anyways.


    Hope this info is of some use.

  • TomBille Level 1 Level 1

    This is much more quickly available by holding alt (also called option key) and clicking on the loudspeaker symbol in the upper right corner. I already mrntioned that - switching around the sound prefs like that resets core audio too.

  • TomBille Level 1 Level 1

    Enter this on the commandline / terminal with the Lion Audio Fix so you wont have to enter the admin password anymore.


    sudo chown root /Applications/

    sudo chmod 4000 /Applications/

  • rem13 Level 1 Level 1

    Having same problem. Extremely frustrating! I can't believe there's no official word from apple on this. My machine is useless for itunes, Final Cut, Premier, training video, skype.... In other words, sound is NOT a "nice to have feature". I don't understand how this is not a Pri-1 bug to be resolved.


    I have tried all the fixes here and quite a few others that I've found outside these forums. Nothing works. I have reinstalled Lion (over the top of existing) as well. Still nothing. I don't see how it's a 3rd party software issue either, at least not for me since I didn't add anything between when things worked and when my sound components vanished.


    I'm on a MBP 17" purchased in July 11. I don't think it's a hardware issue.


    Man, I REALLY don't want to rebuild this machine from scratch.


    If Apple thinks they can distribute a new OS via app store only, then the upgrade path should be flawless! This is certainly NOT flawless!


    I'm ****** off apple!

  • keeth Level 1 Level 1

    Had this problem since I got my new MBP (Early 2011, 13-inch).


    Genius dude recommended I reinstall Lion (resetting PRAM did not work), he emphasized that I should erase the disk and do a complete re-install.


    I did that a couple days ago (erased disk, installed 10.7.0, then recovered my stuff with Time Machine), and it was still broken.


    Today Software Update pulled down the 10.7.2 update and some other updates, and after reboot, the problem appears to be gone!


    Hope it stays this way!

Previous 1 3 4 5 6 7 Next