9 Replies Latest reply: Aug 17, 2012 1:45 PM by David Schwartzer
sborowski Level 1 Level 1 (0 points)

After updating Safari to 5.1 the Cocao plugin is missing / doesn´t work?  Any idea how i can reinstall the plugin? I need the plugin for Citrix access.

 

Error Message from Safari:

Dieser Browser verwendet nicht das Java Plug-In Cocoa.

1) Vergewissern Sie sich, dass JVM 1.4.1 oder höher installiert ist

2) Überprüfen Sie, ob dieser Browser Java für Cocoa unterstützt (wie beispielsweise Safari)

 

 

Any Idea?

 

thanks in advanced

Sebastian


Safari 5.1
  • MacAlexT Level 1 Level 1 (0 points)

    I've the same problem here.

  • David Schwartzer Level 3 Level 3 (770 points)

    I have the same issue.  Tried running Safari 5.1 in 32 and 64 bit mode but that didn't help.  Also tried loading Java 32 bit and 64 bit first but that didn't fix it either.  Any help would be appreciated.

  • MacAlexT Level 1 Level 1 (0 points)

    A possible workaround for this issue is to reinstall Safari 5.0.5 parallel to new Safari 5.1. I did this by recovering the older Safari version from TM backup.

     

    Another way is described in this hint: http://hints.macworld.com/article.php?story=20110722154439693 

  • moz4lou Level 1 Level 1 (0 points)

    Same problem:

    This browser does not use the Cocoa Java Plug-In.

    1) Make sure that the JVM 1.4.1 or later is installed

    2) Check that this browser supports Java for Cocoa (such as Safari)

     

    With several Mac users to support the dutch Amstelveen Council would like to be able to offer a solution other then the workarounds. These prove to be overstretching the capabilities of the average user.

     

    However another question remains: is the solution forthcoming from Apple or is this a Java problem?

  • jannina Level 1 Level 1 (0 points)

    Keep getting a message saying that the Java plug-in for Cocoa is missing, so I cannot access work files that were easily accessed before I upgraded to Lion OSX. Is this a Lion OSX issue or is it a Java issue? In any case I need help like the other people on this community post. Thanks.

  • cqexbesd Level 1 Level 1 (0 points)

    I answered this on another thread but to aid people Googling for the error I will answer here as well. The error message is produced by some javascript that just checks for a particular plugin by file name - one that no longer comes with Safari 5.1. If you go tohttp://www.ugh.net.au/~andrew/jsam.xhtml and download the dummy JavaPluginCocoa.bundle it gets you past the script and everything seems to work fine. Downgrading Safari seems (a) hard work and (b) opening yourself up to security issues (as I assume Apple probably won't be releasing updates for it).

  • David Schwartzer Level 3 Level 3 (770 points)

    Thanks for your tip.  Unfortunately, it did not seem to resolve the problem for me.

     

    Perhaps I am reading your web page wrong but it seems to say that the file to install in the Library is: JavaPluginCocoa.bundle.  That file already exists in my Library.

     

    I downloaded the file you suggested but that file is named JavaPluginCocoa.plugin.  I installed this as you suggested but it had no affect.

     

    What am I doing wrong?

     

    Regards,

     

     

    David

  • cqexbesd Level 1 Level 1 (0 points)

    Hi David,

     

    The file should be called .bundle rather than .plugin. You can rename the file or download it again as I have just renamed the file in the zip archive. Sorry about that. You can check what plugins you have loaded using "Help -> Installed Plug-ins" inside Safari. Make sure it has loaded JavaPluginCocoa.bundle.

     

    If it has but you still get the error let me know - I don't have access to a mac for a few weeks to test it out again but it shouldn't be too hard ot work out whats wrong.

     

    Thanks,

     

    Andrew

  • David Schwartzer Level 3 Level 3 (770 points)

    It appears that as of Safari 6 (Mountain Lion) this problem has been resolved.  I am now able to log into the Citrix environment properly.