Previous 1 2 Next 18 Replies Latest reply: Mar 22, 2013 3:20 AM by Nemrod
phenyl007 Level 1 (0 points)

Hi All,

 

I am trying to format a 3TB WD Elements (USB 2) external HD, GUID, 1 Partition Mac Extended Journaled. The formatting goes ok.

If I click on the "3TB WD Ext HDD 1021 Media" on the left in Disk Utility and hit "verify disk", I get the following error message:

 

"the partition map needs to be repaired because there's a problem with the EFI system partition's file system"

A 'repair disk' goes through without hitch, but if I hit 'verify disk' again, I get the same error.

 

I wonder if I can just disregard this or if I will encounter problems somewhere down the line.

 

 

Thank you very much for your help.

 

 

(Verify of the actual partition does not yield any problems)


MacBook Pro, Mac OS X (10.7)
  • jhmcaleely Level 1 (0 points)

    I can report the same symptoms on a G-drive mini (500Gb).

     

    In my case it seems that this prevents the disk being used for an encrypted filevault backup.

  • Sonicray Level 4 (1,470 points)

    By the way, did you updated your WD drive's firmware? before updating to Lion?

  • Walter Wedler Level 2 (225 points)

    I am having the same problem with the same 3TB WD Elements. Where is the firmware update? When I asked the WD tech about a firmware update he nixed and tried to have me reformat in Apple format!! When I told him it needs to be GUID he switched gears to that. After which the same: "Problems were found with the partition map which might prevent booting. Error: The partition map needs to be re...h the EFI system partition's file system" returning after I removed 3 TB of my life of the drive (hours!) Maybe there are nice people out here that know better than the "Mac" WD technicians. Help please.

                                                                                  W.W.

  • LexSchellings Level 6 (8,747 points)

    There are WD disks that are not compatible with Lion, also the WD Smartdisk app is not compatible. Make sure you have the latest compatible Firmware on the WD Disk, and maybe there now is a new update for Smartdisk (I am not sure it is there already).

    Research the WD sites.

  • Pekeler Level 1 (0 points)

    I have the exact same problem with my new Hitachi Touro Desk Pro 3TB.

  • artsvision Level 1 (0 points)

     

     

    I just bought a Seagate 3TB USB Expansion External HD and have exactly the same problem when verifying the disk.

     

    "The partition map needs to be repaired because there’s a problem with the EFI system partition’s file system.”

     

    It repairs ‘ok’ but get the same error message when verifying again.

     

    As this thread has been running for 4 months or so and its still a problem!.... Has anyone had problems using their ‘drives’ while ignoring the error message?

     

    I feel very uneasy trusting the drive as a reliable backup and I'm surprised that Apple hasn't sorted this potentially serious issue out with a 'fix'.... Most especially as it appears to be a fault with 'Lion' rather than the various brands of 3TB external drives?

     

     

     

     

  • dood man Level 1 (0 points)

    I have a Seagate 4TB GoFLex usb 3.0 drive and am getting the same error. I just bought it yesterday and I think I'm going to return it.

  • TomMcK Level 1 (0 points)

    These instructions from WD helped me out:

     

    http://wdc.custhelp.com/app/answers/detail/a_id/3865/p/208%2C339/c/130/session/L 3RpbWUvMTMyNDUwNTY2Ni9zaWQvZnBDaHJhTWs%3D

     

    The drive now appears ready for time machine.

  • LexSchellings Level 6 (8,747 points)

    I think this is not an Apple problem, but an incompatibility problem. Read the post of Tom, maybe it helps you too.

  • misfitactual Level 1 (0 points)

    I just got this same error message when I was checking my external backup drive which is a G-Drive USB mobile 750GB. I researched the issue on the Web and tried all suggestions. Nothing seems to work. It seems this issue crept up after I updated my OS to the latest version. Does Apple know something and hasn't announced it on the forum board or anywhere else? I am suspicious. I read someone's post on another site that hinted that the problem might be linked to OS. They went on further to say it's likely a deep OS glitch. If anyone has any suggestions for how to eliminate this error I would greatly appreciate the guidance. I am lost for what to do next.

  • Kelly John Carney Level 1 (35 points)

    Worked perfectly for me.  I chose to use 3 partitions and followed the same set of instructions.  Chose "3 Partitions" from Partition Layout dropdown.  Also used GUID Partition Table after clicking Options...

     

    Screen Shot 2012-03-13 at 3.57.51 PM.png

  • artsvision Level 1 (0 points)

    Kelly, have you 'verified' the disk?..... Formatting and partitioning is fine - the error only occurs upon hitting 'verify disk' which gives the message : 

     

    "the partition map needs to be repaired because there's a problem with the EFI system partition's file system"

     

    It repairs 'ok' but the repeat error message occurs when verifying again.

  • Kelly John Carney Level 1 (35 points)

    Verified just fine.  Ran CCC backups and Time Machine backup too.

    Screen Shot 2012-03-14 at 4.04.55 PM.png

  • Nemrod Level 1 (0 points)

    @ Kelly John Carney

     

    The problem appear when you verify the disk, not the partition.

     

    @ others

     

    I have the same probleme on 2 WD Elements Desktop on 10.7 and 10.8, no prolems on 10.6.

     

    Apple support says that it shouldn't be a problem if it's only for data but honestly i don't want to risk my data and they suggest to format using PPC partition table.

Previous 1 2 Next