Previous 1 5 6 7 8 9 Next 129 Replies Latest reply: Nov 22, 2014 2:03 PM by Wisemeister Go to original post
  • dinglydell Level 1 Level 1 (0 points)

    Sorry, what I meant was Photoshop CS6. I have CS6 and am on Snow Leopard OS 6.8. I also have a Canoscan 8400F.


    I will be upgrading to Mountain Lion very soon and just wanted to know whether the workarounds Rabrack and others have come up with to get the 8400F scanner working will work on Mountain Lion and CS6.


    If any readers of this discussion have that combination working please let me know! Thanks and happy new year!

  • MlchaelLAX Level 4 Level 4 (1,975 points)

    p717 wrote:


    Hi Dinglydell,

    My CS2 was not supported in MT.  It worked in SnowLeopard but needed Rosetta.  Lion would not support CS2.  If you have Photoshop 6 you might want to verify MtLion will support it.  CS6 works fine in OS X 10.8

    Hope things work out for you.


    Photoshop CS working concurrently with Lion (or Mt. Lion) with Snow Leopard (and Rosetta) installed into Parallels:



                                  [click on image to enlarge]


    Full Snow Leopard installatilon instructions here:


  • p717 Level 1 Level 1 (0 points)

    Hello Dinglydell,

    I have CS5, OS X 10.8.2 and an 8400F.  IMHO you only lose by not trying the RABRACK solution.  Can it make things worse any worse? If it saves you buying a new scanner then great!

    To me the hero of 8400F users is rabrack and the solution provided has worked a number of us!  It did fine for me with both Lion & continues to work in MtLion.  I can only assume CS6 will work (sorry I misunderstood you…my concern was that "Photoshop 6" is an old application and they do not run on Lion or MtLion).  You can read back through the thread to see what minor snags I overcame and the links for drivers.  All is working fine for me {:-))

    ~~~~~ Good Luck and may 2013 be full of Light, Laugher & Peace! ~~~~~

  • Douglas Aitken Level 1 Level 1 (0 points)

    Thanks for the post p717. I guess I am driver challenged. No luck. But in reading these posts, decided to give VueScan a try. The good thing is you can do tests with the download before purchase. I downloaded it, and initially it did not recognize my 9950F, but gave hints on how to get it recognized. Did the hint and bingo, was able to use the scanner as advertised.


    So, it was worth the $29.95 for me to get this thing up and running.


    My thanks to everyone in this thread. Very interesting and informative reading.


    Doug Aitken

  • p717 Level 1 Level 1 (0 points)

    Hi Doug! $29 is cheaper than a new Scanner!  Wishing you success in all your scans!  The one feature I needed was to be able to scan slides so until my 8400F is completely out of date I shall be very pleased!  Even if it only does one slide at a time now as opposed to the 4 at a time it used to!  Small compromise... just makes it a little more time intensive!  Wishing you success in all your scans! 

  • p717 Level 1 Level 1 (0 points)

    Hello Adam! In case it was not cleared up the Image Capture works fine for me however, it can not do slides and with thousands of slides I needed that feature so I could interface with CS5 and the 8400F!  So rabrack is still my hero!  Happy scanning!

  • labarker Level 1 Level 1 (5 points)

    Why can it no longer do 4 at a time, p717? Have you broken something? This wasn't exactly a cheap scanner when it was new. I remember when I went looking for a new scanner there was only one other scanner on Canon's web site that was more expensive than the 8400F. It was twice the price of the 8400F.

  • dinglydell1 Level 1 Level 1 (0 points)

    I am so sorry I have taken so long to reply to this post. Apple locked me out of Apple discussions when I updated to OS10.8.2 from OS6.8 and I had to change my Apple ID. That caused all sorts of problems and I had to create another Apple Communities ID, and my forum username has also had to change.


    Anyway, I have got my Canoscan 8400F working with CS6 and Mac OS 10.8.2 at last! Thanks all.


    It's such a shame though that Adobe chose to get rid of the 'import' function which allowed far more scanning options than the rather basic Canoscan does. I also have Silverfast 6.6, but that won't work with OS10.8.2. Swings and roundabouts and much frustration!


    Jamesqu's post helped me sort this out:


    Thanks again to all.

  • markelliot2002 Level 1 Level 1 (0 points)

    OMG your a life saver...How in heaven's name did u figure that combo out?

    Many many thanks


  • Wisemeister Level 1 Level 1 (0 points)

    Just want to add that I too was able to get my 8400f up and running on OSX 10.9.2 following Rabrack's detailed instructions (and even opening the scans right into Photoshop CC 2014). During the steps, the scanner did not show up in Image Capture which was initially discouraging, but I opened the Toolbox anyway and it was working like a charm. Disappointing Canon terminates support and updates for its products. I suppose it makes more economic sense for them to drive sales of new products but it still leaves a bad taste in my mouth. The hardware works perfectly well with the OS if you'd just allow it and make it easy for customers to use it. Thanks for hacking the system Rabrack and good luck to everyone else.

Previous 1 5 6 7 8 9 Next