Previous 1 4 5 6 7 8 Next 119 Replies Latest reply: Sep 27, 2012 3:44 PM by Macnetmedia Go to original post
  • Mike Hardy Level 1 Level 1 (0 points)

    Confirmed fixed for me with the public release of 10.7.3 and a 500GB Hitachi G-Drive as well. I used Disk Utility, selected "Erase" tab, chose "Mac OS X Extended (Journaled, Encrypted)" in the Format drop-down, and all was well.

  • emarsh Level 1 Level 1 (0 points)

    After trying different options on my 10TB external HW RAID (SSI 5x3,5" USB3,FW800,FW400,eSATA) system the only functional option was USB. I did not try to do a convert via diskutil in terminal mode as I had a brand new 12TB hardware system working in RAID5. I tried FW800 and 400 with the error "Cant find logical disk after operation"- or something like that. Switched my external RAID to USB and the procedure was over in a flash :-) I'm using WD green 5x2TB drives from 2010. After the "encryption", although there is noting to encrypt yet, I unmounted and swithed to FW800. The drives showed up after I entered the password so now I'm about to copy some files and check if the result is truly encrypted and functioning (I'm a paranoid little boy)... Stay tuned :-)

  • Property Level 1 Level 1 (0 points)

    10.7.3 fixed the issue for me (G-Drive Slim 500GB). I went to System Preferences / Time Machine / selected the drive, ticked Encryption, set the password, and everything worked.

  • Pecos Bill Level 1 Level 1 (75 points)

    emarsh wrote:

     

    …the only functional option was USB…

    Others on here have said that their products have worked after moving back to the desired interface (FW, etc) so you ought to move off USB now that it's formatted. Curious which do you have, GUID or Apple partition scheme?

  • emarsh Level 1 Level 1 (0 points)

    GUID. Everything works fine now on FW800 (knock on wood) :-) I even did a loop-through on my RAID device to a second disk and did a wipe on that... So far so good ;-)

  • mhofert Level 1 Level 1 (0 points)

    I use OS X 10.7.3 on the latest MacBook Air and tried to format a LaCie disk (300 GB) as MAC OS Extended (Journaled, Encrypted). I tried it via Disk Utility and via TimeMachine, no luck -- quite frustrating:

     

    Screen Shot 2012-03-03 at 15.51 .png

    Screen Shot 2012-03-03 at 15.52 .png

  • mhofert Level 1 Level 1 (0 points)

    I also tried to encrypt the disk through CarbonCopyCloner -- again, no luck:

     

    Screen Shot 2012-03-03 at 16.18 .png

  • James_Dean Level 1 Level 1 (0 points)

    WORKAROUND FOUND!

     

    I'm using a 4TB (2TB+2TB RAID0) via Firewire with 10.7.3

     

    The problem seems to be the re-arranging that Filevault2 (aka Core Storage) wants to do to add the EFI partition. It needs that at the beginning of the disk and the step that is failing is the move that provides that space if done via USB and FW. So, very "simple" workaround:

     

    MOVE the first partition start so that it starts at block 409640 (That number was determined by looking at some other FileVault2 encrypted disks.)

     

    I used iPartition, but gdisk or whatever that can do it in place is fine. Note that this can take a very long time (2 and half days in my case!)

     

    Fire up the convert:

     

    diskutil cs convert disk5s1 -passphrase mypassword

     

    and et voilà !

     

    Started CoreStorage operation on disk5s1 mydiskname

    Resizing disk to fit Core Storage headers

    Creating Core Storage Logical Volume Group

    Attempting to unmount disk5s1

    Switching disk5s1 to Core Storage

    Waiting for Logical Volume to appear

    Mounting Logical Volume

    Core Storage LVG UUID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX

    Core Storage PV UUID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX

    Core Storage LV UUID: XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX

    Core Storage disk: disk4

    Finished CoreStorage operation on disk5s1 mydiskname

    Encryption in progress; use `diskutil coreStorage list` for status

     

    My other option if that had not worked would have been to dig out the eSATA card for my 17"MB and do the conversion first that way, interrupt it and the finish via FW. Not everyone has an eSATA interface or an external device that does both, so I thought I'd be a Guinea Pig to see if it was needed.

     

    Please report back here if this works for you?

  • James_Dean Level 1 Level 1 (0 points)

    Ooops, forgot to include the "proof" it was 4TB:

     

    $ diskutil list

    .

    .

    .

    +-- Logical Volume Group XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX

        =========================================================

        Name:         mydiskname

        Sequence:     1

        Free Space:   0 B (0 B)

        |

        +-< Physical Volume XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX

        |   ----------------------------------------------------

        |   Index:    0

        |   Disk:     disk5s1

        |   Status:   Online

        |   Size:     3998614552576 B (4.0 TB)

        |

        +-> Logical Volume Family XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX

            ----------------------------------------------------------

            Sequence:               6

            Encryption Status:      Unlocked

            Encryption Type:        AES-XTS

            Encryption Context:     Present

            Conversion Status:      Converting

            Has Encrypted Extents:  Yes

            Conversion Direction:   forward

            |

            +-> Logical Volume XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXXX

                ---------------------------------------------------

                Disk:               disk4

                Status:             Online

                Sequence:           4

                Size (Total):       3998295781376 B (4.0 TB)

                Size (Converted):   62836965376 B (62.8 GB)

                Revertible:         Yes (unlock and decryption required)

                LV Name:            mydiskname

                Volume Name:        mydiskname

                Content Hint:       Apple_HFS

     

    :-)

     

    Oh and another +1 for iPartition: It converts APM to GUID! (I really should have done my homework before putting TBs of data on a new drive.)

  • Zephon Level 1 Level 1 (0 points)

    Hi James_Dean,

     

    Unfortunately your solution didn't work for me. It turned out that the first partition already starts at this block (409640).

     

    Also, I can't move to any other interface with my USB-only LaCie Porsche HD and my MBA 11".

     

    If you have any other suggestions, I'm happy to hear from you.

     

    Thanks,

    Zephon

  • CarltonBanks Level 1 Level 1 (15 points)

    This actually now works perfectly fine for me.

     

    Looks like latest version of Lion with patch resolves this issue. 10.7.3

     

    Thank you.

     

     

    In steve we trust.

  • srizvi1 Level 1 Level 1 (10 points)

    I'm dealing with this now. Have a 320gb older Western Digital Hard Drive. The connection was via USB (will try Firewire next - but need to find my Firewire 400 to 800 cable). Right now I have 10.7.4 and I believe that on 5/23/2012 when I Tried this last I had that same version. If not, it should have been 10.7.3.

     

    First Tried to encrypt within Time Machine by selecting "Encrypt Backup Disk":

     

    Screen Shot 2012-05-23 at 3.49.23 PM.png

    Got the error that says "There was an error preparing the Time Machine backup disk... Invalid Request"

     

    Screen Shot 2012-05-23 at 3.51.44 PM.png

    Then went into Disk Utility next and tried to encrypt from there:

    (Selected "Mac OS Extended (Journaled, Encrypted"):

    Screen Shot 2012-05-23 at 3.52.11 PM.png

    Got a "Disk Erase failed with the error: Unable to create a new Core Storage logical volume group."

     

    I did the verify disk and repair disk, and tried again, still no luck.

  • sushiman Level 1 Level 1 (10 points)

    I still experienced this issue in Lion 10.7.4, just like srizvi1 above, in my case from a 2007 MBP to a G-TECH 2TB drive purchased in 2011. Perhaps this will be helpful:

     

    At first all attempts failed, whether I had connected the drive via USB, FW400 -> FW800, or FW800 -> FW800.

     

    I was about to give up, but on a whim, I tried connecting the drive via USB to a different USB port on my MBP than the first one I'd tried. This time it worked, finally, using Disk Utility. (I still got an error message, however, when using the Time Machine setup checkbox.)

     

    I don't know whether there was something different on the computer about the health of the two different USB ports, or whether I somehow ended up with a better connection, or what, but it worked.

     

    Once the initial encryption was complete, I switched to FW800 and the Time Machine backup is now underway.

  • sushiman Level 1 Level 1 (10 points)

    Well, I have to update my earlier comment, unfortunately. The reformatted and encrypted Time Machine backup completed but then stopped working -- the disk wouldn't even mount, all of a sudden. And simultaneously I've also been experiencing some minor booting problems and similar Disk Utility error messages, all exactly as described in another thread about FileVault 2 on startup disks after the 10.7.4 update, here:

     

    https://discussions.apple.com/thread/3247328

     

    All of this makes me think there are still issues going on with FileVault 2 for startup disks and external disks alike; certainly that seems to be the consensus on the other thread regarding startup disks at least.

  • Macnetmedia Level 1 Level 1 (0 points)

    Is this issue solved in OS X 10.8.2 now? I still had problems with a 4TB drive and 4096 byte blocks and CoreStorage creating a HFS+ encrypted partition.

Previous 1 4 5 6 7 8 Next