Previous 1 4 5 6 7 8 Next 119 Replies Latest reply: Sep 27, 2012 3:44 PM by Macnetmedia Go to original post
  • niall.young Level 1 (0 points)

    Erm, now I'm thinking this isn't a quick and easy fix...  It sounds like there are 2 or 3 issues here across block sizes and buses, D'oh!

  • Pecos Bill Level 1 (75 points)

    For the truly geeky dive into the hard disk manufacturer's explanation of the sector changes, you can check out Seagate's PDF of what's going on industry-wide. I found it informative. I am bashing my head against the wall for my Mom's WinHELL box not being able to back up to her external 4k sector disk. Happened across this and though I would chime in where I could. For Mac troulbes: since the disk should be emulating 512 sectors and not 4k native (which is set at the factory but may appear as 4k native depending on the connection type), it could end up with a misaligned format which would work but would run much slower. I'm hoping that's not possible with MacOS. Good luck.

  • nathanfromkailua kona Level 1 (0 points)

    This is a bug. I went to the "Genius Bar" at the Apple meca in Silicon Valley (IMO where the customers train the Apple employees) and the Apple technician replicated the issue on his machine. The technician escalated the problem to engineering. Hopefully that will *finally* get engineering moving on a fix.  The collective genius at "the bar" couldn't offer any workarounds, but here's mine. Use at your own risk (I haven't extensively tested this and I'm no expert on Time Machine, but it seems to work and backups generate a "Backup completed successfully." message in /var/log/system.log):

     

    1) Create an encrypted sparse bundle on the external drive (change "464g" as appropriate for the size your external backup drive and "/Volumes/G-DRIVE Slim" to your external drive mount point as appropriate):

     

    cd /Volumes/G-DRIVE\ Slim

    hdiutil create -size 464g -encryption AES-128 tm -fs "Case-sensitive Journaled HFS+" -type SPARSEBUNDLE -volname tm -nospotlight

     

    2) Mount the sparse bundle:

     

    (click on it in finder)

     

    3) Associate Time Machine with the sparse bundle volume, exclude it from backups, and make the first backup:

     

    tmutil disable

    tmutil setdestination /Volumes/tm

    tmutil addexclusion -p /Volumes/tm

    tmutil startbackup

     

    4) Put Time Machine back on automatic:

     

    tmutil enable

     

    You'll need to connect the external drive and mount the sparse bundle each time you want to perform a backup or restore.

     

    Hopefully Apple will finally get this fixed before it's necessary, but you may also need to periodically compact the sparse bundle.

     

    Whole disk encryption was my only motivation to "upgrade" to Lion and encrypted backups are broken without some type of hack around like this one.  Lion is such a disappointment. It seems more like a product from Redmond, WA than from Cupertino,         CA

  • there_ Level 1 (0 points)

    this issue appears to be fixed in 10.7.3 (tested with the latest developer seed).  i was having the same issue with a new WD 3TB drive, but after upgrading to 10.7.3, i was able to re-format and encrypt the new drive with corestorage.

     

    i'm not sure when 10.7.3 will be released to the general public.

  • Allen McBride Level 1 (0 points)

    Glad to hear it was fixed with the previous seed; have you confirmed with the latest as well? I'm not a dev so I can't test. I just bought a WD 3TB drive myself and am trying to decide whether to return it or keep it and trust that 10.7.3 will be out soon. Does the disk also verify okay, or does it still give the "Error: The partition map needs to be repaired because there’s a problem with the EFI system partition’s file system" message when using GUID partition map? It sort of sounds like that and the encryption issue both stem from the same underlying issue, but I don't really know.

  • Borislav Tranchev Level 1 (0 points)

    Hello there, I have WD 3TB external hard drive. I am using it since last summer and its nearly full. On it I have 500gb selected for Time Machine and I have a lot of backups and everything was cool until today.

     

    To begin with the story I want to state that last weeks I have been noticing my MacBook Air crashing and needing force shut down sad story. Today I downloaded some updates and some time after when I was copying some files to my WD HDD an error ocured (the external hdd was not plugged out properly or something like this and it also stated that next time I plug it in my system will attempt to repair any damages made on the information. When I plug it and put the password the time machine part appear but the other part of the hdd where my files are is still reading. Soon after it shows the same message with the error and wrong plugging.

     

    I tried to connect it to Windows machine and it works. I verified the WD hdd with disk utility and it says that there is a problem with the EFI system. I veryfied my mac 250 gb SSD and it says that:

     

    ----------------------------------------

    2012-01-31 21:15:01 +0000: Invalid volume free block count

    2012-01-31 21:15:01 +0000: (It should be 9360167 instead of 5188623)

    2012-01-31 21:15:01 +0000: The volume Macintosh HD was found corrupt and needs to be repaired.

    2012-01-31 21:15:01 +0000: Error: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk.2012-01-31 21:15:01 +0000:

    2012-01-31 21:15:01 +0000: Disk Utility stopped verifying “Macintosh HD”: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk.

    2012-01-31 21:15:01 +0000:

    ----------------------------------------

     

    Now my concern is that I dont want to lose all the data I have on the HDD and that if I want to repair my mac ssd I have to use the time machine back up from the WD HDD (which is not working). If a update is coming soon thats great, but I guess to fix it i will need to format the whole hard drive.

     

    Can you give me some advice guys?

    Thank you in advance!

  • Thierry Nkaoua Level 1 (0 points)

    Fixed for me with 10.7.3 update

  • BradleyBraves Level 1 (0 points)

    The issue is still there after the 10.7.3 update, even tried converting the drive to CoreStorage via Terminal. I'm using a Seagate GoFlex 3TB via USB. This is so disappointing - I still can't encrypt my backup drives using FileVault 2. I am using "Knox" now since I have a feeling certain large (mainstream) drives will never work in Lion. Incredible.

  • niall.young Level 1 (0 points)

    Try a full format rather than converting, worked for me WD 3TB.

  • BradleyBraves Level 1 (0 points)

    Hi Niall-

     

    I tried erasing the drive, repartitioning it to one partition and setting it up as a encrypted time machine drive - without success. I tried erasing it and formatting it straight with encrypted format, without success. Did you do a full secure erase overwriting the whole drive with zeros or only the quick one?

     

    Has anyone discovered where Apple officially lists this as an issue or a limitation? It feels like a zillion users have this issue and there's no official statement regarding this.

     

    thx

  • DocBaldie Level 1 (0 points)

    Make sure you are using the GUID partition table.

     

    In my case I didn't get the encrypt option when I partitioned the drive but was able to encrypt the drive using erase.

     

    My 2 TB WD drive appears to encrypt just fine, as of 10.7.3.

  • diesel_dad Level 1 (0 points)

    10.7.3 fixed this for me as well. I am using a 500GB G-Drive Slim. I was able to select the volume, click encrypted, enter a password and then OS X went and encrypted the drive.

     

    Finally but at least it works.

  • CarltonBanks Level 1 (20 points)

    I've had no issues with file vault 2 on external drives 2TB and under.

     

    This is about drivers like the WD 3 TB External usb desktop drives. Does the 10.7.3 patch fix the issue with those drives?

     

    Thank you

  • Pecos Bill Level 1 (75 points)

    FWIW, the issue can happen with smaller drives. It's not a size problem but a disk sector size. The industry is chagning from 512k to 4096 (4k) sectors and that's what was triggering the bug. I had a iomega 500GB disk that had 4k sectors which would cause this problem.

  • aoz8080 Level 1 (0 points)

    Well, after 10.7.3 it still failed to format on FireWire 800, but I was able to format it encrypted with USB, then switch back to the FW connection, so it worked out ok I guess. (Though being a mobile bus-powered drive, it turns out to be not much faster on FW800 than USB anyway).

Previous 1 4 5 6 7 8 Next