Previous 1 2 Next 29 Replies Latest reply: Nov 1, 2012 4:24 AM by Shorey78 Go to original post
  • Euka Level 1 Level 1 (0 points)

    Hi guys in my case the solución was to update Better Touch Tool to the last version

  • Niklas Luhmann Level 1 Level 1 (45 points)

    I never installed Better Touch Tool. Interestingly, I did install Better Snap Tool, but I removed it. I wonder if it left something behind which could be affecting things? In any case, there is more discussion on this bug in this thread:

     

    https://discussions.apple.com/thread/3255369?tstart=0

     

    UPDATE: Just to test, I installed the latest version of Better Touch Tool. It does not solve the problem.

  • randhindi Level 1 Level 1 (0 points)

    Hey there!

     

    Had the same problem with keynote and the magic mouse.

     

    The solution is simple: Don't let your finger(s) on the mouse while using the keyboard. Seriously, that's it.

     

    For some odd reason, iWorks interprets that as a  command, so if you have your fingers loosely touching the magic mouse, and press a keyboard key, it won't register properly. Sometimes it will, sometimes it wont, probably due to the sensitivity of the mouse. But not touching your mouse will ensure your keyboard stays responsive.

     

    Hope that helps, it drove me crazy until I figured it out.

     

    Rand

  • jayrusalem Level 1 Level 1 (0 points)

    Rand... um....er...how do I say this...

     

    Oh. My. God. I can't believe this problem has been plaguing me for almost a year and the solution is so simple. I just tried it and you're 100% right. I need your mailing address to send you flowers :-)   It now seems SO obvious...hard to believe I never actually took my @$)*%#$ hand off the mouse!  And when it periodically "mysteriously" worked, that was why.

     

    Wow. My forehead is all red from slapping it.

     

    Thanks... I just dusted off my beloved Magic Mouse and am back in action.  If I feel really virtuous later I'll troll through the boards here and find all the people who suffered the same thing.

     

    Thanks again,

     

    Jay

  • silencesound Level 1 Level 1 (0 points)

    It's a shame that this problem has been there for so long time without a solution from Apple.

  • gravitron Level 1 Level 1 (0 points)

    +1 for keyboard problem - but in all iWork applications, every other application is fine. I mainly notice that shortcuts for copy and paste fail on a regular basis - SUPER annoying.

     

    My set up is:

    Lion 10.7.3

    Mighty Mouse + Wireless Keyboard.

    iWork '09

  • jayrusalem Level 1 Level 1 (0 points)

    Did you see my post above? Simply make sure your hand isn't touching the Magic Mouse. It sometimes prevents the input because it seems to be sending the signal also. If you get used to solving this way, you stop noticing you are doing it. Ridiculous situation but it works, at least.

  • gravitron Level 1 Level 1 (0 points)

    I did see that suggestion - unfortunately it doesn't work for me. The problem occurs irrespective of my hand/mouse position.

  • racemase Level 1 Level 1 (0 points)

    JFYI I have the same problem since ages. Lion, Mountain Lion, lots of different versions of iWork Apps. It drives my crazy. BTW it doesn't work even without touching the mouse ...

  • paoloasso Level 1 Level 1 (0 points)

    Yes.  I have a wireless touchpad (hate mice).  I can't use it to progress through a slide show.  Only the play keys on the keyboard work - I mean the keys with the rewind, play, and forward symbols on top toward the middle of the keyboard (I am on a MacBook Air, late 2010).

     

    It's really absurd.  I am about to switch to PowerPoint because when I lecture in a room with 300 students I need to walk around -  can't stand at the podium like a statue and click the keys. Not even the external clicker that the school provides works with Keynote but it used to back in 2009 when I had a MacBook Pro with Tiger OS X.  I am now on Snow Lion latest version.  I love it, but it gave me so many problems.  This one really *****.

     

    This is a real bug that needs some genius attention.  Surely is something simple that a crackpot head like mine can't see.

  • Shorey78 Level 1 Level 1 (0 points)

    Hi

    Did you find a solution to your problem with the Keyboard?  I've got the same issue.  At first I thought it was the wireless keyboard so I changed to wired.  That did improve things, but the problem is still there.  I'm using Lion 10.7.4, and iWorks '09.

  • jayrusalem Level 1 Level 1 (0 points)

    I solved it... see my note above. When touching the MagicMouse, it "blocks" the keyboard. When I remove me hand, all is fine...Odd bug, and I'm BAFFLED that Apple hasn't address it -- their hardware, their software...

  • Shorey78 Level 1 Level 1 (0 points)

    Thanks for that - it wasn't till I sat at my computer and worked out that I do have my hand on the mouse that I realised that this could be the answer to my problem!  It seems so stupid that such a simple thing could cause so much of a problem.

  • alperfrombrooklyn Level 1 Level 1 (0 points)

    Same problem here.

     

    MacBook Pro 13 @ 2.4 Ghz

    Snow Leopard 10.6.8

    Keynote 5.1.1

     

    No peripherals connected, just plain trackpad and onboard keyboard.

    The problem persists about 4-5 times a day.

  • Shorey78 Level 1 Level 1 (0 points)

    It really is as simple as not touching the mouse when you type - it has made such a difference!  However, I hope Apple gets this sorted out 'cos its pretty stupid.

Previous 1 2 Next