Previous 1 2 3 Next 62 Replies Latest reply: Jan 13, 2016 7:41 AM by dj_jake_audio
ridikulas Level 1 Level 1

Every time I scroll through my tabs, Safari reloads the page (similar to how pages autoreload in iPhone and iPad). Anyone have a fix to stop Safari from reloading tabs all the time?

Macbook, Mac OS X (10.5.6), none
  • Deanius Level 1 Level 1

    Same problem. Just started a day or two ago. Can't work out why its doing this...

  • Carolyn Samit Level 10 Level 10

    Quit Safari. Open a Finder window select your Home folder in the Sidebar on the left. Then open the Library folder, then the Caches folder, then the folder. Move the cache.db file from the folder to the Trash. Relaunch Safari.


    If that doesn't help, could be the preferences are corrupted ..


    Go to ~/Library/Preferences. Move the file to the Desktop.


    Quit then relaunch Safari to test. If that helped, move the .plist file to the Trash.


    ~ (Tilde) character represents your Home folder.

  • sarabearinaz Level 1 Level 1

    not working for me either.

  • keelymarie Level 1 Level 1

    This has been happening to me all week as well. It is so annoyng becuase you lose anythign you are working on in that tab.


    Help Please!

  • mtbarlow Level 1 Level 1

    Me, too... ever since my most recent software update. Any assistance, Apple? If it goes on much longer I will quit using Safari... and I hear once you go Chrome you never go back.

  • keelymarie Level 1 Level 1

    Just switched to Chrome today because I couldn't take it anymore.


    It even started freezing in general as of yesterday.


    Hoping for a fix soon as I like my top pages in Safari.



  • Jason Sims Level 2 Level 2

    This has been bothering me too, and I might have a possible fix for it.


    I did some digging around, and I'm pretty sure this is happening because of a new feature in Safari 5 (more specifically, it's new to Webkit2) called "multi-process windows". You can read some info about it here, but the essential point is that Safari now runs on two separate processes -- one for the user interface (the "UI process"), and one for the content (the "web process"). If any page misbehaves, it can crash the web process, but instead of causing the entire application to quit (which is what would have happened in Safari 4 and earlier), Safari now just silently restarts the web process and then reloads all the tabs you had open.


    That's great in theory, but for whatever reason, the web process seems to crash or hang quite often; I see Safari 5 suddenly reloading tabs far more frequently than outright crashes used to occur in earlier versions. The net effect is that this feature that's meant to make Safari more stable has so far caused a lot more problems than it has actually solved.


    Anyway, if you enable the Debug menu in Safari (you can do this with TinkerTool or any of several other similar apps; note that this is not a hack, it's simply a hidden setting in Safari, so there should be no problem with me mentioning it here), there's an option in that menu called "Use multi-process windows". I haven't tested it yet (I don't have time at the moment), but disabling that option might stop this "spontaneously reloading tabs" nonsense from happening. I'll look into it later and post a blog entry if I can confirm that this solves the issue (in which case I'll come back and post a link to it in this thread).

  • Jason Sims Level 2 Level 2

    This has nothing to do with cache or corrupt preferences. It's a new behavior in Safari 5 due to a major redesign of the underlying engine (Webkit2), which may still have a few bugs. If you don't actually understand the problem, you shouldn't be giving people advice on how to fix it.

  • Jason Sims Level 2 Level 2

    Quick follow-up: disabling "Use Multi-process Windows" (in the Debug menu) does indeed stop the unexpected reloading of tabs. After you disable this option, close any Safari windows you have open. New windows/tabs created after that point should say "Untitled [SP]" (where SP = single process).


    You can confirm this fixes the problem by loading a couple of web pages into tabs, then selecting "Crash Web Process" from the Debug menu. This would normally trigger the reload behavior, but it will not cause any tabs in an [SP] window to reload.

  • Jason Sims Level 2 Level 2

    I just wrote a blog post that explains how to stop this annoying behavior in Safari 5.



    Hope this helps anyone who's been frustrated by this problem.

  • mwegner Level 1 Level 1

    Excellent, Jason!  This is the first reliable fix I've seen for Safari's atrocious behavior. 


    BTW, Tinkertool did not allow adding the Debug menu to Safari; I had to use a terminal command.


    I think I'll stick with Camino for a while yet, but I'm glad to know there's a way to fix Safari.

  • Jason Sims Level 2 Level 2

    You're right. I discovered there's no checkbox for the Debug menu in TinkerTool as I was writing my blog post about this (I could have sworn there was at one point…), so I included the Terminal command in my article.


    If you like the performance of WebKit, you could also look at Chrome, which doesn't seem to suffer from this problem (because every tab is an independent process, any one of them can crash without causing the rest of them to reload).


    Camino is good too. It was written by Dave Hyatt before he was hired by Apple to build WebKit and Safari. Camino uses Gecko (the same engine as Firefox) instead of WebKit, which is still pretty decent.

  • beadgrrl Level 1 Level 1

    Jason - thanks for the info. I did this & tabs/pages no longer spontaneously reload, AutoFill doesn't work & when I scroll it's 'floaty,' unlike before I made the switch. Do you have any idea why these other things changed, & do I have to go back to flaky reloading to get them back? Thanks for any advice!

  • qap Level 1 Level 1

    Safari 5.1.2 still has this bug, tabs reload on Webprocess crash



Previous 1 2 3 Next