Previous 1 2 3 Next 132 Replies Latest reply: Mar 6, 2014 9:09 AM by Alex Zavatone
tbonecopper Level 1 Level 1 (0 points)

Has anyone managed to disable the iOS like "rubber band" scrolling in the Lion version of Safari ? For instance when you scroll all the way up or down, a blank space is created, like on iOS , and releasing the scroll rubber bands the content to the top (or bottom).


MacBook Pro, Mac OS X (10.7)
  • Meherally Level 4 Level 4 (1,115 points)

    Any reason why you would want to disable that.

  • jk_baller23 Level 4 Level 4 (2,120 points)

    Follow these steps to disable/enable "rubber band" scrolling:

     

    1. Click on the Apple () button on the top left corner of your screen and then click on "System Preferences".

     

    2. Under the top row of icons titled "Personal", click "Universal Access" on the far right.

     

    3. At the top of the newly opened screen you have four options to click ("Seeing", "Hearing", "Keyboard", and "Mouse and Trackpad"). Select "Mouse and Trackpad".

     

    4. Select "Trackpad Options..." towards the bottom of the newly opened screen.

     

    5. In this screen, "Scrolling" should be checked unless you have tampered with this option before. To the right of scrolling is a drop down arrow with two options: "with inertia" or "without inertia". Select "with inertia" if you would like the "rubber band" effect or select "without inertia" if you would like to remove the "rubber band effect".

     

    6. Select "Done" and enjoy your new method of scrolling!

  • tbonecopper Level 1 Level 1 (0 points)

    Thank you for that. Unfortunately that is for the speed @ which you can scroll, by flicking the trackpad & letting go.

     

    I refer to the ability to flick upwards or downwards, and when the top is reached, your scroll almost bounces, and the page you're looking at in Safari, kind of rubber bands down, then back up.. and in the midst of this, a "space" is created, as if it's moving along a pedestal.

     

    Like on the iPhone.

  • Meherally Level 4 Level 4 (1,115 points)

    Uncheck Scrolling itself...

  • Meherally Level 4 Level 4 (1,115 points)

    Also under general pref pane, check for scroll bar to show 'always' now you can use the scroll bar to scroll without the rubber band.

  • stevefrog1 Level 1 Level 1 (5 points)
    Any reason why you would want to disable that.

     

    Because it's annoying and unnecessary on a laptop with large (15 inch) display.

  • stevefrog1 Level 1 Level 1 (5 points)
    5. In this screen, "Scrolling" should be checked unless you have tampered with this option before. To the right of scrolling is a drop down arrow with two options: "with inertia" or "without inertia". Select "with inertia" if you would like the "rubber band" effect or select "without inertia" if you would like to remove the "rubber band effect".

     

    But doing this also disables inertia scrolling, which is very nice. What we want is to keep inertia scrolling but disable the annoying bounce (rubber-band) when scrolled to the top or bottom.

  • Király Level 6 Level 6 (9,530 points)

    Are you willing, like me, to give up all Gestures to be rid of the scroll bounce?  If so, just throw your Apple pointing devices out the window and pick up a cheapo third party USB mouse from any chain store's bargain bin.  No scrolling bounce with my 8 year old Logitech USB mouse.

  • Király Level 6 Level 6 (9,530 points)

    Meherally wrote:

     

    Also under general pref pane, check for scroll bar to show 'always' now you can use the scroll bar to scroll without the rubber band.

     

    You are misunderstanding the request.

     

    The issue is when scrolling beyond the end of a document or a web page.  It bounces like a trampoline.  Even disabling scroll inertia does not stop this "feature", which is IMO one of the most irritating things about Lion.

  • Suffix. Level 1 Level 1 (0 points)

    I'm pretty sure there is no way to disable it without pestering around in terminal.

    Why disable it anyway? Since you are using a trackpad it does nothing but create a dynamic experience.

  • stevefrog1 Level 1 Level 1 (5 points)
    I'm pretty sure there is no way to disable it without pestering around in terminal.

    I'd be more than happy to use Terminal to get rid the behavior.

     

    Why disable it anyway? Since you are using a trackpad it does nothing but create a dynamic experience.

    I don't see how using a trackpad would warrant the bounce at edge effect any more than using a mouse. Either way, it's just plain annoying, especially on a 15 or 24 inch display. At the very minimum, it should be configurable - give the user the choice.

     

    I predict that any third party tool to disable this will be extremely popular (hint hint tool developers).

  • Király Level 6 Level 6 (9,530 points)

    There's no known software method of disabling it at this time; not even by using Terminal.  Third party mouse is the only known way at this time.

     

    What's a "dynamic experience"?  It's irritating as anything.  I scroll down to the bottom of a web page, go to click a link, and miss the link because it bounces away from the mouse pointer.  Arrrrgh! 

  • tbonecopper Level 1 Level 1 (0 points)

    Thank you, everyone, for your replies.

  • AndyFibz Level 1 Level 1 (0 points)

    Please keep this issue popping up in the forum i feel as if apple reads how irritating it is they will maybe give us the option to disable or enable the elastic bounce.. I regret updating and spending the money

Previous 1 2 3 Next