8 Replies Latest reply: Mar 15, 2012 5:41 AM by Ivan_ua
Longsi Level 1 Level 1

After update to Lion, Numbers works very slow and clumsy. Any solution to fix this problem?

MacBook Pro, Mac OS X (10.5)
  • dbk9999 Level 1 Level 1

    Don't know about being "slow" - I've always felt it was slow.  I could run Office XP (maybe 2000 - not sure) on an 133 mhz Pentium and it was faster than Numbers on my late 2008 Aluminum MB.


    But I've had other issues under Lion with it.  It seems whenever I first go to my spreadsheets after the computer has been asleep - even if it is some time after waking it up - and start to enter some numbers, I'll get a beep and see that what I tried to type didn't come out right and I have to do it again.


    I was wondering if it was something to do with the auto-save versions maybe kicking in when I first start to enter info, but before I finish the first entry.

  • fabrica64 Level 1 Level 1

    After Lion update Numbers is hanging every few seconds, and especially after being switched in from another app. I think this is due to auto-save, that's a very good feature, but as of now very un-workable.. let's hope for a quick fix!

  • kimfromaarhus Level 1 Level 1

    I'm having the same issue, it drives me insane.

  • tlwyse Level 1 Level 1

    Similar issue here.....I've got about a 2.5 MB Numbers doc that freezes/hangs when I attempt to delete tables or sheets or create new ones. Virtually anything I do causes delays and/or hanging. This is probably the most complex Numbers doc I've built to-date but 2.5 MB doesn't seem overly large to me. Numbers has become unusable to the point that I'm considering rebuilding this one particular spreadsheet in Excel.


    I've sent reports off to Apple every time I've had to force quit so hopefully they're getting the message.




  • andrii.uriadov Level 1 Level 1

    I faced the same problem and FOUND a temporary solution.

    The problem is: Numbers uses daemon "fontd" for fonts rendering. This daemon uses up to 100% of CPU with some fonts.

    Solution: Try to change globaly fonts in your tables to Arial.

  • andrii.uriadov Level 1 Level 1

    Numbers works (actually, daemon fontd renders) very slow with Helvetica Neue font!

    I've deleted Helvetica Neue and Numbers starts fly!


    Warning: Mac OS X needs Helvetica. If you delete Helvetica dfonts, make sure to install your own Helvetica.


    sudo -s

    cd /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ ATS.framework/Versions/A/Resources/ProtectedFonts/

    rm HelveticaNeue.dfont

    cd /System/Library/Fonts/

    rm HelveticaNeue.dfont

  • nassorcnivek Level 1 Level 1

    Same issue.  Everything was working fine untill I downloaded a file (from icloud) previously run on my ipad.  I can't even navigate without getting frustrated.  I ended up exporting the file into excel and then working on it there.  I'll have to export my changes back to numbers so that I can continue to use the file on my ipad.  Is there any news on better icloud integration for iwork?

  • Ivan_ua Level 2 Level 2

    I had this problem, just switching to regular Helvetica within Numbers without sudo activity solved the problem for me. Before it was painful to complete even tiny table. Thanks!!!