Previous 1 2 Next 21 Replies Latest reply: Mar 13, 2013 12:14 AM by Dhiraj Bhor
Georgie23 Level 1 Level 1 (0 points)

Like many I cannot network with Win 7 - first Mac ever and thought it would be easy but seems a disaster


I ahve read all about SMB and problems that people are having and I am one of them - I enter my password and username and I keep getting an error.


Just wondering does it have anything to do with the "Workgroup" of the Mac.  I seem to add "Workgroup" as my workgroup but it does not save it - everytime I look later it is blank again.  Do you think it has anything to do with the Workgroup setting?

MacBook Air, Mac OS X (10.7)
  • Headgrunt Level 1 Level 1 (0 points)

    Same here !!!!


    Start up Lion. go to "NetworkPrefPane/Wi-Fi/Advanced/WINS" settings are all "blank". Re-enter NetBios name & Workgroup. Works for hours even through "Sleep".


    [Restart] I have to go through the entire process all over again. Computer name set in the Sharing Pref Pane does not change.


    Steps taken to resolve. "That don't work."


    1. Created a new /Library/Preferences/SystemConfiguration/"preference.plist" by renaming current to .bak, to force a new preference.plist to be created after start up. Same done for the in the same location.


    2. Deleted the Network Interface "Wi-Fi" and started from scratch.


    3. Changed the computer name. Several different names used.


    4. Toggled On/Off SMB sharing in Sharing Pref Pane. Same with Share over AFP.


    5. Locked the Network Pref Pane. After [Restart] Network Pref Pane is unlocked "not asked for admin password". Every other lockable Pref Pane remains locked.


    6. Cleared all caches, ran all crons scripts, repaired permissions, and zapped the PRAM.


    7. Changed Network name. Several different names used.


    8. Toggled Back to my Mac On/Off.


    9. Toggled Firewall is On/Off.


    10. Toggled all sharing services On/Off.


    Tried all the above several dozens of times in different sequences. This has been a 12 hr. trouble shoot so far, after upgrading to Lion 10.7.


    Any other suggestions ???


    Really like Lion, and don't want to give up yet.......

  • pete from milton keynes Level 1 Level 1 (0 points)

    I've just tried connecting via CIFS/SMB to my Lion installed iMac, and it doesn't work.


    The workgroup settings which were visible before the Lion upgrade,  have now disappeared, and even if they are re-entered again are not retained when the setting are re-visited!


    This must require an urgent update from Apple! There are/were many cosmetic changes in Lion, it seems so maddening that Apple let this 'bug' through.


    Is there any likliihood of seeing this work again correctly?

  • rgoldd Level 1 Level 1 (110 points)

    UGHHH...not that it's a deal breaker I don't use the workgroup very often and stuff I use usually works without setting the workgroup somehow with my Time Capsule.


    But it's still annoying it won't allow me to save the Workgroup and the Netbios Name...Lions alright just a few things are wack and I don't think Apple knows or cares it's not major though

  • maddmaxx666 Level 1 Level 1 (0 points)

    Mine is currently stuck as WORKGROUP, when I try to change the NetBIOS name or the workgroup, I get the same thing, just reverts back. This was working in Lion before for me, don't know what changed though... Seems pretty greasy, if they don't support CIFS/SMB anymore...


    I just got off the phone with apple care, and yeah, they don't. After talking with one support rep for about 10 minutes, even taking him through the steps in the Network pane, aka pain, he quickly determined he did not have the training to adress the issue. He escalated the case to a senior advisor Another half hour hold later, this fella comes on and tells me that it's not something they support. They're not allowed to even if they could. He suggests that maybe I should get support from Micros***... lol!


    That has to be the best thing I've heard yet! Call Mocros***, and ask them: "Yeah, I'm having trouble changing the workgroup on my Mac, can you help me?" Baaahahahahaha!!! 


    In all seriousness though, it worked like 5 days ago, since then I've had no updates, and it started this... ***?

  • maddmaxx666 Level 1 Level 1 (0 points)

    Well I fixed it, just called back, and the next representative, Ryan, was very attentive to the issue at hand, it took him some time to research it, but eventually he came up witht he answer of just deleting the two and in Finder -> Go -> Hold "option" key, click library... in that folder. Of course it will set all of your preferences back to default, but that didn't cause me any issues... Now go back and set your netbios and workgroup, apply, and go find your shares... Now hopefully I didn't just put my good friend Ryan out of a job... lol

  • HigherAndFaster Level 1 Level 1 (0 points)

    I don't have these two files on my MacPro running 10.7.3...

  • HigherAndFaster Level 1 Level 1 (0 points)

    Has anybody come up with a solution for this yet?

  • itsamacthing Level 1 Level 1 (85 points)

    Having the same issue here, had no idea why i could not browse the mapped drives on my mac from a windows 7 machine.  Was too busy to figure out the issue till this weekend... some 2 months and very frustrating days later.  Now I have to put the settings in each morning and when I tried to navigate to the regular location of SMB.conf I found out that Apple rewrote their working version of Samba and put in a new one.  One of the reasons I switched the mac 11 years ago was that Apple was using open standards, and now Apple seems to want to write it's own version of SMB for example and that breaks its connection with everyone else?  Don't get me wrong, Windows writes their own as well... but this kinda of thing is not good.  So where is the fix? 

  • Headgrunt Level 1 Level 1 (0 points)

    Upgraded to Mountain Lion tonight. My mac is discovered/viewable from win7 and vice versa.


    Workgroup on mac does not clear after reboot....for me anyways.

  • itsamacthing Level 1 Level 1 (85 points)

    Intersting, and have you tried an app like Pathfinder?  I'm interested in knowing if SMB discovery is working again for 3rd party apps in ML.  Thanks

  • Headgrunt Level 1 Level 1 (0 points)

    Just tried the current Pathfnder. My Apple [Shares] show but NO Windows [Shares].

  • Howard_K Level 1 Level 1 (0 points)

    I am having the same problem with OSX 10.7.4. . . must enter the WorkGroup name every time I restart. Sometimes I forget and then i cannot connect to this mac from Windows computers on the network which are in a different part of the building so this is a PITA and I would love a solution. I cannot upgrade because certain software i am running is not supported past 10.7.4. This all worked great for years. Not sure when exactly it changed. I saw another post where everyone with this problem had SSD drives, which i do as well. I do not see the preference files named in the earlier post in this thread.

  • Howard_K Level 1 Level 1 (0 points)

    Ok, I see the Preference files now, one level deeper in the "SystemConfiguration". I deleted, restarted, reset proferences, restarted again, and the WINS Workgroup still was emply when i restarted. . so no change. My Preference file "" contains:


    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">

    <plist version="1.0">


















  • itsamacthing Level 1 Level 1 (85 points)

    This is truely the most annoying bug in OSX.  I also have an SSD, OWC.  I don't think it should have to do with that since my other macs who have stock SSDs also have that issue. 


    Since Apple is using it's own home made version of SMB, I would be more inclined to look at it and how buggy it is. 


    If you want the setting to stick, go into your preferences and turn off file sharing.  Then setup your workgroup, netbios, save... and then go back and turn your file sharing back on.  It should stick for a little while.  Even thru a few reboots. 


    I wish we could just hardwire a smb.config file. 

Previous 1 2 Next