Previous 1 2 Next 21 Replies Latest reply: Mar 13, 2013 12:14 AM by Dhiraj Bhor Go to original post
  • Howard_K Level 1 (0 points)

    This doesn't really help. . .but might provide a clue. Running this line in the Terminal Populates the WorkGroup in the WINS dialog:


    sudo touch "/Library/Preferences/SystemConfiguration/"


    I found the above in another thread. . . i don't really have a clue what i am doing. This is frustrating. . . I may as well be running Windows. . . I expect more from Apple and OSX!


    I think I am running either a:

    INTEL SSDSA2CW120G3: or

    OWC Mercury Electra 3G SSD:


    I have 2 startup drives for different OSX versions and I am not sure which is for which. . .


    Is there a way to run that line during startup to ensure WINS Workgroup is set? Sorry. . . I am a Windows guy and don't know my way around OSX.

  • itsamacthing Level 1 (85 points)

    It does work... try it.  I only have to fix like once a month or so.  It's been a bug since 10.7 and i'm on 10.8 now. 

  • Howard_K Level 1 (0 points)

    Unfortunetly not working for me. Steps I tried



    Check WINS. It is blank

    Turn Off File Sharing in the Sharing Dialog

    Go To WINS and it now mysteriously has my WorkGroup and NetBIOS Name.

    Turn On Sharing,

    Check WINS again and it is still there.

    Restart computer,

    WINS is Blank.


    I Tried it 3 times. . . same result.

  • Howard_K Level 1 (0 points)

    A solution might be to have this run automatically at startup:

    sudo touch "/Library/Preferences/SystemConfiguration/" password=myadminpassword


    This works fine within Terminal (replace myadminpassword, with you password) and the WINS Workgroup is updated immediatly with the Value in the file.


    However I don't know how to do this automatically. . . I read what I could on LaunchAgents and got the App "Lingon 3" to help make it easier, but it did not want to run this command in root.



  • gchermette Level 1 (0 points)

    Hello all


    Thanks so much for all this, I was just getting mad until I read this thread.

    So, same thing here: Workgroup was getting lost when my iMac boots up (or gets out of sleep mode). Solution is to run this "sudo touch..." command.


    I can't seem to find a solution as how to run it when the iMac wakes up, but when it boots up, Applescript is what you're looking for.

    Run AppleScript editor, create a new script and insert this:

    {do shell script "sudo touch /Library/Preferences/SystemConfiguration/" user name "your_user" password "your_pwd" with administrator privileges} (don't insert the brackets...)


    Save the script, somewhere easy to find (like documents).

    Then, in the System Preferences (not sure of the English name, sorry), go in Users and Groups (again, sorry).

    Go in tab Start (or Open or... actually, the 2nd tab of your user, next to password). This tab manages all the scripts and programs that are to be run when your user logs in. Just drag&drop the script you've created within the list.

    Next time you start your Mac, the sudo touch command will be automatically run.



  • iDeviceDreamer Level 1 (0 points)

    Shame on Apple - the solution is so easy - look at this tread:


    It's a bug not yet solved by Apple in OS X ML !!!


    Regards Michael

  • Dhiraj Bhor Level 1 (0 points)

    Is there any code snippet to view our own workgroup name on mac?

    If so then help is welcome.

    Thanks in advance.

Previous 1 2 Next