Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.


Question: "Unable to write to the last block of the device"

Trying to format an external hard drive using diskutil gives me "Error: -69760: Unable to write to the last block of the device".

Is that a hardware problem and what could be done about it?

Disk Utility-OTHER, Mac OS X (10.7)

Posted on


Mar 7, 2012 12:52 PM in response to nickspassov In response to nickspassov

I had this problem "Unable to write to the last block" with my brand new 6 TB Fantom Drive and after contacting the Manufacturer it was due to a firmware bug for the drive.

They sent me a firmware updater (It had to be run on Windows) and I updated the firmware. After this the drive mounted to my MAC no problem and formatted.

Might want to try and update the firmware of your drive.

Mar 7, 2012 12:52 PM

Reply Helpful

Mar 7, 2012 1:15 PM in response to JeremyS In response to JeremyS

a momentary and pointless whine...

JeremyS wrote:

After this the drive mounted to my MAC no problem and formatted.

it's Mac (short for Macintosh), not MAC (acronym for Media Access Control). I get that Windows is sometimes abbreviated as WIN (because of holdovers from earlier versions of their file system), but dude - this aint your grampa's PC.


Mar 7, 2012 1:15 PM

Reply Helpful

Apr 7, 2012 4:00 PM in response to nickspassov In response to nickspassov

I cant figure out how to do the same in lion, however, this is how you fix a corrupt usb in windows 7:

(The commands shown for cmd should be correctly spaced as I have shown).

1. Click "start"

2. Type "cmd" in the search field and press enter

3. In the cmd window type "diskpart" and press enter

4. Now type in "list disk" and press enter

5. Notice the space that best matches your usb space and note the disk number associated

6. Type in "select disk 1" (or whatever the usb disk number may be, instead of 1), press enter.

7. Type in "clean" and press enter

8. Type in "create partition primary" and press enter

9. Type in "active" and press enter

10. Type in "select partition 1" and press enter

11. Type in "format fs=fat32" and press enter.

Cmd should now start formatting your usb drive and once its done it should be detected by windows/mac as normal.

Apr 7, 2012 4:00 PM

Reply Helpful (3)

Apr 16, 2012 4:09 PM in response to nickspassov In response to nickspassov

I have this same problem with a WD Caviar Black 2TB firewire drive.

It worked great with every version of OS X 10.6x thru 10.8x (prerelease).

I went through all of the fix attempts that you guys have described (USB, Linux, other format types, other machines), but the drive is dead.

It appears that only common factor in these different events is that Apple recently added the "Unable to write to the last sector warning" and it is popping up for a variety of faults.

It is unable to write to the last sector, but not for of the same reason in all cases.

I think that we all have dead or dying HD's and this warning is distracting us into thinking it's a software issue.

Apr 16, 2012 4:09 PM

Reply Helpful

Apr 20, 2012 3:21 PM in response to wtf2007 In response to wtf2007

Like I said earlier, I think that this is a physical drive problem.

We are being distracted by an error message that heretofore never had existed.

Hard drives die everyday here in computerland and we thing nothing about it, provided we have the data backed up.

The first symptoms from my drive was that all but the newest Time Machine backups were no longer being displayed.

The drive was slowly dying.

On the next restart it was gone.

I think that the biggest problem with the error message is that it discribes a symptom that could be caused by numerous causes.

It's for that reason that we think that it could be fixed by one of your many great suggestions.

There is no silver bullet for this issue.

Some work arounds may work in some cases, but not in all that display this error message.

Apr 20, 2012 3:21 PM

Reply Helpful

May 13, 2012 9:12 PM in response to neu242 In response to neu242

Astounding. Thankfully I have a little netbook at home I use as a web server, and it is running some variant of ubuntu. I recently moved my Mac Mini to my office (I hated my windows machine so just unilaterally brought in my Mac). When I did, I brought in this old 150 gig external hard drive I had kicking around. I had barely used it for years, but did occasionally and it always worked properly.

Once I got everything set up at work (which was about a 10 minute job, by the way, from plug in to figuring out all the networking stuff--super easy), I tried to back up to the drive. It went sideways, but I have lots of experience with Time Machine doing that. I did all the regular things in terms of deleting the .inprogress file, reformatting and even repartitioning the drive. I tried Disk Utility and formatting from the terminal. Things just got worse and worse, with more and different errors.

Weeks passed. (I wasn't working on this full time, of course, since I do have a job and the backup was entirely unnecessary at work, since I have the windows box sitting on the floor should I really need it.) I saw the post below. I said, what can it hurt? I took the drive home, plugged it in, and linux said it couldn't format it because it was in use. So I ejected it from the linux desktop and tried again and it said "fine." It was that easy. I spent a week with Disk Utility on my Mac trying to format or partition it, with errors most of the time, or at least a drive that failed on backup if the partitioning or formatting worked. Linux just partitioned it and that was that.

Note, though, that Linux -- at least my distro -- can't format as HFS+ or any other Mac file system, so I just partitioned it and left the partition unformatted. I then plugged it into my Mac Mini at home (which is not the same machine as my Mac Mini at work -- I bought a new one for home when I took my old one to work) and was able to see it in Disk Utility so I added a Mac OS X journaled partition. This time, finally, it worked.

I came to work, plugged the drive in, told Mac OS X to use it for Time Machine, but to exclude the external drive from spotlight, let it go and bam, everything worked fine. I finally have backups again.

Man, Time Machine is nice when it works, but it has been a nightmare for me after upgrading to Lion (which I run at work and home). I have had to get dirty with terminal and delete .inprogress folders many times, and then all the above craziness happened. Something has gotten very broken in this latest iteration of Mac OS X I think.

Anyway, thankfully, the LAST error that I was having with this drive in Mac OS X was the "Unable to write to the last block of the drive" error. That was only after I switched to a USB cable. (Before that I had been using the firewire interface on the drive, with different errors every time I tried to back up, partition or reformat. Shrug.) It's a good thing I had that error and found this thread.

Thanks neu242!

neu242 wrote:

I just had the same problem with an external USB disk that I tried to repartition. No matter what I did (using diskutil and dd in the Terminal, ...) I couldn't get rid of the error.

But then I plugged it into a Linux box and partitioned it there without any problems.

When I plugged the disk back into the Mac, I could format the linux-created partition with Journaled HFS+. Problem solved!

May 13, 2012 9:12 PM

Reply Helpful

Jun 15, 2012 12:49 PM in response to nickspassov In response to nickspassov

I had the same issue with an external harddrive i had hooked up using firewire and the usb "power" cable.When i disconnected the "usb power cable" and only had it connected withe the firewire cable i was then able to format my drive and read/write to it.

(Note:I had to reconnect the "usb power cable" when i daisy chained the firewire cable thru my other firewire external harddrive.)

Jun 15, 2012 12:49 PM

Reply Helpful

Jun 25, 2012 10:16 AM in response to John Meyer In response to John Meyer

If anyone is looking for another possible solution...

I had this problem on a mac mini with an SD card. I didn't have physical access to the machine either. The result appears to have completely resolved the problem. I was not worried about losing the data, I had already tried erasing the card.

I did try the other suggestions. I had someone there reformat the card in another machine. After that I could use it, but the moment I tried to rename the volume or erase the card it was back to the same error.

What worked was (in Disk Utility) to select the busted disk entry and then make a 'New Image'. Then I did all the partition and initialization work on the .dmg virtual substitute for the drive. Once the .dmg was mounted I could use it in the restore step to initialize the physical drive.

I've now been able to erase, rename the drive, and work with files on the card.

I realize this trick might not be possible for the typical large external drive, but for the USB flash drives and SD cards it's another possibility.

Jun 25, 2012 10:16 AM

Reply Helpful

Aug 3, 2012 7:50 AM in response to normstorm In response to normstorm

I have a 1.5TB USB external drive that I use as a Time Machine backup. It's worked fine for close to a year, and suddenly this morning TM couldn't back up to it, I couldn't see it's contents in the Finder, Disk Utility couldn't repair, erase, partition, or unmount it.

I was bracing myself for a really long slog, and perhaps purchasing a new drive, when I saw normstrom's note that mentioned "something wrong with the USB ports." On a whim, I swapped my cable to one of the other USB ports (not the one I've always connected it to), and the drive popped up on my Desktop, Finder showed its contents, Disk Utility reported no problems, and all seems to be well with the world.

At the moment, it would appear that a problem has developed over time in the one USB port.

Aug 3, 2012 7:50 AM

Reply Helpful

Aug 3, 2012 6:58 PM in response to nickspassov In response to nickspassov

Ok, so, here is the deal. I found out that my issue was with a toshiba USB 3.0 external drive. I contacted toshiba directly and they knew of this issue. They promptly setup a rma and exchanged the drive. Since I received the replacement I've had no issues what so ever. I suspect all of our issues may be faulty drives. I too was able to format the drive on another machine or in a different format. Nothing made sense. With all the drives I've had I've never had this issue and since then I've never had it again.

Not that this info is full of work arounds or a quick fix but you may check with your manufacturer to see if they know of the issue. You may even want to run software such as seatools for seagate drives to test the integrity of the drive.

Aug 3, 2012 6:58 PM

Reply Helpful

Sep 2, 2012 4:16 PM in response to trevorbsmith In response to trevorbsmith


I had the same problem with an iPod Classic that I had to try to repair manually, because iTunes wouldn't do it. I kept getting the "last block" error and tried several different USB cables, ports, tried from the recovery partition, etc., still got the same error. Based on the posts here about Linux, I tried formatting on my Windows machine because I don't have a Linux box. That worked, as well! Plugged it back into my Mac (Mountain Lion) after formatting in FAT32, and was able to Erase/recreate as Mac OS Extended Journaled, and it worked like a charm. iTunes was then able to see the iPod and restore it.


Sep 2, 2012 4:16 PM

Reply Helpful

Nov 9, 2012 9:28 AM in response to nickspassov In response to nickspassov

I had the same problem with my old internal disk which used to hold my home folder.

After replacing it with a new one I hooked it up to a SATA to USB 3.0 and wanted to format

the drive. I first got an error that the drive could not be unmounted.

After force unmounting the drive with terminal I got the famous "could not write to last block" error.

I tried formatting on my macbook pro, 2 imac's and a windows 7 laptop,

all with no succes.

What did the trick for me was breaking open my external harddrive and hook up the drive in there.

Connect it with the firewire 800 cable to my macbook pro and formatted the drive with no prob.

apparently for my drive it was a USB conflict...

Nov 9, 2012 9:28 AM

Reply Helpful
User profile for user: nickspassov

Question: "Unable to write to the last block of the device"