Skip navigation

"Unable to write to the last block of the device"

88707 Views 38 Replies Latest reply: Jan 6, 2014 2:30 PM by Afrit RSS
1 2 3 Previous Next
nickspassov Level 1 Level 1 (0 points)
Currently Being Moderated
Jul 30, 2011 6:08 PM

Trying to format an external hard drive using diskutil gives me "Error: -69760: Unable to write to the last block of the device".

 

Is that a hardware problem and what could be done about it?

Disk Utility, Mac OS X (10.7)
  • ArbiterSpartan Level 1 Level 1 (0 points)

    I have the same problem.

  • Dead Parrot 42 Level 1 Level 1 (0 points)

    I just got the same error.  Using Lion (10.7) on my iMac (20" late 2006) my TimeMachine disk just failed.   I'ld really like to not lose a few years of backups.

  • donkatron Level 1 Level 1 (5 points)

    I'm having this problem as well. The drive details are below. If anyone at Apple wants to fix this, I'd be happy to ship them this drive:

     

      Product ID: 0x0073

      Vendor ID: 0x0dc4  (Macpower Peripherals Ltd.)

      Version: 0.00

      Serial Number: BC5177

      Speed: Up to 480 Mb/sec

      Manufacturer: Newer Technology

     

    I can format/partition the drive from a 10.6 machine but it fails from 10.7. Also fails when trying to turn this drive into an encrypted Time Machine drive (which probably starts by formatting the drive using the same stuff Disk Utiltity does).

  • donkatron Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 19, 2011 7:54 AM (in response to donkatron)

    10.7.1 didn't fix this.

  • donkatron Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 21, 2011 4:55 PM (in response to donkatron)

    Someone in another discussion thread suggested plugging in via Firewire. I was able to initialize the drive over Firewire. Once that was done, I could switch back to USB and things worked fine.

  • GQ Lewis Level 1 Level 1 (5 points)

    If you are running Lion, try this. It worked for me. There could be some type of corruption with your Disk Utility app. If you boot using cmd-r, you can use the disk utility app from the restoration partition and then you can erase, partition, or RAID to your hearts content. You can also copy the disk utility app to your startup disk from the terminal app.

  • tmockingbird Level 1 Level 1 (0 points)

    I too, am having the exact same problem. My 2TB external Seagate drive was partitioned for Time Machine backups as well as misc. media files.

     

    I am running OSX 10.7.2 on a late 2011 MBP.

     

    What I have tried so far:

    - data recovery software (Recuva, SeaTools, Data Rescue)

    - tried via USB on other systems (XP/Vista/7)

    - removed it from its enclosure and hooked it up as a slave drive in my desktop

    - reformatting from cmd+R DiskUtility

    - reformatting from Terminal

    Unfortunately, the drive does not support FW.

     

    So far, the drive still seems dead and I am losing hope here. Any other suggestions?

  • neu242 Level 1 Level 1 (10 points)

    I just had the same problem with an external USB disk that I tried to repartition.  No matter what I did (using diskutil and dd in the Terminal, ...) I couldn't get rid of the error. 

     

    But then I plugged it into a Linux box and partitioned it there without any problems. 

     

    When I plugged the disk back into the Mac, I could format the linux-created partition with Journaled HFS+. Problem solved!

  • loggy1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2011 11:55 AM (in response to GQ Lewis)

    Logging on using cmd-r worked for me too - select disk utilities and then you can either erase or partition your disk as you please. There is definitely a bug in the disk utilities in Lion which Apple need to fix pronto. Mac Fuse and OSX Fuse don't seem to work with Lion either (which is what prompted me to reformat my external disk)

  • tmockingbird Level 1 Level 1 (0 points)

    Just a follow-up on my previous response (2 responses up);

     

    I was unable to solve the problem - lost all my data. I did however send the external HD back to the manufacturer (Seagate). They accepted the RMA and I have just received a new HD by mail, luckily all under warranty.

  • normstorm Level 1 Level 1 (0 points)

    I find myself in the same or very similar situation. I have a 1TB Toshiba Ext. USB 3.0 drive. I know that it can't read USB 3.0 speeds but it can at 2.0. I keep getting the error: "Unable to write to the last block of the device." I can format the drive on Windows 7 just fine. I tried NTFS and exFAT and I still get the error when I connect it to the Mac. I do get a message that indicates I need to innitialize the drive. I choose to do this and it does nothing. The drive works find on Windows but can't get the drive working properly on Mac. I also find that if it is connected to the computer the ext drive will not come on but if I connect it to a powered Hub it sees the drive but still cant format or erase the drive.This is a brand new drive that is working on Windows but not Mac. Any other ideas?

  • cmoore55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2011 3:10 PM (in response to normstorm)

    Ditto here, my HD is a NEW Hitachi Dekstar 3 TB.  My issue is exaclty the same as the last post here.  It gets the errro as described in 10.7, but in 10.6 "POSIX: could not allocate memory" error.   .........Then I realized that I was using a Western Digital enclosure that had a vidtual CD partition in the firmeware of the enclosure that the Mac os was not able to write to.  The Mac OS saw 2.2 TB for the HD, and a small balance on the virtual CD partition.  Ok fine, so I used another enclosure (Acomdata) in this box the OS only say 801, GB, but it formated correctly.  Im still working on it but lets just say. 

     

    Yet ONE MORE part of lion that was not ready for prime time.   "Sigh"

  • normstorm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 17, 2011 8:32 PM (in response to normstorm)

    Apparently this was only an issue with My Mac. Two others at work were able to format the drive. Apple support said that there was something wrong with the USB ports.....I returned the Mac since it was Under 14 days old and will buy a Mac Book Pro. I will also take the drive to the Apple store to see if it works on other new Macs or find out the new computers are unable to read the drive.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.