Previous 1 2 Next 28 Replies Latest reply: Nov 3, 2014 8:45 AM by michelle282 Go to original post
  • filmbuff99 Level 1 Level 1 (0 points)

    I had same problem with safari closing, found easy solution from other users.  It was caused by Java Quick Starter.  I have Windows XP, so I disable it in Control Panel, the Java Control Panel, Advanced Tab, Misc. section: Uncheck Java Quick Starter, click OK.  This worked immediately.  Quick Starter allows web pages to open faster, but I haven't noticed a big difference without it, & at least safari works now.  I don't like other browsers.

  • Jim-K Level 1 Level 1 (0 points)

    Not sure if you noticed, but this thread is regarding Mac OS 10.5, not Windows XP.

  • nvnv0 Level 1 Level 1 (100 points)

    It also happening to me. After such thing, apple do release a software update but since few weeks, the autosent of error or crash report is suddenly closed. Always showing error in network!

    I think its time to shift for new snow leopard! I think they are closing more support to leopard.

    Since internet is a growing thing, better shift to new codes of better operating system.

  • Tiff2009 Level 1 Level 1 (0 points)

    I believe this is APPLE trying to weed out the folks that still have leopard.  They want you to spend the money to update to snow leopard or lion because if you look they only have safari updates for those systems.  I am having an unbelievable time getting into any website, however when I go to apple.com, NO PROBLEM.  Im not going to update my system, i'm just gonna use firefox....    So long APPLE.........

  • Neville Hillyer Level 4 Level 4 (1,855 points)

    My Safari 5.0.6 runs fairly fast on OS X 10.5.8.

     

    Here are the measures I take:

     

    1. I flush DNS cache daily at boot - Terminal command: dscacheutil -flushcache
    2. Use a very fast DNS server - find best for you with NameBench or use 8.8.8.8
    3. I don't use tabs as they consume too much RAM and slow my Mac
    4. Set History to 7 days
    5. Adjust Safari Reset to clear everything else except passwords
    6. Start Safari at least once a day with the this AppleScript

     

    Decompress the script and put it in Applications and then replace any Safari startup or Dock items with the script.

  • JanetF Level 1 Level 1 (0 points)

    If there is more than one user account, should each user Reset Safari?

  • Neville Hillyer Level 4 Level 4 (1,855 points)

    Only if they are having problems.

  • blu horse Level 1 Level 1 (0 points)

    Have to agree with tiff2009.  Firefox works great for me.  I spent 4 hours trying to use the various solutions offered here.  None worked, except for dumping Safari.  I resent apple for forcing the issue.

  • Chainjr Level 1 Level 1 (0 points)

    This is what worked for me:

     

    1.  Removed all files/plugins from the "Internet Plug-Ins" except for Flash Player, JavaPluginCocoa, QuickTime Plugin.  (still slow)

    2.  Erased the Cached file at: Home/Library/Caches/com.apple.Safari/cache.db (still slow)

    3.  Cacelled DNS pre-fetching by entering the following in Terminal: "defaults write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false"  Restart Safari (worked for a minute, then back to slow)

    4.  Flushed the DNS cache by entering the following in Terminal: "dscacheutil -flushcache" (still slow)

    5.  Changed the DNS server to: 8.8.8.8 (previously had changed it to the Open DNS ones, and it was slow, so I tried the 8.8.8.8 one.  But it at this point, still slow)

    6.  Reset Safari:  Open Safari, click on Safari and click "Reset Safari" (still slow)

    7.  Last but not least, Open System preferrences, network, select your connection and click Advanced.  Set Configure IPv6 to "Off".  Now blazing internet speeds!!!!!!!

     

    Most of these sudggestions were listed in this forum, I am just posting what worked for me in the order that I did it.  Everything works now to include Flash on Youtube and other sites.  I installed the Modded flash pluggin since I am on Powermac G5.  Best of luck!

     

    Link to Youtube for flash plugin mod (look in description): http://www.youtube.com/watch?v=iCrAKhv3R_c

  • George Johnson Level 2 Level 2 (265 points)

    Wow. Thank you. This did the trick:

     

    7.  Last but not least, Open System preferrences, network, select your connection and click Advanced.  Set Configure IPv6 to "Off".  Now blazing internet speeds!!!!!!!

     

    I had been trying on and off for most of the year to solve this problem and had tried Nos. 1-6 numerous times, finding that they did nothing. Changing the IPv6 setting has made all of the difference. The dreaded "Web pages are not loading" stallouts have disappeared.

     

    This, by the way, was not just a Safari problem. Before I changed the setting Chrome would also jam up.

     

    This was on a Mini running Snow Leopard 10.6.8.

  • stpackman Level 1 Level 1 (0 points)

    Thank you so much, I was about ready to give up on this computer...But #7 totally worked...My Safari is super fast now.

  • Smokey-girl Level 1 Level 1 (0 points)

    Same here...

     

    7.  Last but not least, Open System preferrences, network, select your connection and click Advanced.  Set Configure IPv6 to "Off".  Now blazing internet speeds!!!!!!!

     

    Solution worked for me too. Many many thanks!

  • SOLVEsDad Level 1 Level 1 (0 points)

    Thanks Chainjr.Your Step 7  fixed the very irritating, persistent problem for me as well, with Safari 5.06 on OS 10.5.8 PPC.

     

    Why is Apple such a lame corporation that someone from there did not provide the solution at leeast 2.5 years ago when the problem started to be raised in support forums?

  • michelle282 Level 1 Level 1 (0 points)

    Chainjr wrote:

     

    7.  Last but not least, Open System preferrences, network, select your connection and click Advanced.  Set Configure IPv6 to "Off".  Now blazing internet speeds!!!!!!!

     

    Thank you Chainjr. I was pulling my hair out trying to fix this issue. "IPv6 Off" was an instant fix. My hard drive is so quiet now it's almost spooky. I had given up on Safari and had switched completely over to Chrome because while it had been getting worse and worse over the last several months, Safari had recently ground virtually to a halt, freezing my computer, constantly churning, refusing to load anything. Now I may actually be able to use Safari again. I'm annoyed this took months to fix. I can't tell you how many things I tried - everything short of a clean reinstall (which I hadn't yet tried because several people said that didn't fix their issue either. I'm grateful I finally found this thread!

Previous 1 2 Next