Previous 1 2 Next 23 Replies Latest reply: Dec 28, 2011 1:32 AM by waybacmac Go to original post
  • JH33 Level 1 (0 points)

    I had the same problem when my iMac 10.7.1 was not mounting external HD. TRY THIS... it worked for me.

    You need to reset POWER MANAGEMENT...


    1. Shut Down your iMac

    2. Unplug everything from the back of your iMac including the power cable.

    3. Unplug power to your external HD

    4. Wait 15s

    5. Plug power back to external HD

    6. Plug power back to your iMac

    7. Turn on your iMac

    8. Wait until you see the log in screen, plug your keyboard first....

    9. Plug everything back to your iMac




    Good luck.

  • David Gnotta Level 1 (5 points)

    I have the same problem. No success with the above offered solution.


    Brand new, fully loaded BTO 27" iMac ;-) with Lion 10.7.1


    I have two 2TB G-Technolgy Firewaire drives, but the system only recogionzes one.

    Under System Profile / Firewire it shows the one drive, but says "Unknown Device" for the second one.


    Our entire iTunes Movie folder is on that drive ... help!

  • frombreda Level 1 (0 points)

    Having the same probleme with 2 x 1TB LaCie external disks. All my photos are on it. LaCie doesn't have a sollution. Neither an update of Apple .... Os X lion further works fine, but doesn't recognice the external disks. Only 2 x 500 GB LaCie external disk are recognizeble.Help!!!!

  • Jader Ivan Level 1 (0 points)

    Same problem with me..


    Just bought a brand new macbook and a brand new Toshiba Canvio 1TB usb 3.0 eternal HD and it doesnt appear in disk utility...

    It works perfect in windows...


    Illusion that mac is perfect.. a lot of problems till now, I am very disapointed.

  • Csound1 Level 8 (46,340 points)

    NTFS is a Microsoft only format, why not use exFat

  • Art Level 1 (115 points)

    The problem with Toshiba Canvio drives not mounting can be fixed by using a micro-USB2 cable. There is a known incompatibility with those drives when using a USB 3.0 cable.

  • waybacmac Level 1 (10 points)

    I've had a similar problem and seen many similar discussions. The external USB drive could not be seen by DU or anything else. Restarting my Mac (late 2011 MBP/10.7.2) and repeated plugging/unplugging/poweron/poweroff off of the drive were ineffective. That is until I started up in SAFE mode (restart holding down the SHIFT key). I then connected a different drive which did show up on the desktop. Whether this had any real curative effect I can't say but after that the original drive mounted fine.


    Since I haven't seen any better cures for this problem, I'm going to post this on other similar threads.

  • a brody Level 9 (65,410 points)


    Not a good idea.  Start your own thread.  If you just tailgate another thread, those who know how to solve them aren't likely to be able to see your thread as they only go to threads with no replies.  We ignore long threads like the plague, as we never know if our advice is going to be taken by the wrong people.   Similar symptoms can be made by many different causes.   And the original thread starter if they aren't responding, either has found a solution, or is waiting for someone to give them the solution.  When you start a thread, give it a descriptive title of the symptoms, the drive model, and operating system.


    There are numerous causes for drives to become unreadable ranging from:


    1. A bad directory.

    2. Bad permissions.

    3. Bad PRAM battery.

    4. insufficient disk space for Spotlight or Time Machine to manage it.

    5. A bad cable.

    6. Outdated firmware.

    7. Bad power supply.

    8. File system too new or too old for the operating system.

    9. Drive dying.

  • David Gnotta Level 1 (5 points)

    I have the same setup ... Fully loaded BTO iMac 27" brand new. I had been using a G-Drive 2 TB for iTunes and a bunch of architectural photos. I decided to buy a second G Drive 2TB to separate my work files from my iTunes files. But ... Once I had everything hooked up my iMac could only see one of the drives (and not the one with my iTunes library ... Agh!)


    I have played with all the suggestions .... to no avail?


    Then, grasping at straws, I decided to swap the power cord from the new drive with the one from the original drive and. ... Holy Cr@p! It works! I couldn't believe it. But I tried to older power cord on the new drive .. No go. Put the new one back I. ... Works great. Repeated the same with the older drive and got the same wonderful result.


    The odd part is that when I used the older cable the drive light did come on and I could hear the disk spin up to speed. Yet it would not mount.


    I'm sure this is some weird fluke and will probably not help to many people out there, but as it did work for me, I thought it was worth posting.

  • waybacmac Level 1 (10 points)

    Understood, brody, thanks. You are right about the many causes of drive mounting problems, but in my case I have been seeing odd things happening while migrating to Lion and, for me, they seem to point to the Finder or the file system. Files just seem to diappear. Turns out they are not really gone, just that they can't be seen. Not turned invisible in the usual sense either. Finder doesn't see them and they don't show up in the file count or space used. Day-to-day use doesn't seem to be a problem. The problems cropped up while doing lots of file changes, like when adding/deleting/moving lots of files over an extended period. Finder seems to get overloaded and cannot track the changes. Repairing permissions and a restart usually fixes things. I checked everything on the hardware side and that seems OK--ram, drive, cables, no overheating, power, etc. I've been using Macs since the original 128k machine and never saw anything like this.

Previous 1 2 Next