Previous 1 2 Next 23 Replies Latest reply: Dec 28, 2011 1:32 AM by waybacmac
Nasjo Level 1 (0 points)

I recently installed Lion osx (10.7). But after installation, my external harddisk isnt' recognised by the computer anymore... It's a HFS format disk, and in snow leopard i had no problems with the HD. My time machine partition is on it, along with other important stuff. When i plug it in, it doesn't show on my desktop, nor in disk tools or finder. I've tried waiting for hours, restarting the imac, unplugging the disk etc., but nothing works. The HD is a Western Digital elements disk. Could it be a driver problem?


iMac, Mac OS X (10.7)
  • a brody Level 9 (65,765 points)

    Are you saying it is not an HFS Extended (HFS+) disk?  HFS standard went out of date back with the release of Mac OS 8.1, and should be avoided unless communicating with older Macs than 8.1's release partly because formatted blocks are larger.

  • Eric Ross Level 6 (11,665 points)

    Try running disk utility on the hard drive to repair it, also repair the permissions.

  • Nasjo Level 1 (0 points)

    no, it's HFS+, and disk utility doesn't see the harddisk either...

  • Marcus Peaston Level 1 (100 points)

    Do you have some more details about the type of drive that you are having problems with?  WD seems to make quite a few different models under the "WD Elements" product name.

     

    My feeling at the moment is that it isn't a driver issue, not least because you typically don't have to install drivers yourself in order to access external hard drives.  I have a late 2009 iMac upgraded to Lion that is connected to a variety of hard drives both by USB and FireWire, and from different manufacturers (Seagate, LaCie and Iomega) but all seem to be quite happy mounting in 10.7.

     

    By any chance do you have anything else that you can plug into your iMac to see if it mounts correctly, such as another hard drive or even a USB memory stick?  If so, do you have any problems with that?

  • Nasjo Level 1 (0 points)

    it's a WD elements desktop 1,5 TB external harddisk (so no network or multimedia drive). I bought the Imac a month ago, and immediately formatted the external HD to HFS+, everything worked just fine. After I installed osx 10.7, the trouble started.

     

    I've tried another external HD (which is in ntfs format), and it was immediately recognised and appeared on the desktop. Also, memory sticks are no problem.

     

    When i connect the disk to a different computer (a windows pc), it is recognised...

  • Marcus Peaston Level 1 (100 points)

    Given all that you have to figure that this is a bug in Mac OS 10.7 - it certainly does not sound as though there is a fault with the drive or with your iMac. At this moment I think you ought to wait for 10.7.1 to be released (which ought to be soon) and see if that fixes the problem.

  • a brody Level 9 (65,765 points)

    Unlikely that it will.  The problem with many hard drives, and this was very apparent with Mac OS X 10.3 many eons ago, is that their firmware does not match what Apple understands to be the industry standard.  Apple rarely if ever downgrades its own industry standard spec with an upgrade.  Contact Western Digital and ask them if they have heard of other issues with the same drive on Lion.  With 10.3 it became obvious that most vendors they need to upgrade their firmware to continue to be compatible with the updated operating system. If not, you may want to use a data recovery tool to see if you can access your data*:

     

    http://www.macmaps.com/backup.html

  • Nasjo Level 1 (0 points)

    wow...does that mean i cant use my external hd with my imac ever??

  • a brody Level 9 (65,765 points)

    No it just means some models are antiquated, and need to be updated in their firmware.

  • Nasjo Level 1 (0 points)

    ok, but how do you update the firmware, if the HD can't be accessed?

  • a brody Level 9 (65,765 points)

    Its access may only be obvious once you get the firmware installer.  Once you do, then it will become visible again.  If it isn't then there is an issue with the hard drive itself.

  • duedate Level 1 (0 points)

    I have an external Lacie disk now that was not mounting with Lion. now I went back to Leopard and my mac still does not recognize the disk nor mount it.... I plugged the same disk on a mac book pro with Leopard that was never "contaminated" by Lion and the disk shows up no problem. any help out there? thank you

  • a brody Level 9 (65,765 points)

    I answered in your other thread Duedate.

  • Panthera Multimedia Level 1 (0 points)

    I have about 20 external hardisks of several brands and different sizes. After installing Lion on some Macs the disks could not be accessed. Some however had no problem at all. Among this harddisk were 3 new ones bought in the last month (the last 2 yesterday).

     

    I have learned all disks mounted without any problem when formatted FAT32 however when the were formatted NTFS, they did not mount at all.

    Using Paragon did not help with Lion even the newest version did not resolve the problem so my guess is we have to wait till Seagate cs will make new firmware, Paragon will make an update or format your harddisk to FAT32 and lose all data or take some days to copy it to another disk.

Previous 1 2 Next