Previous 1 2 Next 17 Replies Latest reply: Aug 10, 2011 1:08 AM by Lewisstudio
Tomp2 Level 1 Level 1 (10 points)

Here's what I've found. Others may want to see if their experience is the same if not already tried.

 

I installed Lion and the new Aperture upgrade two days ago. Nothing has worked properly since.

 

Yesterday, I could not open the latest upgrade of Aperture at all on my iMac (8gb Ram installed). Like all other apps, it just hung, and Force Quit caused any other app on the machine to freeze up too.

 

Today, I booted the machine in Safe Mode. Takes about 5 mins (reminiscent of having a Microsoft machine), but Aperture then opened under this method. I can see all projects and albums in the Browser view. In Split View, the thumbnails appear at the foot of the screen as normal, but the viewing pane is blank. In Viewer mode, nothing shows at all.

 

All metadata is nevertheless visible in Inspector. In Split View, running the mouse over the blank viewing pane in crop or straighten mode affects the thumbnail in the normal way - it crops or straightens.

 

So, the problem is clearly that the  version from which I would normally edit is simply missing from actual view on screen. This suggests the error is partly in the Aperture upgrade, or at least in how it displays under Lion.

 

I have been through all three of the Library rebuild processes. Neither of these made any difference to the problem. I can view and manipulate separate versions of the same photos in iPhoto, but iPhoto will not read the Aperture library.

 

Booted in normal mode, Aperture still will not open at all. It says it is accessing the Library, but the Force Quit screen (even after leaving it for 30 minutes) says Aperture is "not responding".

 

Nothing on my iMac since installing Lion will give me access to any external USB drive or memory card.

 

Anyone any suggestions, or workarounds that might move this forward, please?

 

Tom


iMac, Mac OS X (10.7)
  • Ernie Stamper Level 8 Level 8 (37,555 points)

    Tom,

     

    Not having that problem here.  Try holding down the Option key while clicking to launch Aperture.  Does it allow you to create a New Library?

     

    Ernie

  • Tomp2 Level 1 Level 1 (10 points)

    Ernie,

     

    Looks like it would. I get the drop down asking me to give the new Library a name. I have not created one, as this thing seems such a mess already. What would be your suggestion, given that I can in theory create a new Library?

     

    Tom

  • Ernie Stamper Level 8 Level 8 (37,555 points)

    I suggest following through to see if a new Library can be created -- strictly a test, which if successful would indicate there is nothing wrong with the installation of the app.  Attention would then shift to the old library.

     

    In the Finder, click on the old library, and observie whether is reported to have been used in 3.1.3, or an earlier version?

     

    Ernie

  • shuttersp33d Level 4 Level 4 (1,540 points)

    And what did you mean by:

     

    "Yesterday, I could not open the latest upgrade of Aperture at all on my iMac (8gb Ram installed). Like all other apps, it just hung, and Force Quit caused any other app on the machine to freeze up too."

     

    When you say, "Like all the other apps..." are you saying that you can't run any app on Lion? A little confusing as you say later that any other app then freezes up, as if they were running.

  • Tomp2 Level 1 Level 1 (10 points)

    In ordinary mode (as opposed to safe Mode) I can open an app like Pages, but virtually any action causes it to lock up. The Force Quit menu will then say that the app isn't responding. If I choose to force that app to quit, it quits, but all other app on my Dock freeze up at that point and won't even open. Happens every time.

     

    In Safe Mode, I can open and close apps. It is only in Safe Mode, which takes 5 mins plus to start up, that I got Aperture to open and I found the viewing problem described in this thread.

     

    I am clear that Lion is at the root of the problem, as I had full and happy functionality on all fronts until last Saturday when I made the regrettable decision to install it. However, that being so, I cannot yet rule out a bug in the new release of Aperture, as I have never yet managed to get it to do anything.

     

    Currently, the most worrying part of all of this is that even under Safe Mode, I cannot get my iMac to recognise a card reader of external HDD. This robs me of the option of moving all of the photos on my iMac to safer ground, except via something like Dropbox, which I am going to explore.

  • Ernie Stamper Level 8 Level 8 (37,555 points)

    I fear you have problems far above, and separate from Aperture.

     

    Ernie

  • Tomp2 Level 1 Level 1 (10 points)

    Yes, but consistent with what others are reporting about Lion, and in my mind there is no doubt it is Lion that is the root cause.

  • Tomp2 Level 1 Level 1 (10 points)

    Some progress today. Spoke to Apple Support, to see what they knew. Guy I spoke to was very tactful, and I am sure could have been indiscreet had he wanted, but he talked me through some stuff that has resored basic functionality. The fact that he went straight for the options he chose makes me think Apple have spotted some principal bugs already.

     

    Before downloading Lion I had given my machine a pretty thorough healthcheck. It was therfore a surprise to find a very large list of disk permissions that had become corrupted. I had not thought to check this. (Cmd-R on boot up and use the Utilities menu). Once fixed (and the only way I can see they became broken was by the Lion installation), I got back use of Finder, and all viewing options in Aperture now work.

     

    That's been as far as I have been able to go since then, but I am cautiously optimistic.

     

    Tom

  • Lewisstudio Level 1 Level 1 (0 points)

    Hi there, I seem to have got the same problems you have got. I did the permission verification clean up - still Aperture issues. What else did the Apple dude tell you?  I am desperate getting this fixed now and you seem to know how.

     

    Many thanks.

    Regards,

    Jan.

  • Tomp2 Level 1 Level 1 (10 points)

    Hi Jan,

     

    I spoke to soon, of course. When I closed the call with Apple, everything worked fine. I was unable to recreate any of the problems I had had with Aperture, Finder, or anything else. However, when I turned on my iMac next day, they were all back again, just as before.

     

    I have made two more calls to Apple support since. I have been talked through so many minor system tweaks that I have lost count - removing files from this folder and that, changing settings etc.

     

    Right now, I have just ended a call with a very knowledgeable and helful support agent, and I appear to have a fully working machine. I have been advised to test everything except Aperture very thoroughly, and if it all works, to try opening Aperture and see what happens. The Support team are going to call me again tomorrow, and if there are still issues, they will refer me to the support agents who specialise in Aperture.

     

    Stay tuned. My conclusion is that at the very least, there must be dozens of issues with which Lion is incompatible, and that we users are, of course, doing Apple's product testing for them.

     

    Tom

  • Lewisstudio Level 1 Level 1 (0 points)

    Thanks Tom for your reply. I will stay tuned.    I have a lot of photo work on at the moment and Aperture not working is causing me enormous issues. So hoping for an update.

  • Tomp2 Level 1 Level 1 (10 points)

    My situation too. I have 10,000 photos from the recent World Masters track and field championships an eager world is waiting to see!

     

    I have spent the last few hours giving my system a tough time before attempting to use Aperture. Already, I have USB HDDs that it will not recognise, and an ethernet network drive, both used for backups, that Finder will not "see", but which are there when I open the third party "Path Finder" app. Clearly a Finder fault.

     

    I am also seeing Time Machine just endlessly report that it is "preparing for backup" to an external HDD - one which Finder does show, because it has a backup from last week on it - yet no backup happens. For the moment, I have switched off automatic backups and will raise this with Apple tomorrow.

     

    All this before I get to opening Aperture. It's 10.30 pm here now. Probably be tomorrow morning before I delve into what Aperture now does.

  • Tomp2 Level 1 Level 1 (10 points)

    Well, as far as I can tell, I have a fully working version of Aperture. It even seems prepared to import from external drives. Been using it to do some sorting and editing this morning, and it has worked normally.

     

    However, my research with the apps on my iMac show the following don't open, and give error messages (see if you can spot the pattern here!):

     

    Address Book

    iCal

    iChat

    Numbers

    Pages

    Keynote

    Photobooth

    Preview (though double clicking a photo file will open it)

    QuickTime Player

    Activity Monitor

    System Profiler

     

    Yup - these are all Apple's own products. Third party apps on my machine all seem to work fine. What's the betting that Apple Support, from whjom I am supposed to be getting a call in half an hour from now, try to suggest that it is third party apps that are causing the problem.

  • Ernie Stamper Level 8 Level 8 (37,555 points)

    Sorry to see this.  Thus far I am only using Lion with apps that I directly install afresh, and have not migrated anything, as I am suspicious of the rather all or nothing approach to migration.  Your experience is probably a prime example of why I am suspicious.

     

    However, of those that are installed from the OSX install disk are working fine.  I created the boot volume I upgraded with a clean install of Snow Leopard.

     

    Ernie

Previous 1 2 Next