Previous 1 2 3 Next 32 Replies Latest reply: Feb 4, 2014 11:58 AM by Poetnerd Go to original post
  • Christopher_Hull Level 1 Level 1 (5 points)

    Chris-

    I am running 10.7.2. and, to my surprise,  I have not been successful with any of your fixes.

    I (oddly) have no pathway (~/library/mail/mail data etc..). In fact, there is no "mail" at all in "library." SO no luck there. I ran the onyx rebuild mail folder option: no luck. I went so far as to rebuild my startup by creating a startup disk on a flashdrive (needed to do this according to Onyx), yet I still have mail indicating the wrong number of unread emails. In fact, it always says "1" whether I have 20 unread emails or none. Any ideas or thoughts?

    Thanks,

    Chris

  • iamdjdmoney Level 1 Level 1 (0 points)

    Stranks.


    "MAC OS X 10.7 Lion hides the ~/Library directory by default. This is easy to reverse and show Library all the time with a terminal command:"

     

    chflags nohidden ~/Library/

     

    Try that. (Source:http://osxdaily.com/2011/07/22/access-user-library-folder-in-os-x-lion/ )

     

    Delisle (@iamdjdmoney)

  • bandit Level 3 Level 3 (875 points)

    The library is hidden. when in finder hold down the option key and go to the file menu to GO and you should see the library

  • stranks Level 1 Level 1 (0 points)

    my problem was ultimately resolved. it was an issue with the "plist" within the library.

     

    although i did try the mail>v2>mail data trick twice before i called apple care. they walked me through the plist fix.

  • Christopher_Hull Level 1 Level 1 (5 points)

    Well played guys. I located the "envelope" files and rebuilt the mailboxes. All is back to normal. I will speep better tonight!

  • John Hammer1 Level 4 Level 4 (2,805 points)

    Here's what worked for me:

     

    1- I quit out of Mail.

     

    2- I moved the Accounts.plist file from ~/Library/Mail/V2/MailData to the Desktop.

     

    3- I launched Mail and then made a sandwich while it redownloaded and rebuilt a bunch of stuff.

    -->Important: Don't panic during Step 3. You will not lose data or screw up your accounts.<--

     

    4- Once it was done working, I quit out of mail.

     

    5- I moved the saved Accounts.plist file from the Desktop back to ~/Library/Mail/V2/MailData, allowing it to overwrite the new Accounts.plist file which was creaed during Step 3.

     

    6- I launched Mail – Dock icon is now showing the correct number of unread messages total in all my accounts!

  • iamdjdmoney Level 1 Level 1 (0 points)

    John,

     

    Was just your dock count wrong? Or was your inbox folder count and dock count incorrect?

     

    I'm trying to better understand. The plist method was a fixed for one and the envelope for others.

     

    You have 2K plus points, assuming you know a thing or two ;).  What is the difference between plist method and envelope method? (one in the same?)

     

    Does everyone have multiple accounts?  I see it's hitting both IMAP and exchange.

     

    Delisle (@iamdjdmoney)

  • John Hammer1 Level 4 Level 4 (2,805 points)

    Try to not pay too much attention to points. At least in my case. I know just enough to have a grasp of how little I really understand.

     

    The method I described doesn't change the Accounts.plist file (since you put back the original as one of the last steps) so it won't help you if the problem you're experiencing is rooted in that file rather than in some other component. For instance, it won't repair the inbox folder count issue (at least, I don't think it will) but it will repair the unread-count-in-the-Dock-icon issue, which is the problem I was experiencing.

     

    FWIW, all my accounts are IMAP. In Snow Leopard, I had no issues with Mail. When I upgraded to Lion, Mail's Dock icon was displaying the unread count only for the inbox of one of my accounts rather than the total of unreads in the inboxes of all of my accounts. I just lived with it for a few weeks, but eventually it started to really bug me. I figured that deleting the Accounts.plist file would force Mail to rebuild most of everything else (which should — and did — resolve my problem) and I could then recover all my settings and whatnot by replacing the original Accounts.plist file once that was done. So I tried it and it worked. If it didn't work and/or screwed my Mail somehow, I had both a Time Machine backup I could roll back to and a bootable backup, both of which I updated just before making the attempt.

  • Christopher_Hull Level 1 Level 1 (5 points)

    So the problem is still not solved. I've done what Chris suggested below. I still have 1 unread email according to the dock icon, but there is no unread email. I even made a smart mailbox and set it fro unred messages. Nothing. Please help, this is driving me insane!!!

     

    This is what i did so far:

     

    In your library ( ~/library/ ) mail>mail data folder there are several "envelope" files, ie. envelope, envelope-shm, envelope-wal... remove these to your desktop... incase you want to put them back.

    Restart mail, it will rebuild these files probably correctly.

    If satisfied, drag the old versions"envelope" files on your destop to the trash.

     

    Alternative, OnyX is a Mac utility that has a "rebuild envelope files" option, does the same job.

  • perille Level 1 Level 1 (0 points)

    Chris's suggestion worked for me, but this annoying problem came back a few weeks after I got it back to normal... Sigh...

  • FrankiLogan Level 1 Level 1 (0 points)

    John Hammer1 steps worked prefectly for me:

     

    1- I quit out of Mail.

     

    2- I moved the Accounts.plist file from ~/Library/Mail/V2/MailData to the Desktop.

     

    3- I launched Mail and then made a sandwich while it redownloaded and rebuilt a bunch of stuff.

    -->Important: Don't panic during Step 3. You will not lose data or screw up your accounts.<--

     

    4- Once it was done working, I quit out of mail.

     

    5- I moved the saved Accounts.plist file from the Desktop back to ~/Library/Mail/V2/MailData, allowing it to overwrite the new Accounts.plist file which was creaed during Step 3.

     

    6- I launched Mail – Dock icon is now showing the correct number of unread messages total in all my accounts!

     

    Thanks John!

  • micfromvalbonne Level 1 Level 1 (0 points)

    This worked for me ! Created a smart mailbox with only unread mails and it shown up some messages from a recovered IMAP thingy. Marked all as read and voila !

     

    Thanks !

  • carty-UK Level 1 Level 1 (0 points)

    Hi all

     

    I have tried most of your suggestions and it didnt work for me so I tried something very simple - I had one mailbox showing an unread mail but no unread mail inside it, so I created a new mailbox, moved all the mails out of the old one into the new one - now there were NO unread mails showing in the new one - so I deleted the old one (still showing an unread mail but the mailbox was empty!!!) and then renamed the new one back to what the old one was called - voila - problem solved!

  • Ted Witt1 Level 1 Level 1 (5 points)

    That worked for me, too.  This is the simplest solution!

  • Christina NM Level 1 Level 1 (5 points)

    Thanks! I made a smart mailbox for unread messages and Viola! 77 unread messages. I marked as read and the problem is solved. My problem started after I restored my computer to a new harddrive with TimeMachine. This little "ghost in the machine" is finally exorcized!