8 Replies Latest reply: Apr 22, 2013 12:36 AM by bootareen
ericfromhouston Level 1 Level 1 (0 points)

Hi -  When using Safari, I frequently get an Invalid URL when accessing a popular web page (Like Google News or Yahoo). If I wait for an hour, it takes me to the page without issue.  Meanwhile, I can access these pages without any problem from other local devices.

 

I have read through a number of posts on this topic, but there is never a agreed conclusion about what is happening and how to fix it.

 

In the example above: I am accessing Google News by Going to the Google homepage and clicking on the 'News' link. I get:

Invalid URL

The requested URL "/nwshp?hl=en&tab=wn", is invalid.

Reference #9.9da41160.1312241126.593bca2d

 

Any help is appreciated. Thanks.


iMac, Mac OS X (10.6.8)
  • Set The Barr Level 1 Level 1 (0 points)

    Eric, my daughter and I both have Mac OS X 10.6.8 and we keep having this problem over and over. Did you finally get help for this? If so please tell me.

    Thanks

    Kim

  • ericfromhouston Level 1 Level 1 (0 points)

    Hi Kim,

     

    I did finally get it resolved, but it took many phone calls to Apple customer support, a re-image of the OS, swapping out library files, etc. In the end it turned out that it wasn't the OS or Mac at all, it was related to my Network settings and my Router DNS Server address - it was routing my internet searches to a bad address.  I changed the settings under System Preferences > Nework > DNS Server. I replaced the exsiting addresses with 208.67.222.222, 208.67.220.220. These were given to me by an Apple agent and have worked for me ever since.

     

    Good Luck!

    Eric

  • dewerd Level 1 Level 1 (0 points)

    Eric, just stopping by to mention that I've had the same problem for the longest time, and was absolutely baffled by it. I even thought I had a virus or malware, and spent some bucks on anti-virus software. I spent a lot of time searching the internet for fixes and nothing worked, until I came across your post. I never would have come across the solution Apple customer support offered to you. Thanks to all of th hastle and fuss you had to endour, my own problem seems to be resolved. I chnaged the DNS addresses on my machine last evening and so far, so good.

     

    Thanks!

  • Set The Barr Level 1 Level 1 (0 points)

    Eric thank you, thank you, thank you. It worked perfectly!

     

    I wanted to take some time to see if it was going to last and sure enough it has. It has been about 2 weeks and no invalid URL messages anymore. I can jump from site to site without errors. I do social media for a living and you wouldn't believe how much it slowed me down before. I would have to save everything I was doing and restart my computer at least 4 or 5 times a day.

     

    You need to post this on YouTube.

     

    Dewerd I am sure you will fine that everything is perfect with your computer now too. Eric you are the best!

     

    Kim

  • dewerd Level 1 Level 1 (0 points)

    With me it had become a chronic, hair-pulling, maddening problem. I'd have to reboot to get things straight again, but within fifteen minutes the problem would recur. With me it was usually Google and iGoogle and rarely other pages, but Google is my preferred search engine.

     

    Never in a million years would I have thought of the solution presented to Eric. What a huge relief! It's been only a couple of days but everything seems to work fine still.

     

    On a side note, this did not seem to have become a problem for me till I upgraded to 10.8. I wonder if that has somethign to do with it? It happened to my MacBook, too.

     

    The YouTube video is a great idea.

  • ericfromhouston Level 1 Level 1 (0 points)

    Wow! Glad this helped both of you!  We were equally frustrated at the time.  I'll post a YouTube video - good idea.

     

    Happy Holidays,

    Eric

  • dewerd Level 1 Level 1 (0 points)

    A lot of people seem to be having this problem, Eric. You see queries about it all over the internet, and all sorts of responses suggesting fixes that don't fix anything. That's why I was so happy to come across your post.

     

    And to date, everything is still working fine. Fingers crossed!

  • bootareen Level 1 Level 1 (10 points)

    Wow thanks Eric! Your solution worked perfectly. This problem just popped up suddenly and has been extremely aggravating.

     

    I also get these certificate issues especially from Facebook. I wonder if this fix will resolve that issue as well.

     

    Is this a temporary fix? Even though your solution works, it seems weird that we have to do this just to visit popular websites.