Previous 1 2 Next 25 Replies Latest reply: May 29, 2012 3:34 AM by onurradio
Jim Constant Level 1 Level 1 (100 points)

I upgraded my new MBP to Lion and now I can't send mail if I'm on my network at home. After looking at other threads (like this one: https://discussions.apple.com/thread/3192956) and based on the symptoms I'm having, I think the problem is likely an AT&T problem. When I use the Lion laptop on a different network, mail works and I can send mail with no problems. That suggests to me that the network is the issue.

 

I called AT&T to tell them this and they feel everything is working on their end so it must be my email client. They want to charge me to talk to tech support because I'm using an email client instead of their web interface.

 

Does anyone using AT&T have the same problem? Does anybody know how you get through to a big company like AT&T who isn't listening?


MacBook Pro, Mac OS X (10.7), 2.2 Ghz Intel Core i7
  • MotionMan Level 1 Level 1 (60 points)

    1.  Have you tried sending through the web interface while at home? (It should not make a difference, but best to eliminate all possible issues.)

    2.  Are you otherwise able to get on the internet while at home?

    3.  Do you have another device you can try to use to send e-mail at your house, like an iPhone or friend's laptop?

    4.  If using wireless, have you tried connecting to the modem via ethernet (with wifi off)?

     

    MotionMan

  • Jim Constant Level 1 Level 1 (100 points)

    Haven't tried the web interface because I'm certain it's specific to my Mac and the new Lion email client. My wife is having no problems with sending/receiving mail on her PC, my older MBP running Snow Leopard can send/receive with no problems, I can send and received with my iPhone, etc. When I take the MBP that I have the issue with to another network (neighbor's or work, for example) sending and receiving mail works just fine.

  • Kerry M Level 1 Level 1 (5 points)

    Jim,

     

    Ditto - same problem.  From home, via a Time Capsule wi fi network connected to the internet via AT&T, I can send email from all accounts (gmail, .mac) from my iPhone and from a Snow Leopard iMac.  From my Lion MBP, none will send - but they all send just fine from my Lion MBP at other wi fi networks (e.g., my workplace, McDonalds, Starbucks).  Seems like it might be AT&T.  I'm in central Oklahoma.

     

    Please post a follow up if you come upon a solution.  I won't upgrade the iMac until this is ironed out.

     

    PEACE
    Kerry

  • Ernie Stamper Level 8 Level 8 (37,550 points)

    This issue is not new to Lion, and Mail 5.0.  Several topics about it in Snow Leopard forums.  See also:

     

    http://forums.att.com/t5/Email/Email-problems-and-AT-amp-T-unresponsiveness/td-p /2699017

     

    The problem is apparently not limited to Macs and Mail.  Note the first comment by Jcullens, AT&T Internet Expert.

     

    In one of those topics, another posted the following:  " . . a couple weeks ago an AT&T tech, with whom my technician was on the phone for at least 45 minutes trying to diagnose and fix the problem, acknowledged that there had been problems on the AT&T side in the recent past."

     

    Ernie

  • Jim Constant Level 1 Level 1 (100 points)

    Hey Kerry,

     

    Believe it or not, sending mail from home seems to now be working for me. The strange thing is that when I made the change I'll tell you about, it didn't work at first, but now it does. The only explanation I can think of is that I've rebooted my machine since I made the change and that seems to have made the difference.

     

    Anyway, here's what I did. In Mail, go to File > Preferences > Accounts. Now, select the account in the left pane if it isn't already selected. In the main pane at the bottom you should see an option for TLS Certificate. Mine had 'None' selected so I opened the combo box and saw there was a certificate I could choose (just a big long string of numbers and letters). I chose that, saved my changes, and that was it.

     

    Like I said, nothing changed immediately after I did this yesterday. But this morning, I can now send mail. So either this change (and a reboot) fixed the problem for me or coincidentally AT&T fixed the issue on their side - I don't know.

     

    Give this a shot and let me know what happens.

     

    Jim

  • William Bauer Level 1 Level 1 (10 points)

    I am also having this problem (mail won't send) on a new MacBook Air running Lion.  I am able to send mail on an older MacBook Pro running Snow Leopard on the same network.

  • Kerry M Level 1 Level 1 (5 points)

    Jim, thanks very much.  I'll try this tonight and report my results.  Sounds promising.

     

    PEACE
    Kerry

  • Kerry M Level 1 Level 1 (5 points)

    Jim, your solution worked like a charm!  I am now sending emails from Mail at home via AT&T without any problems.  Many thanks!

    Peace, Kerry

  • Jim Constant Level 1 Level 1 (100 points)

    Kerry, that's great news - glad to hear it! Happy I could help.

     

    Jim

  • tracyfromsanta cruz Level 1 Level 1 (0 points)

    Jim,

     

    I have the same problem.  A question about your suggestion:

     

    What/where is the "combo box" you mention?

     

    Thanks!

    Tracy

  • jwendolo2 Level 1 Level 1 (0 points)

    My problem seems to be the reverse. Send  mail  (on Comcast) works fine on a new MacBookAir with Lion preinstalled, but not at all on a Mac desktop that's been running fine for years until the Lion upgrade. Both machines are using the same network connection and connection types, and all the settings I can see appear to be the same on both. 

    A small error message box flashes by when I try sending mail, but I haven't been able to read it or figure out if it's stored anywhere.

    I've also try multiple tricks from this post and others - frustrating!

    John

  • Jim Constant Level 1 Level 1 (100 points)

    Hi Tracy,

     

    By "combo box" I just mean what many people refer to as "drop down box". So in Mail, go to File > Preferences > Accounts. Make sure the account you're having the problem with is selected in the Accounts list on the left, then in the right pane look for the drop down box for TLS Certificate toward the bottom. It should open up and with a little luck you see the choices 'None' and a Certificate number.

     

    Good luck,

    Jim

  • Jim Constant Level 1 Level 1 (100 points)

    Hi Kerry,

     

    Is sending mail still working for you? All of a sudden, tonight, the problem seems to have returned. Sending mail just hangs.

     

    Jim

  • Kerry M Level 1 Level 1 (5 points)

    Jim, sorry to be so long in replying - it's been a hectic week, and I haven't done email from my laptop at home. 

     

    But I did note that the solution worked only for 2 days, then it stopped working!  We had a power outage from an electrical storm, so I wonder if that reset something on AT&T's side of things.  I wanted to try a few things before posting a report here, so first I tried unselecting the certificate and restarting, then choosing it again and restarting, with no improvement.  Now I've installed the latest Lion update, hoping that would fix things, but no luck.  So I'm sitting here this weekend unable to send mail through Mail.app.  Bummer.

     

    PEACE
    Kerry

Previous 1 2 Next