Skip navigation

iCal default duration - Lion Upgrade

37335 Views 94 Replies Latest reply: May 5, 2013 8:06 AM by Teri R. RSS
1 2 3 ... 7 Previous Next
Tocanostra Calculating status...
Currently Being Moderated
Aug 2, 2011 5:56 PM

Hey all, so i updated to Lion last week and now when i go to enter an event into ical it sets the default duration at 8 hours. ***? How do i fix this back to 1 hour?

iCal, Mac OS X (10.7)
  • Ferd II Level 7 Level 7 (23,235 points)
    Currently Being Moderated
    Aug 2, 2011 6:05 PM (in response to Tocanostra)

    Tocanostra,

     

    Try refreshing the iCal plist file. You will find the com.apple.iCal.plist file in your Macintosh HD/Users/yourusername/Library/Preferences Folder. To get to the Library folder use Finder>Go>Depress the "Option" Key and select LIbrary. Quit iCal, drag the .plist file to your Desktop. Then log out/in or restart.

    /___sbsstatic___/migration-images/158/15828514-1.png

    IMac 24, Mac OS X (10.7), iPad 3G, iPhone 4, 20GB iPod Color, iPod shuffle
  • Ferd II Level 7 Level 7 (23,235 points)
    Currently Being Moderated
    Aug 2, 2011 8:08 PM (in response to Tocanostra)

    Tocanostra,

     

    Your first post indicated a duration of 8 hours. The 8 hour duration was an indication of plist corruption. Since you followed the suggestion and refreshed the plist file, I surmise that it now reverts to the default behavior.

     

    For others reading this thread, events entered in the Month view without any time references will be entered as all day events. Additional event entry tips:

    1. Click Add at the top of the iCal window or press Command (⌘)-N.Events are added automatically to your default calendar.
      • If you want to choose a different calendar for the event, hold down the Add button (+), and then choose a calendar.
      • To change your default calendar, choose iCal > Preferences, click General, and then select a calendar from the Default Calendar pop-up menu.
    2. Enter a name, date, and time duration for the event, and then press Return.For example, you can enter “Super Bowl Party Feb 6,” “Movie with Rebecca on Friday at 7pm,” “Soccer Game on Saturday from 11am-1pm,” or “Breakfast with Jon,” and then press Return.
      • If you don’t enter a time duration for the event, iCal sets the event’s duration to 1 hour.
      • If you don’t enter any time information for the event, iCal makes the event an all-day event.
      • If you enter “breakfast” or “morning,” iCal sets the event to start at 9 a.m.
      • If you enter “lunch “ or “noon,” iCal sets the event to start at 12 p.m.
      • If you enter “dinner” or “night,” iCal sets the event to start at 8 p.m.
    3. To set any other event options (for example, to set your event to repeat, add an alert, or invite others to the event), make your changes in the event’s editor, and then click Done.

     

     

    /___sbsstatic___/migration-images/158/15829320-1.png

    IMac 24, Mac OS X (10.7), iPad 3G, iPhone 4, 20GB iPod Color, iPod shuffle
  • Mike Rivera Calculating status...
    Currently Being Moderated
    Aug 3, 2011 7:17 AM (in response to Ferd II)

    I correctly refreshed my plist file and if I create a new event iCal defaults to an All-Day duration and if I uncheck All-Day, it defauts to an 8 hour duration.  Really???  This can't be how it was designed to work!  I hope there's a software update soon.  Why isn't the duration a preference setting???

  • Ferd II Level 7 Level 7 (23,235 points)
    Currently Being Moderated
    Aug 3, 2011 7:30 AM (in response to Mike Rivera)

    Mike,

     

    As you describe, under those circumstances I also see the 8 hour duration.

    /___sbsstatic___/migration-images/158/15832883-1.png

    IMac 24, Mac OS X (10.7), iPad 3G, iPhone 4, 20GB iPod Color, iPod shuffle
  • Mike Rivera Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2011 7:33 AM (in response to Ferd II)

    So is there no setting to have iCal default to 30 min. or 1 hour for a new event?

  • Ferd II Level 7 Level 7 (23,235 points)
    Currently Being Moderated
    Aug 3, 2011 7:37 AM (in response to Mike Rivera)

    Mike,

     

    If I knew the answer to that question, I would not keep it secret.

    /___sbsstatic___/migration-images/158/15832985-1.png

  • Connie Mahan Level 1 Level 1 (45 points)
    Currently Being Moderated
    Aug 3, 2011 2:37 PM (in response to Ferd II)

    I'm having the same problem. Trashed plist, logged out, same issue, new events go to 8 hours (after all day is turned off). Must be a bug of some sort. Since I'm mostly interested in the start time, and work off the monthly view, this isn't a big deal for me but I trust it will get fixed since it certainly impacts daily or weekly views.

  • Maztec Calculating status...
    Currently Being Moderated
    Aug 11, 2011 6:26 PM (in response to Tocanostra)

    Please fix this or make it an option.  Nowhere does it make sense to have an event default to being all day, when you are adding an event from the calendar mode.  I schedule things out weeks at a time and have to check for a conflict, the best way to do this is to use the monthly calendar mode.  Having to change to another mode, type more, or do anything other than just click and enter is obnoxious.  Adding six more clicks to punish me for clicking on the day to add an event is even worse.

     

    This is an option that needs to exist:  "Default Event Duration in <Mode> Mode: [AllDay/1hr/30min/etc]" "Default Calendar in <Mode> Mode: [Work/Home/etc]"

     

    Thank you for attending to this.

  • robinsonsampa Calculating status...
    Currently Being Moderated
    Aug 13, 2011 1:14 PM (in response to Tocanostra)

    Hi, one more vote to fix this, it's really annoying when you type the initial time and it ends in next day.

  • LarsBruun Calculating status...
    Currently Being Moderated
    Aug 18, 2011 6:53 AM (in response to Maztec)

    Yes, I agree. I can not believe that the programmers and designers have made such a huge mistake and not continue this possibility in preferences.. Shocking...

  • Parrish Jones Level 1 Level 1 (100 points)
    Currently Being Moderated
    Aug 18, 2011 7:15 AM (in response to robinsonsampa)

    One more vote for a bug fix. Default to all day or 8 hours is nuts. Another thing. In either iPhone or iPad calendar one can select a one day prior alert. On the Mac, one does not have that selection. One has to chose 30 day and edit it. How many people need a 30 day notification for much of anything?

  • 4x4bob Calculating status...
    Currently Being Moderated
    Aug 18, 2011 11:04 AM (in response to Tocanostra)

    ical ***** now.  I like being able to put my times in manually.  I drink the apple koolaid and love a ton of stuff... I hate the ical mods.  Double click on a day for a new event and it defaults to all day? Then you have to edit, remove all day and if you change time to PM, it rolls the activity into a two day event.  ***?

  • Joe Quint Calculating status...
    Currently Being Moderated
    Aug 18, 2011 1:46 PM (in response to Mike Rivera)

    there's a terminal command for changing the default event duration. it is:

     

    defaults write com.apple.iCal 'Default duration in minutes for new event' 15

     

    the above would change the default time to 15 minutes, but any value should work.

1 2 3 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.