Previous 1 3 4 5 6 7 Next 263 Replies Latest reply: Jul 15, 2014 2:45 PM by jopaki Go to original post
  • DrVenture Level 2 (180 points)

    Well here is one issue that I can see right off the bat:


                                SSID           BSSID             RSSI CHANNEL HT CC SECURITY (auth/unicast/group)

                         Belkin.3A0D      94:44:52:67:5a:0d -57  1,+1    Y  US WPA(PSK/AES/AES) WPA2(PSK/AES/AES)

                             linksys           00:1d:7e:65:c6:22 -75  6       N  -- WPA(PSK/TKIP/TKIP)

                            2WIRE896          00:26:50:51:6d:39 -84  1       N  US WEP

                     Belkin.3A0D_EXT      22:4e:7f:2f:05:f8 -49  1,+1    Y  -- WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP)


    There are two belkin routers doing HT40 2.4GHz in the same space. I really wish AP vendors would not allow HT40 in 2.4GHz because of the limited channel space in the band. HT40 is much better suited to 5GHz band.


    You can tell HT40 is active because you can see the channel as 1 +1 (meaning the router is taking up channels 1 to 8 because it is bonding two non-overlapping channels to allow for higher speeds). Just to let you know, Apple does not support HT40 in 2.4GHz because of the limited channel space and how it can affect Bluetooth.


    The only good channel that you can use at this point is channel 11.


    Another solution would be to get a dual band router that would allow 2.4GHz and 5GHz at the same time. That way you could connect your Mac to the 5GHz band (which seems pretty open according to the scan) and still have a 2.4GHz band in case you have devices that can only use that band.



    You may also want to change the security to just WPA2 AES. Currently you are using mixed mode WPA/WPA2 but forcing AES on WPA. Since you have locked down AES, you might as well just lock it down to just WPA2 as well.

  • visitor05 Level 1 (0 points)

    To troubleshoot, then, could I just shut one of the routers off?


    I should have said up front that the ..._EXT router is actually a signal amplifier (though I imagine the machine sees it just as a router).


    Also, I have a macbook with snow leopard and another with tiger in the house and they are both fine with this arrangement.


    I'll try the channel change too.



  • visitor05 Level 1 (0 points)

    and I should add that my problem persists at coffee shops and friends' houses with wireless.

  • DrVenture Level 2 (180 points)

    You should turn off HT 40 if you control both routers. Remeber Macs and iOS debvices do not use HT40 (wide channels) in 2.4 GHz, so you are not really gaining much on the Apple side. You are also hosing up your poor neighbor who is trying to use channel 6 (since you are bonding channels 1 and 6 together). I would move the routers to channel 11 (since you have a neighbors on channel 1 and 6).


    Also you have a security mis match then because one router is configured for WPA(PSK/AES/AES) WPA2(PSK/AES/AES) and the extender is configured for WPA(PSK/AES,TKIP/TKIP) WPA2(PSK/AES,TKIP/TKIP). Like I said before, just stick with WPA2 Personal on both and be done with it.


    Also you extender is not advertising a county code (which is a little odd). Probably not a huge deal, but the CC is how wireless clients know what power tables and channels to use.

  • DrVenture Level 2 (180 points)

    What kind of AP are you using? Make, Model and Firmware?



    If you just upgraded to 10.7.2 and you lost the ability to auto connect, I would go back in and delete the PLISTS on more time and also go into your keychain and dump any password entries for you Wi-Fi network. Then reboot.


    After you have tried the above, it would also help if you did the following, open a terminal and do


    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -s


    and then


    sudo /System/Library/PrivateFrameworks/Apple80211.framework/Resources/airport -I  (that is an upper case i)


    Then paste the output here in the thread.

  • Gustos Level 1 (20 points)

    You might try to reset your System Configuration folder.


    It will delete everything your computer knows about connecting to the internet, and if you do it wrong, you will be reinstalling OSX. So back up internet settings if they are manually configured. 


    You are going to move the System Configuration folder out to the desktop.


    ***Please note:   NOT in the System Folder.  You will find similar library, preference and SysConfig folders in the System folder.  Do not do anything in the System folder.***


    It is located in:


    Macintosh HD > Library > Preferences > System Configuration (folder)


    Move the System Configuration folder to the Desktop, enter your password, and Restart the computer.

    Restarting will create a new SysConfig folder.

    Try connecting to your wifi...


    ...not the System folder

  • blazer2704 Level 1 (0 points)

    HAS ANYONE GOT AN ACTUAL FIX TO THIS its really starting to pee me off :@

  • DrVenture Level 2 (180 points)



    it is hard to try and assist you when all your post is what is seen below. Can you give us a little more information so we can try to help you?


    blazer2704 replied to Mac OS X Lion WiFi issues

    "HAS ANYONE GOT AN ACTUAL FIX TO THIS its really starting to pee me off :@"

    in Mac OS X v10.7 Lion 66 replies
    48 minutes ago
    blazer2704 replied to Mac OS X Lion WiFi issues

    "Yup I Couldnt Agree More :/"

    in Mac OS X v10.7 Lion 66 replies
    1 week ago
    blazer2704 replied to Mac OS X Lion WiFi issues

    "Yep, Whats the Plan Apple?"

    in Mac OS X v10.7 Lion 66 replies


  • ailefroide Level 1 (0 points)

    Hi everyone,

    I have a macbook air 2011 with Lion 10.7.2

    This morning I tested something:

    I just managed to get connected to my home wifi network via parallels!. When it is IMPOSSIBLE to get an IP address from my router under Lion, it seems to work flawessly if I do it from windows 7 under Parallels...

    Really weird...

    It makes me think that all these stories of security problems with WEP, WPA or whatever, is a problem of LION and not an hardware problem. Otherwise, the only way for me to get a valid IP address is to reboot my router (reboot my machine, clean the plists, stop and restart the wifi, change the DNS server etc etc... DO NOT WORK)

  • visitor05 Level 1 (0 points)



    don't know how many of my posts you've seen, but I've been experiencing the same phenomenon you speak of since late August. parallels gets on the net, Lion can't. But in my case my router is giving Lion an IP address, and I can ping sites, etc from Lion. AppleCare techs have agreed with me that it seems to be a Lion software problem, perhaps with certain routers (but I've since tried with many routers so this seems doubtful).  My routers are not optimized for mac (there are pc notebooks on my home network too) but I have adjusted them with no improvment.


    So I'm curious how similar our situations are.


    I'm using Parallels Desktop 6 -- which version do you use?


    My airport on Lion always shows a connection, it never claims to have lost it or has the !,  but Lion can't get to internet with Safari or Firefox. Does your airport / wifi indicator in the menu show that you lose connections?


    I have not heard from anyone else using parallels that Lion won't connect for them, but I have wondered if certain builds of parallels create this problem for mac.


    That said, I don't run parallels all the time and even I shut down, reboot, and never open parallels, Lion can't surf the web.


    I'm glad you've posted, hopefully our situation will be more likely to get noticed.

  • Jean Shea Level 1 (10 points)

    I'm inclined to believe it's a Lion OS issue, because I see all kinds of different routers being used in all sorts of network arrangements. If it were one of those other areas, then a pattern would emerge, or it would zero in a particular router or network setup.


    I have an Airport Extreme and was told when I bought this Mac a couple years ago that it would work just fine because the basic technology hasn't changed even if the model shape has (although I like this model shape and would hate to lose it for one of round-boxy models). My network connections have been golden since the upgrade to Leopard. As soon as I installed Lion, it went batty, and has remained so. 


    It shows up whenever I'm NOT using the internet. One indication I've learned to check is the presence or absence of the green circle on my DropBox icon in the menu bar. The Aiport icon will look like I'm connected but I'm not, but when the green circle is gone, so is my internet connection.


    That's what's so aggravating. Everything looks like you're connected until your mail program starts to warn it can't send or receive or your browser finally shows it's not connected to the internet, which doesn't always happen. I'll just get the frozen progress bar more likely.


    The question is going to be when is Apple going to fix  this, or if it will fix this. I can get by simply shutting the wifi off and on through the Menu bar icon. It's not particularly time-consuming, but if this is the indication of Apple without Steve Jobs then I guess that's GTK.


    I'm not computer literate, so all these instructions about tossing out plists or resetting IPs or going into the SysConfig areas is like being instructed on how to remove a tumor in someone's brain if you're just a laymen and you've never had any medical training. Don't think I want to try because I really don't know what I'm doing there, and everyone uses a different word to describe a certain file or folder or area of the computer.

  • Eric T. Macknight Level 1 (55 points)

    VVesa wrote:




    I made a backup of the files to my destop and deleted them from /Library/Preferences//.


    No luck. WLAN works @ home like it did before deleting the files, and @ the office WLAN does not work properly (occasionally cannot get IP of find WLAN).


    I'm using fixed LAN and waiting for the 10.7.2 to fix the problem. There's no point in wasting more time on this.

    Exactly my problem: everything fine at home, but intermittent dropouts at work. And I'm running 10.7.2, so that's not the solution.

  • moreno@milan Level 1 (0 points)

    I had the same problem with WiFi and WEP password, but now it works. How? I've just removed the password from the wifi. Without password now it works. Anyway I'm still waiting for an apple update just to set up the wifi password again . For now it's OK!

  • AppleStar Level 1 (45 points)

    rjualo, I agree 100%


    It solved my problems as well. There is definitely a hardware issue with the Airport card of the 27" (Mid 2010) iMacs that cannot be solved by software patches. It does not even matter if you are using Snow Leopard or Lion. I just didn't realize it before because I had the Mac connected via ethernet cable.


    Now I bought an inexpensive 3rd party WiFi USB card and I got no connection problems at all! It seems to be the only valid workaround for now. I spent 30 dollars and my iMac is finally online for 10 days in a row without any problems.


    I can only recomment to do the same to all people going crazy with their constant connection drops.

  • rdavo Level 1 (0 points)

    Has Apple acknowledged this problem? There seem to be so many posts, that it indicates a definite Lion cause. Certainly, that is my experinece. MacBook Pro WiFi worked fine under Snow Leopard. Now, under Lion, getting the message: "WiFi: No Hardware installed". So, this problem is caused by Apple OS-X software and they need to provide a solution Asap.

Previous 1 3 4 5 6 7 Next