9 Replies Latest reply: Aug 6, 2011 4:24 AM by The hatter
Easy Rider 1976 Level 1 Level 1 (5 points)

Hi everyone

 

I have just upgraded my mac pro early 2009 with an ATI 5870 and an extra 1gig of ddr3 ram.

All seems to be fine no problems all the ram checks out ok and is working but this utility keeps telling me everytime I boot up or log out and into another profile that the memory modules are installed in the correct slots which is really nice to know but does it have to tell me this every time as once is enough.

 

I have tried moving the memory modules around as slots 1 2 3 had the base ram installed at the factory I then added the extra 1 gig in the 4th slot and started getting the message as stated above. So I swapped the ram around with one of the base ram sticks and put one of them in the 4th slot still the same but when you remove the ram from slot 4 and boot up with 3gig of ram its all happy again.

 

So I then placed the ram in slot 4 3 and 2 leaving the 1st slot empty and the utility tells me it is the wrong configuration which is fine as thats expected as it will not give optimised preformance i just wanted to see its reaction.

 

I have phoned apple and they gave me a number for a local shop and the guy there said he has had this happen as well just make sure software and firmware are up to date and it should clear which of course they are  and I have double checked.

 

So for now I went into system on mac HD and then into core services and removed the memory slot utility and placed it somewhere else for safe keeping and it has stopped now but thats because it can't use the utility.

 

I am stumped I can't see this being hardware it seems it could be software or a bug not sure either way I am covered under warranty but I just want to get to the bottom of this other people have reported this on these forums but not mentioned how they got on.

 

My next step is to reinstall lion I have my old osx leopard cd's also and then I can reinstall everything else from scratch but this seems extreeme

 

If anyone has any ideas I would be really gratefull

 

Kind Regards

 

Martin


Mac Pro, Mac OS X (10.7), Quad Core 2.66Ghz ATI 5870 1Gig
  • 1. Re: memory slot utility
    a brody Level 9 Level 9 (63,255 points)
  • 2. Re: memory slot utility
    X423424X Level 6 Level 6 (14,190 points)

    And here's what I have to say.  Your choice.

     

    Summary - enable root and log in to allow memory slot utility to have the proper permissions to set the flag that's causing the "correct slots" message.

  • 3. Re: memory slot utility
    a brody Level 9 Level 9 (63,255 points)

    Oh my...that is different.  I should read more clearly:  " installed in the correct slots ", as opposed to incorrect slots, or incompatible.  Yes, sounds like you encountered an odd feature that I've never seen before.

  • 4. Re: memory slot utility
    a brody Level 9 Level 9 (63,255 points)

    I would say this, enabling root should only be done when you are off the internet, and are absolutely certain what files are being moved around when, and when root is finally disabled.  If you aren't, you can accidently erase your entire hard drive!

  • 5. Re: memory slot utility
    Easy Rider 1976 Level 1 Level 1 (5 points)

    Thanks for the replies and the suggestions much appreciated for now I have disabled the memory slot utility as I know the memory is installed correctly so I don't need it.

    I went into the finder then into systems and then core services and removed the memory slot utility which is no problem all fixed the only thing that does concern me is if it is a problem that needs addressing because if I need a new processor board I would rather apple pay for it while I am with applecare as those babies cant be cheap.

    My applecare service expires next september so I will keep an eye on things for now.

     

    I have done some more checks my ram is fine no problems my system checks out ok and all is running fine as it has for the past two years since I bought my mac pro.

     

    All my ram is apple certified ram and they are all equal memory modules 1gig in size each.

    Memory can be added to slots 1 2 3 no messages but any ram added to slot 4 and it tells me the memory modules are installed correctly which really warms my heart but just don't tell me this every time I boot up and log in and out it tends to get on your nerves after a while.

    Also if we do something that is not correct like put memory in slot 4 3 2 leaving slot 1 empty it then gives you a longer message telling you its all wrong and to swap them around which is fine as I did that on purpose just to see what would happen.

     

    So do you think I am worrying to much and I should just chill out on this I found my fix just take the memory slot utility out of core services and it is all fine or like X423424X said enabling root though I went for the safe option and just removed the memory utility.

     

    I know I am not alone I have searched the web and on this forum and there are others out there and everyone has different solutions the guy I spoke to at my local apple authorised reseller said he had the same thing happen but it was his firmware but that is not the case for me and others as that is all up to date and my software is also current.

     

    Do you think its a hardware issue or software is there cause for concern as these things are not cheap.

     

    Again thanks for your suggestions and comments its appreciated if anyone does find out what this is please let me know as it is playing on my mind I am one of these people who has to find the solution or cause I can't leave things be.

     

    kind regards

     

    Martin

  • 6. Re: memory slot utility
    X423424X Level 6 Level 6 (14,190 points)
    So do you think I am worrying to much and I should just chill out on this I found my fix just take the memory slot utility out of core services and it is all fine or like X423424X said enabling root though I went for the safe option and just removed the memory utility.

    You know my opinion on this -- yes you are worrying too much.   Basically you are listening to the paranoia and/or inexperience of others.   As I recently posted in the other thread you can verify this safely within 5 minutes by enabling root, rebooting, logging in as root, logging out, and doing nothing other than that.  You'll know as soon as you reboot after that whether the message is suppressed.  So much time has been wasted in this root-vs-no-root debate for want of a simple 5 minute test.

     

    As for removing a coresevice.  You may have indeed stopped the check but as soon as some apple system update comes along that updates coreservices with that app you will only have to remove it yet again.

     

    Also, like that other thread, this is my last post on this subject here too.

    Do you think its a hardware issue or software is there cause for concern as these things are not cheap.

     

    No cause for concern.  IMO it's a software issue (i.e, a bug or "feature").

  • 7. Re: memory slot utility
    Easy Rider 1976 Level 1 Level 1 (5 points)

    X423424X

     

    Thank you very much my friend I followed your advice today when I had a spare five minutes and I enabled the root user logged in and clicked on the dreaded message logged out logged in as me and then hey presto no more message I then disabled the root user as I have no more need for it.

     

    Once again thanks mate really appreciate the help it is a shame as when I was on the phone to applecare that they didnt come up with a simple solution to the problem they wanted me to take my mac into an applestore to have it checked which was why I was getting concerned they were telling me it could be hardware when it is quite clear it is not it just needed clearing through the root user as you so kindly pointed out why did they not pick up on this or my local Apple reseller I guess it needs a fresh pair of eyes.

     

    The problem is many users out there would not think to even go into the root user many don't even know what it is and apple could have talked me through that on the phone but they were not sure themselves about why the message was not clearing they should note this down for future calls for other users as I am sure this will continue to happen with the odd user from time to time depending on there set up and configuration with user accounts.

     

    Any way cheers Mate

     

    Kind regards

     

    Martin

  • 8. Re: memory slot utility
    X423424X Level 6 Level 6 (14,190 points)

    Easy Rider 1976,

     

    Your welcome.

     

    Even if apple doesn't know a answer to a question you would think they (phone help or "genius") would at least refer/suggest to those users to use apple's own discussion forums to try to get their answers.  I wonder how many apple user's out there even know these discussion forums even exist.

  • 9. Re: memory slot utility
    The hatter Level 9 Level 9 (58,880 points)

    How many try to use the Apple home page for Mac Pro support?

    That does have some links to Community threads.

     

    http://www.apple.com/support/macpro

     

    This issue with root and memory slot, and the issue with installing Lion on a 2009, are new to me, unheard of before  on this forum.