Previous 1 2 Next 17 Replies Latest reply: Apr 16, 2012 7:45 AM by Gino Cerullo
elitebox007 Level 1 Level 1

Ever since upgrading to Lion, my MacPro no longer wakes up on LAN (WOL).  Before upgrading to Lion, I could wakeup and access my MacPro by connecting to it from my MacBook Air.  For example, from my MacBook Air, I would open Finder and click on my MacPro.  Now, perfroming these steps no longer wakes up my MacPro, even when both computers are on the same network.  As a result, if my MacPro is asleep, I cannot access its files or share its screen because it won't wake up.  I must manually wake it up before I can access its resources from my MacBook Air.

 

Is anyone else experiencing this?


Mac Pro 8 core, Mac OS X (10.7)
  • Rabanthor Level 1 Level 1

    Yup, mid 2007 iMac no longer wakes after upgrade to Lion. I haven't installed latest update to my airport extreme so giving that a shot tonight.

  • nyteraine Level 1 Level 1

    I'm experiencing something similar (https://discussions.apple.com/message/16106292#16106292), but no solution yet. Maybe it is related to the new "low power wake" feature of Lion? Is there a way to disable this feature and go back to normal WOL?

  • Rabanthor Level 1 Level 1

    Still same problem here. Mostly a nuisance for me with ATV2, which doesnt wake the mac and sometimes needs a restart of itunes to see the library also.

  • JCrebbin Level 2 Level 2

    It would be worthwhile reporting this to the Apple Bug swatters: https://bugreport.apple.com/cgi-bin/WebObjects/RadarWeb.woa/wa/signIn

     

    (You need to be registered as an Apple Developer).

  • JCrebbin Level 2 Level 2

    As luck would have it - this is happening for me too now!

  • IllRepute Level 1 Level 1

    Me too. Trying to gain remote access but wake on lan is only a partial wake so my screen sharing session won't start.

  • DalekSec Level 1 Level 1

    Any news on when this will be fixed? I have had this problem ever since upgrading to Lion. I cannot connect on the same network at home, or outside of the house when my displays are asleep on my Mac Pro (I never put the hard drives to sleep). Also, I have trouble using the RealVNC app for iPad because of this.

  • Quelqu Un Level 1 Level 1

    You have to turn off the "dark wake" kernel feature in order to get the machine to come completely out of sleep mode when you send it a WoL packet.

     

    To do so, I did the following (please don't do this unless you're familiar with using vi and editing XML files):

     

    1. Opened a Terminal window.
    2. Changed to /Library/Preferences/SystemConfiguration by typing the following: cd /Library/Preferences/SystemConfiguration
    3. Edited com.apple.Boot.plist using vi under sudo (because the file is owned by root):
      1. sudo vi com.apple.Boot.plist
      2. Moved the insertion point down to the <string> associated with the Kernel Flags <key>
      3. Hit the "i" key to begin inserting text
      4. Typed darkwake=0
      5. Hit the "esc" key to exit insertion mode
      6. Typed ":wq" to save the file and exit
    4. Rebooted the system.
  • DalekSec Level 1 Level 1

    Changing the dark wake setting had no effect for me, I am still unable to wake the Mac Pro from display sleep. What is weird though, is that I can usually wake the display if I connect within maybe ten minutes, but after that I have to get up and move the mouse to wake the Mac Pro for the connection to actually establish.

  • Quelqu Un Level 1 Level 1

    DalekSec, what's your hardware setup like?  I don't know anything about RealVNC on the iPad, but all works as expected with my MacPro.  Are you sure you're sending a WoL packet to the sleeping machine before trying to do anything with it?  I use WakeOnLan to wake up machines on my network.

     

    I have a MacPro 3,1 with an ATI video card.  Before making the setting I detailed above, when I'd send it a WoL packet, it would do nothing.  Now that Dark Wake is turned off,when it's asleep, I can send it a WoL packet from anywhere on my network and it will wake up and the displays will turn on, just as if I had pressed a button or clicked the mouse.  Screen sharing works using Screen Share from my Macbook, and VNC (I use Chicken of the VNC) works too.

  • Rabanthor Level 1 Level 1

    Worked for me. Thanks

  • Quelqu Un Level 1 Level 1

    How about clicking that "Like" button on my post?  I do love gold stars.

  • Rabanthor Level 1 Level 1

    I did already? Your first post? Although my login here seems to randomly fail, asks to verify my email address over and over. Sigh. Maybe thats a problem.

    Scott

  • DalekSec Level 1 Level 1

    I'm on a MacPro5,1 OS X (10.7.3), 16gb ram, 120gb ssd (boot drive), two 2tb hard drives, and ATI Radeon HD 5870 1024 MB.

    I also have to 24" led cinema displays connected.

     

    The only way I would be sending WoL packets (I assume) is through the Screen Sharing app...

     

    Using RealVNC on my iPad, when I AM able to connect, it shows the fast-user-switching screen (lists all of the accounts on my computer) as opposed to my desktop. If I select my account and enter my credentials, it sends the login command but discconects my VNC session.

     

    Message was edited by: DalekSec

Previous 1 2 Next