Skip navigation

Autofill problems in Safari 5.1

928 Views 12 Replies Latest reply: Nov 11, 2013 7:35 PM by Kazzabaz RSS
Todd Berliner Level 1 Level 1 (5 points)
Currently Being Moderated
Aug 5, 2011 7:29 AM

Macbook Pro 2.4GHz Intel Core i5

OSX 10.6.8

Safari 5.1

 

Safari no longer Autofills blank forms.  Instead, I get a little pop up window that says "Autofill" and shows an Addressbook card icon.  When I hit "return" or "tab" (which used to Autofill the form), nothing happens.  Also, that Autofill icon does not disappear (blocking out the webpage I'm trying to read) and sometimes remains even when I progress to a new webpage.

 

Has anyone else had this problem or know how to fix it?  I have already trashed the Safari plist in preferences.

MacBook Pro, Mac OS X (10.6.8)
  • Barry Hemphill Level 7 Level 7 (33,095 points)
    Currently Being Moderated
    Aug 5, 2011 7:46 AM (in response to Todd Berliner)

    Hello:

     

    I have had the autofill work correctly in the circumstances you describe by clicking on the popup for the addressbook item.

     

    Barry

    iMac, Mac OS X (10.7), 4 GB memory,DSL
  • Carolyn Samit Level 10 Level 10 (84,130 points)
    Currently Being Moderated
    Aug 5, 2011 12:25 PM (in response to Todd Berliner)

    Quit Safari.

     

    Open Keychain Access   /Applications/Utilities

     

    Select Passwords on the left.

     

    Delete the Safari Forms Autofill keychain.

     

    Relaunch Safari. See if that helped...

  • Carolyn Samit Level 10 Level 10 (84,130 points)
    Currently Being Moderated
    Aug 5, 2011 1:07 PM (in response to Todd Berliner)

    You're welcome 

  • Peugeotguy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2011 3:54 PM (in response to Carolyn Samit)

    Dear Carolyn:

     

    I have the same problem as Todd. I did what your instructions said. However I don't have the Safari Forms autofill keychain showing up. There are 4 items in the keychain under "passwords," none of them "Safari forms autofill." Do you have any other recommondations you can offer? Thank you.

  • Carolyn Samit Level 10 Level 10 (84,130 points)
    Currently Being Moderated
    Sep 22, 2011 4:25 PM (in response to Peugeotguy)

    Make sure you are logged into your admin account.

     

    You can type in:  Safari Forms Autofill   in the search field top right corner of the  Keychain Access window. Maybe that will find it for you.

     

    And try deleting the cache.db file.

     

    Quit Safari if it's open.

     

    Open a Finder window select your Home folder in the Sidebar on the left. Then open the Library folder, then the Caches folder, then the com.apple.Safari folder.

     

    Move the cache.db file from the com.apple.Safari folder to the Trash.

     

    Relaunch Safari.

  • Peugeotguy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 22, 2011 5:57 PM (in response to Carolyn Samit)

    Carolyn:

     

    Thank you for the response. It still didn't work. After reading other posts on the subject, I'm beginning to believe that the problem is inherent in Safari 5.1. I guess we'll have to wait for Apple to fix this problem. Thanks.

  • Carolyn Samit Level 10 Level 10 (84,130 points)
    Currently Being Moderated
    Sep 22, 2011 6:01 PM (in response to Peugeotguy)

    How about...  go to Safari / Preferences then select the Autofill tab.

     

    Click the Edit button next to:  Other forms

     

    Delete the urls for sites you have problems with autofill.

     

    Quit then relaunch Safari.

     

    Try again.

     

    I'm just one user in millions but I've yet to have an autofill issue with 5.1.

  • Kazzabaz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 5:21 PM (in response to Peugeotguy)

    Hi Peugeotguy,

     

    I have the exact same problem that you and Todd had with autofill in Safari.  Get the liittle pop up suggestion, but cannot tab or click to get any further.

     

    Did you ever solve this problem?

     

    Thanks

     

    Karen.

  • Peugeotguy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 6:45 PM (in response to Kazzabaz)

    Hello Karen, not really. I decided that the 5.1 update to Safari changed this feature and won't allow us to do the auto fill-in any longer. You now get the pop window which adds an extra step when you sign up for a new website or filling out a form instead of automatically filling in your information. I also mourn the removal of this feature. Sorry not to be much help on this.  Lyndon

  • Kazzabaz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 7:35 PM (in response to Peugeotguy)

    Hi again Peugeotguy,

    Good news.

    Here is what she suggested: 

    From your Safari menu bar (top of your screen) click View > Cuatomize Toolbar

    Click and drag the Autofill icon Autofill icon Safari asc.jpg straight up to the Safari Toolabr either side of the url/search bar.

    You can click the Autofil icon from there.

     

    So I just ignore that unclickable autofill popup when it arrives and just click the newly installed autofill icon on the toolbar instead and voila, it fills all the form fields for me like it used to.

     

    Let me know if it works for you.

     

    Kind regards,

     

    Karen.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.