Previous 1 2 Next 19 Replies Latest reply: Nov 13, 2015 3:43 PM by LaurieKingdon
Alexsandr Level 1 (0 points)

I just bought a new Macbook pro with OSX Lion and I am trying to delete some old Time Machine backups from an external hard drive. I Placed the files in my trash and I cannot delete them or place them back in the original folder. When I try to empty trash it hits zero then continues on into negative numbers no matter how long I wait! The files only appear in my treash when the portable hard drive is plugged in and also when I try to find the files on my old computer to delete them through time machine itself, they are not there. What do I do? I have already tried sudo rm -rf ~/.Trash several times to no avail. Help!

MacBook Pro, Mac OS X (10.7)
  • jeremymaxwell Level 1 (10 points)

    I have done the same thing. Bought a new Macbook Pro, transferred over files from Time Machone to the new computer, but when the New Pro tried to do a back up, there wasn't enough room on the External HD (750 GB).  I went to the Apple Store and spoke to someone on the floor "Oh, just delete you older files on Time Machine" So, that's what I did, I deleted almost all of the old files. But not only has no extra space opened up on the External HD, but When I try to empty the trash, it goes from 80,000 items to delete down to zero, and up to over -100,000 items and counting.  I've stopped it twice and tried again. I've tried to move half of the files out out the trash, to no avail. I've rebooted.  What Gives? 

  • MarkSam Level 1 (0 points)

    I'm stuck with the same problem. Just hit -200K in trash being deleted, wish no signs of slowing down. Does it ever stop? Does the trash actually empty?


    I've already moved the Time Machine Backups to the trash folder, so I'm probably kind of screwed at this point, but I wanted to start fresh with my Time Machine on the new laptop, so I dragged the files I needed and axed the rest. Any additional info on whether this eventually goes away would be great. Thanks.

  • jeremymaxwell Level 1 (10 points)

    I spent an hour working through every fix possible on the Phone with Apple support: Secure Trash Empty. Trash Empty while holing down "Option". Shutting down and opening in safe mode. Shutting down and holding various buttongs down when restarting.  Finally They had me try some third party apps: Trash it (didn't work), Can Man (couldn't find it), Delete it (wouldn't run), and stubborn file remover (seems to be a pc program, agian, couldn't run it).

    When I ejected the Time Machine HD from my Macbook, the files I was trying to delete from the Trash disappeared, so we cam to the conclusion that I was gonna have to reformat the Time Machine HD and start from scratch.  I went to the Genius bar anyway, and after confounding everyone with how high the negative numbers went (-500,00 and counting), the Erase and reformat move was all that was left. 

    That worked fine, and I'm just glad I had the data spread onto another External HD and the New MacPro.  Nobody wwas able to explain to me what and why this happenend except that it was probably a snow leopard/ lion issue combined with dragging the files to the trash instead of deleting from "inside" Time Machine.

  • FMezler Level 1 (0 points)

    I don't know if this will work for you, but it fixed it for me.


    I disconnected my external USB drive from my Mac and plugged into my MacBook Air - yea, unfortunately you are going to need a different Mac. Then I opened the Finder on my external drive. On my MacBook Air I had to turn on the hidden files by going into Terminal and typing the following command:


    defaults write AppleShowAllFiles -bool true


    then enter the command


    killall Finder


    That showed the hidden files on my external drive. I selected Get Info on the .Trash and changed the permissions to Read and Write for me. Then I renamed it .Trashed. Ejected it from my MacBook Air and plugged it back into my Mac. That was it - the trash on my Mac was empty!


    To get the hidden files so they don't show again, just enter the same command, but change true to false.


    Some may say that the files never deleted off the drive or whatever, but I could care less - it was the trash on the Mac I need emptied - not the external drive.

  • Badunit Level 6 (11,520 points)

    If there is nothing else on your external drive, reformat it.

  • anders.blomberg Level 1 (0 points)

    I had the same issue. Although the solution was of the simplest kind. I could tell the computer was working as the numbers kept growing (into the negatives) so I let it work. Easy as that.


    The backup files were roughly 600 GB. While emptying the thrash the numbers kept growing to roughly minus two million  (- 2 000 000) files. Took ≈ 8 hours. No problem though as I've been working on the computer all day and the process ran fine in the background.

  • Level 1 (0 points)

    Seriously, I had the same problem just now, I simply disconected the external hard drive (g-raid) by ejecting it then I just empty the trash, that worked for me.

  • Topher Kessler Level 6 (9,865 points)

    The sudo rm -rf ~/.Trash command will not work on an external volume, because it targets the trash folder within your user account. Each external volume contains its own hidden ".Trashes" folder for the files on it, so you can perform this action by running the following version of the command:


    sudo rm -rf /Volumes/"TIME MACHINE DRIVE"/.Trashes


    In this command, replace the TIME MACHINE DRIVE text with the name of your Time Machine volume (keep the quotes around it if it has a space in the name), and then run the command to remove the trashed files on the external volume.


    You might notice that if you eject the Time Machine volume the files in the trash will disappear, and then reappear when you re-attach the volume. This is because the files are located in the volume's .Trashes folder ("Trashes" as opposed to "Trash" because it holds all the volume's individual trash folders for each user account on the system).

  • Mark Jalbert Level 5 (4,630 points)

    sudo rm -rf /Volumes/"TIME MACHINE DRIVE"/.Trashes


    The following command will remove a users files in the ./Trashes/<userid>/ directory and is alot safer->

    rm /Volumes/"<VolumeName>"/.Trashes/$UID/*


    If the ./Trashes/<userid>/directory has folders in it then you would use the -R option with reservation->

    rm -R /Volumes/"<VolumeName>"/.Trashes/$UID/*


    As a last resort then remove the directories inside the .Trashes directory->

    sudo rm -R /Volumes/"<VolumeName>"/.Trashes/*
  • Michael Fox3 Level 1 (5 points)

    I had this problem after switching Time Machine disks.  I wanted to delete the old time machine files.  They wouldn't delete.  It would run for hours and hours, then start with the negative numbers for hours and hours, then ultimately left everything where it was.


    So, I followed the above advice and it worked:


    sudo rm -rf /Volumes/"<VolumeName>"/.Trashes/$UID/*




    Thank guys.

  • unMike Level 1 (0 points)

    Michael Fox3: Your suggestion worked for me. Thanks!

  • GRJP Level 1 (0 points)

    anders.blomberg gave the solution; as long as the numbers are moving, it is deleting files from those old backups. There really are millions of files if you are deleting months of complete backups and it does eventually reach the end of the process.


    However, it is much faster to use the original computer from which the backups come to delete them from within time machine.

  • mcmorry Level 1 (0 points)

    For me it worked only:


    sudo /System/Library/Extensions/TMSafetyNet.kext/Helpers/bypass rm -rf /Volumes/"<VolumeName>"/.Trashes/$UID/*


    Without bypass I got only thousands of "Operation not permitted"

Previous 1 2 Next