Previous 1 2 3 Next 38 Replies Latest reply: Mar 4, 2014 3:38 PM by Alan Rogers
mp3 Andrew Level 1 Level 1 (35 points)

Since I have upgraded to OS X Lion and Mail 5, I have noticed that the "new message" sound is not playing when I receive a new email.  I have checked the settings, and the option for this is enabled.  I am using Gmail and have the "idle command" option enabled, and I suspect that this may be involved in the issue.

 

I have read that in the past Mail had an issue where it would only play the "new message" sound if it had received the new message by polling the server.  If the new message was received through the "idle" command, then the "new message" sound would not be played.  Perhaps this is the same bug.

 

Is anyone else having this issue?  I know I could just turn off the "idle" command, but I'm looking for an actual fix to the underlying issue.  I've reported it to Apple, but I would like to see if anyone else has noticed this.


MacBook Pro, Mac OS X (10.7), Mail 5
  • thomas_r. Level 7 Level 7 (29,580 points)

    Mail 4 did indeed have such an issue, but Mail 5 has fixed it for me.  (Whether it's a "fix" I haven't decided yet...  it's nice when I'm waiting for a message, but very distracting when I'm working.  My somewhat OCD personality can't just leave the e-mail there un-looked-at.)

     

    Have you tried changing the sound that gets played?  Perhaps there's a problem with the one you have selected.

  • mp3 Andrew Level 1 Level 1 (35 points)

    I was about to try your suggestion, but after sending a few more test emails, I discovered that it does in fact play the sound sometimes.  I sent about 20 test emails, and they were all received using the "idle" command, with about 75% of them playing the sound.  There was a 5-10 second delay between the messages being received and the sound playing that I don't remember from Snow Leopard, but I'm not positive about that.

     

    It shouldn't be the actual sound that is the issue, being that it is played sometimes, but I still don't know why it's not playing every time.  I tried receiving messages with the app running in the background, with it minimized, and with it as the active window, but I couldn't find any specific instance that caused it to not play the sound.

     

    I wasn't having this issue in Mail 4.  It didn't start until I installed Lion, which I did a clean install of, if it matters.

     

    I'm still open to thoughts on this, and thank you for your help.

  • Peter Harrison Level 1 Level 1 (10 points)

    This had been annoying me since I upgraded my iMac to Lion. After scanning the comments about similar problems, the following suggestion from another thread on sound problems with Lion seems to have fixed the problem:

     

    "Success - in the Audio Midi Setup (Applications/Utilities) I changed the output to 2ch - 32bit Float and all the audio works well."

     

    The really weird bit was, as reported in yet another post on sound problems with Lion, all the send/receive sounds for all the messages I had sent/received since installing Lion then played, one after the other, like they had been queued at the time, but not played until I changed this setting...

  • russcus Level 1 Level 1 (0 points)

    I wonder why my Audio/MIDI utility does not include "2ch - 32bit Float." I only see 2-ch 16-, 20- and 24-bit integer.

  • mp3 Andrew Level 1 Level 1 (35 points)

    I would guess that your hardware doesn't support it, though my early 2011 MBP doesn't show that option under output either.  It is available under input, but I don't think that's relevant.  Maybe Peter Harrison can tell us what Mac model he is using.

  • Peter Harrison Level 1 Level 1 (10 points)

    Yeah, I thought that was going to be shown on my response, but it seems to only appear on the original post. I'm using a Core i7 iMac (27", 2.8 GHz, just in case that makes any difference), running OS X 10.7.2, Audio MIDI Setup 3.0.4. I also have a Core i7 MacBook Pro, running OS X 10.6.8, Audio MIDI Setup 3.0.3, and that also includes a 2ch-32bit mode (although it doesn't actually identify the modes as integer or float).

  • mp3 Andrew Level 1 Level 1 (35 points)

    What size is your MBP? Mine is a 13" Core i7.  I'm not sure if it matters, but maybe the smaller Macs don't support 32 bit.

  • Peter Harrison Level 1 Level 1 (10 points)

    Mine's a 15" unit (May 2011). I note that one difference between the 13" and larger screen models is that the latter include AMD Radeon graphics co-processors (as do the current iMacs). From the specs, I note that these co-processors include "a HD audio controller to transmit HD Audio over HDMI and DisplayPort".

     

    So it's probably as you suggest—the 2ch-32bit mode will only be there as an option is the reelvant hardware supports it.

     

    Just for the heck of it, I just tried changing my (Audio MIDI Setup) setting to 2ch-24bit Integer, and the sound was still OK. The 'bug' may be such that you just need to change this setting to something else... It's probably worth a try.

  • mp3 Andrew Level 1 Level 1 (35 points)

    Good observation.  That sounds like the most plausible explanation to me.  Just out of curiosity, what is your output format set to?  Mine's at 44100 Hz, but it goes up to 96000 Hz.

     

    As for the original issue I posted about, it seems to have resolved itself, though I followed your advice just for good measure.  Hopefully this will help anyone who may still be having this problem.  Thank you for your assistance.

  • Peter Harrison Level 1 Level 1 (10 points)

    Mine's just on 44100 Hz, which must be the default, 'cause I've never been near this stuff before.

  • Peter Harrison Level 1 Level 1 (10 points)

    I just discovered that this stopped working some time in the last 24 hours. Back to Audio MIDI Setup, change the setting back to "2ch - 32bit Float", and I get the stream of sounds from all the email since whatever this problem was occurred again...

     

    Just changing the setting seems all that's required, so, at the moment, it looks like a genuine bug to me—something gets hosed, and a change resets the system, flushing whatever is doing the hosing.

  • Peter Harrison Level 1 Level 1 (10 points)

    This is becomming a regular occurrence now. The sound was off again this morning. Change the Audio MIDI Setup setting, and out they all come again.

     

    The sounds are all being queued, but for some reason the queue gets stopped periodically. Maybe there's a bug in Mail's [internal, as in Objective-C] notification system.

     

    It'd be nice to have a permanent fix...

  • Nut Village Ferenc Level 1 Level 1 (0 points)

    I goggled my way overhere, as I'm having the same issue.

     

    Just tried the suggestion halfway this thread: changing the output parameters in the Audio/MIDI window, and the queue gets a shove: all sent/new mail alerts since way back get played one after another. Very funny, actually.

     

    May 2011 13" MBP (Europe), upgrade to Lion from Snow Leopard btw.

     

    Cheers all, hope this helps someone.

  • mp3 Andrew Level 1 Level 1 (35 points)

    I would encourage everyone experiencing this issue to also submit feedback to Apple through the Mail application menu option.  Thanks for your continuing input.

Previous 1 2 3 Next