11 Replies Latest reply: Mar 29, 2012 5:54 AM by Dahlex
Rettoc Level 1 (0 points)

When i close down my mac book pro, it doesn't remember the settings and each time I open it up i have to close down apps and manually change to the settings I want.  The particular one that annoys me is the screen brightness, which i continually have to change, it also doesn't remember settings that I have made within programmes such as CS5 and word.

MacBook Pro, Mac OS X (10.7)
  • Barry Hemphill Level 8 (37,155 points)



    Try resetting the PRAM and SMC - might help.



  • Rettoc Level 1 (0 points)

    Barry, as a non techie, what is PRAM and SMC please?

  • Barry Hemphill Level 8 (37,155 points)



    Sorry.  I use acronyms so often, I sometimes forget to explain a bit more. 


    Here are the instructions for resetting the PRAM and SMC (the articles have a brief description of their functions):






    In situations like yours, resetting those sometimes helps.  In any event, resetting them will not harm anything.



  • Rettoc Level 1 (0 points)

    None of this worked, so am going to remove Lion it's too buggy!  Where do I go to find out how to reinstall snow leopard?

  • Jay.JayDub Level 1 (0 points)

    Did you get this fixed, or did you uninstall Lion?  I am having the same issue and would love to have it fixed!!

    Namely, Lion doesn't remember the settings for key backlighting and for items in finder to be dated with a non-relative date.




  • Rettoc Level 1 (0 points)

    As I said in my response to Barry, none of the fixes worked.  I searched long and hard to find an answer, but nothing seemed to work.  Additionally to the above, my imac wouldn't shut down, it just hung and I had to use the power button to force it to shut down, not good.

    In the end I did a fresh re-install of Snow Leopard and I am now back to loving my mac.  I won't install Lion until I am completely reassured that it will work as described.

  • tasi2006 Level 1 (0 points)

    I am having the same problem


    somebody help plz

  • Eleonora. Level 1 (0 points)

    I think I'm having the same problem. I have to set my wacom settings every time I startup. As an additional problem; I just edited a video (and saved the project lot's of times) but what I saved just seems to be gone?

  • Dahlex Level 1 (0 points)

    It's starting to be an old post, but there were no answers so it's basically still open. I started having the same issues out of the blue a couple of days ago. MBP always restarts with the same apps and same safari page even though I quit everything before shutting it down. I have an appointement with an Apple Genius this afternoon, I'll report back here and on my post here.

    I spent a considerable amount of time trying to figure this out but to no avail. What seems to be strange is that the same problems (but not all) started on my iMac around the same time.

  • Rettoc Level 1 (0 points)

    Dear all,

    I have now, with some trepidation, gone back to Lion and am using it without any issues.  I did some research before doing so and first of all made sure the there were no problems with my disk by going to the disk utility and verifying the disk.  I then downloaded Lion, and before installing it turned off my antivirus (Kaspersky).  Once it was up and running I encountered a problem with my macbook pro, it wouldn't shut down, it just hung as before and so I did two things 1.  removed all of the junk from my system using Cleanmymac and 2. I went to System Preferences, General and unchecked the "Restore windows when quitting and re-opening apps".

    Everything on my imac and macbook now works without issue (but I still have my fingers crossed).

    The main reason for going back to Lion is the next version, Mountain Lion, is due out later on this year and I didn't want to miss out just because I had done something wrong.

  • Dahlex Level 1 (0 points)

    Report of my encounter with an Apple Genius. Good news is, it's not a hardware problem but software. The installation of an app messed up the permissions too badly/agressivly/deeply. Something went wrong somewhere. Unfortunatly there was no way to tell which application caused that.

    One command line I saw him tried was 'sudo rm -rf ~/.Trash', but didn't solved the problem. They have multiple tools at the Apple Store unavailable to us and none of them worked.

    First thing that tipped him off was when rebooting in safe mode (holding shift key while the computer starts), there was no problem. Safe mode, if I understood him correctly, starts the OS with just the essentials to be running. There was no problem with the essentials, so it had to be one of the program I installed. Second thing he did to confirm is creating a test account to see if the problems were still there. They were not.


    Two things were possible to solve it, nuked the HDD and start over, or create a new admin account, transfer everything over there and delete the first. I chose the second option. Now everything works fine.


    If I had to guess, it's probably Git (dev tool for version control) that messed up something. I am now extra carefull before installing it. Soon I'll even install the OS on an external drive and test everything on it before intalling something.